
  









<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.mtexpress.com/content/tncms/live/" />
<meta name="keywords" content="environmental volunteering, sawtooth national recreation area, idaho conservation league, national forest foundation, sawtooth society, litter, outdoors, outdoor tourism, idaho outdoors" />
<meta name="news_keywords" content="environmental volunteering, sawtooth national recreation area, idaho conservation league, national forest foundation, sawtooth society, litter, outdoors, outdoor tourism, idaho outdoors" />
<meta name="description" content="A self-guided project to address months of heavy traffic and littering in the Sawtooth National Recreation Area will begin on Sunday, Sept. 12, with volunteers in high demand." />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="googlebot" content="noarchive" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.mtexpress.com/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=840%2C630" />
<meta property="og:image:width" content="840" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Volunteers sought in SNRA cleanup" />
<meta property="og:description" content="A self-guided project to address months of heavy traffic and littering in the Sawtooth National Recreation Area will begin on Sunday, Sept. 12, with volunteers in high demand." />
<meta property="og:site_name" content="Idaho Mountain Express Newspaper" />
<meta property="og:section" content="Community" />
<meta property="fb:app_id" content="135817296433862" />
<meta property="article:publisher" content="https://www.facebook.com/MountainExpress/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@IdahoMtExpress" />
<meta name="twitter:image:alt" content="Sawtooth Valley, smoke" />
<meta property="tncms:subs" content="2.0" />
<meta property="tncms:ads" content="refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.ad27c9f77605d024db8c365716c30e23.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.da34fee69fbd9a506f70c74c56e2ccfa.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/live/global/resources/styles/site.css?_dc=1455636824"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,600%7CDroid+Serif:400,700%7CNews+Cycle:400,700"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.59.3"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"banded","style":"default","path":"\/wood_river_journal\/community","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"asset":{"presentation":null,"start_hour":"11","id":"2594e858-0c15-11ec-b042-efe19fb3f72b","app":"editorial","ga_page":"\/wood_river_journal\/community\/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"},"infinity_scroll":{"display":"summary_siderail","order":"latest"},"vendor":{"outbrain":"disabled","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":373},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-56941017-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms/subscription.js"></script>
<script>/*<![CDATA[*/ TNCMS.Subscription.initialize({"service_id": "3787,7650,3806,3793,3786,3794,3795,3796,3812,7488,4550", "prefix": ""}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.440cdcae2c3272df39c09befc9eb3dd6.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/ads/impressions.js?_dc=1630634714"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/ads/traffic.js?_dc=1630564511"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/ads/settings.js?_dc=1613517699"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.status.828de94349981272665c0fb0107f3e49.js"></script>
<script>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</script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/ads/fixed-big-ad-top-asset/1.js?_dc=1629815844"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/ads/fixed-big-ad-top/1.js?_dc=1630497665"></script>
<script>/*<![CDATA[*/ window.poll_config || (window.poll_config = []); window.poll_config.push({"id":"ed9ff512-0aa4-11ec-bfd6-e76e372a62b0-1210186","asset_id":"ed9ff512-0aa4-11ec-bfd6-e76e372a62b0","title":"What\u2019s your favorite part of Labor Day?","url":"\/opinion\/poll\/what-s-your-favorite-part-of-labor-day\/poll_ed9ff512-0aa4-11ec-bfd6-e76e372a62b0.html","results":"https:\/\/www.mtexpress.com\/opinion\/poll\/what-s-your-favorite-part-of-labor-day\/poll_ed9ff512-0aa4-11ec-bfd6-e76e372a62b0.html?action=poll:results&format=json","chart":"bar"}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/ads/fixed-big-ad-middle/1.js?_dc=1629325008"></script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"bg_color":"#ffffff","heading_bg_color":"#ffffff","heading_tag":"h4","heading_text_color":"dark","require_user_account":"","signup_lists_only":"1","note":"","links_position":"top","text_color":"inherit","list_ids":"","sign_up_text":"Sign up","manage_button_text":"Manage your lists","show_select_all":"","show_audience":"","hide_audience":"","block_id":"1210282"}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>Volunteers sought in SNRA cleanup | Community | mtexpress.com</title>
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.mtexpress.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/14cc261c-ef9c-11e5-8918-535c37aa0e67.png?resize=180%2C180" />
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Volunteers sought in SNRA cleanup | Community | mtexpress.com" href="http://www.mtexpress.com/search/?f=rss&amp;t=article&amp;c=wood_river_journal/community&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.mtexpress.com/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.3aa64d478db9cdd63e9d4b159e0c9334.js"></script>
            
   
    
        </head>
        <body class="app-editorial grid-banded blox-asset uuid-2594e858-0c15-11ec-b042-efe19fb3f72b  section-wood-river-journal section-community type-article infinity-summary-siderail" data-path="/wood_river_journal/community">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.mtexpress.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.59.3&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=banded&amp;tncms.page.style=default&amp;tncms.page.path=%2Fwood_river_journal%2Fcommunity&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.asset.start_hour=11&amp;tncms.asset.id=2594e858-0c15-11ec-b042-efe19fb3f72b&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fwood_river_journal%2Fcommunity%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html&amp;tncms.infinity_scroll.display=summary_siderail&amp;tncms.infinity_scroll.order=latest&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=blox&amp;tncms.system.render_time=373&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.google.ua=UA-56941017-1&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.mtexpress.com",
  secureDomain: "mtexpress.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        
        <script>
    (function() { 
        var ARTICLE_URL = window.location.href; 
        var CONTENT_ID = 'everything';
        document.write(
            '<scr'+'ipt '+ 
            'src="//survey.g.doubleclick.net/survey?site=_furuh2j6ras66vpwrwoeisuq6e'+ 
            '&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
            (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
            '&amp;random='+(new Date).getTime()+ 
            '">'+'\x3C/scr'+'ipt>'
        );
    })();
</script>

        <script>
            document.addEventListener("DOMContentLoaded", function(event) {
                __tnt.metering.access.d.push(function(){
                    //DMP logging
                    if(window._cc){
                        __tnt.log("Logging DMP data")
                        var paywallDmpData = 'Paywall : Viewed Paywall';
                        // Call to cms.dmp.js_behavior_action is here
                        
                    }
                });
            });
        </script>
    

    <div id="template-metering" data-message-mode="basic">
    <template class="template meter subscription">
        <div class="meter message" data-message="blox regissub subscription wall">
        <div class="wall panel panel-default">
            <div class="panel-body">
                <h4 class="meter-heading media-heading">
                    Thank you for reading!
                </h4>

                <p>Please purchase a subscription to read our premium content. If you have a subscription, please log in or sign up for an account on our website to continue.
</p>

                
                <div class="col-xs-12">
                    <div class="pull-right">
                        <a class="btn btn-default btn-block meter-modal-open">Purchase a Subscription</a>
                    </div>
                </div>
                
            </div>
        </div>
        </div>
</template>
    
    <template class="template meter registration">
        
    <div class="meter message wall panel panel-default" data-message="blox registration wall">
        <div class="panel-body">
            <h4 class="meter-heading media-heading">
                Thank you for reading!

            </h4>
            <p>Please <span class="not-logged-in">log in, or sign up for a new account</span> to continue reading.</p>

            <div class="col-xs-12">
                <div class="row not-logged-in">
                
                    <div class="col-xs-6">
                        
    <a  class="btn btn-default btn-block" href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">Sign Up</a>
                    </div>
                    <div class="col-xs-6">
                        
    <a class="btn btn-primary btn-block" href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">Log In</a>
                    </div>
                </div>
                
                <div class="row logged-in">
                    <a class="btn btn-default" href="https://www.mtexpress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.mtexpress.com%252Fwood_river_journal%252Fcommunity%252Fvolunteers-sought-in-snra-cleanup%252Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">Purchase a Subscription
</a>
                </div>
            </div>
        </div>
    </div>
</template>
    
    <template class="template meter referred">
        <div class="meter notification referred alert alert-dismissable alert-info" data-message="blox user referred">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
         
        <p><strong>Thank you for reading!
</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    
    
    <template class="template meter access" data-count="1">
        <div class="meter notification access alert alert-dismissable alert-info hidden-print" data-message="blox first free">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
         
        <p><strong>Welcome!</strong> We hope that you enjoy our free content.</p>
    </div>
</template>
    
    <template class="template meter access" data-count="5" data-registered="false">
        <div class="meter notification access alert alert-dismissable alert-warning hidden-print" data-message="blox login prompt">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        
        <p><strong>Thank you for reading!
</strong> On your next view you will be asked to <span class="not-logged-in"><a class="alert-link" href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">log in</a> to your subscriber account or <a class="alert-link" href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">create an account</a> and subscribe</span><span class="logged-in"><a href="https://www.mtexpress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.mtexpress.com%252Fwood_river_journal%252Fcommunity%252Fvolunteers-sought-in-snra-cleanup%252Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">purchase a subscription</a></span> to continue reading.</p>
        </div>
</template>
    
    <template class="template meter access" data-count="5">
        <div class="meter notification access alert alert-dismissable alert-warning hidden-print" data-message="blox last free">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for reading!
</strong> On your next view you will be asked to <span class="not-logged-in"><a class="alert-link" href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">log in</a> to your subscriber account or <a class="alert-link" href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">create an account</a> and subscribe</span><span class="logged-in"><a href="https://www.mtexpress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.mtexpress.com%252Fwood_river_journal%252Fcommunity%252Fvolunteers-sought-in-snra-cleanup%252Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">purchase a subscription</a></span> to continue reading.</p>
    </div>
</template>
    
    <template class="template meter access" data-registered="true" data-after-wall="true">
        <div class="meter notification alert alert-dismissable alert-info" data-message="blox after login">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for signing in!</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    
<div id="subscription-modal" class="subscription metering-modal modal fade" data-message="blox modal subscription">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="modal-title">Support journalism you can trust about the valley you love.</h4>
            </div>

            <div class="modal-body">
                <div class="row">
                    <div class="col-xs-12">
                    <div class="not-logged-in">
                            <p>Thank you for reading! Please purchase a subscription or log into an existing subscription to continue reading the Idaho Mountain Express.</p>
                           <span class="sitelogo"></span>
                       </div>
            
                        <div class="logged-in">
                            <div class="no-services" style="display:none">
                                <p>Thank you for reading! Please purchase a subscription or log into an existing subscription to continue reading the Idaho Mountain Express.</p>
                               <span class="sitelogo"></span>
                            </div>
                
                            <div class="has-services" style="display:none">
                                <p>Your current subscription does not provide access to this content.
</p>
                            </div>
                        </div>

                        <div class="col-xs-12">
                            <div class="row not-logged-in padding-bottom">
                                <div class="col-xs-6">
                                    <a class="btn btn-primary btn-block" href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">Subscribe</a>
                                </div>
                                <div class="col-xs-6">
                                    
    <a class="btn btn-default btn-block" href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">Log In</a>
                                </div>
                            </div>
                        </div>
                    <div class="col-xs-12">
                            <div class="row logged-in">
                                <div>
                                    <a class="btn btn-default" style="background-color: #bb112d; border-color: #bb112d; color: #fff;" href="https://www.mtexpress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.mtexpress.com%252Fwood_river_journal%252Fcommunity%252Fvolunteers-sought-in-snra-cleanup%252Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">Subscribe</a>
                                </div>
                            </div>
                            </div>
                        
                        
                    </div>
                </div>
            </div>
            <div class="modal-footer">
                
            </div>
        </div>
    </div>
</div>

<script>
var promoOpenedFromModal = false;
$(function(){
    $('#service-promo-open').on('submit',function(){
    
        if($('#service-promo-open').find('input[name=promo]').val()!=""){
            $('#service-promo-modal').find('input[name=promo]').val($('#service-promo-open').find('input[name=promo]').val());
            $('#service-promo-modal').find('.promo-loading').show();
    
            if($('#subscription-modal').is(':visible')){
                $('#subscription-modal').modal('toggle');
                promoOpenedFromModal = true;
                setTimeout(function () {
                    $('#service-promo-modal').find('.modal').modal('toggle').submit();
                },500);
            }else{
                $('#service-promo-modal').find('.modal').modal('toggle').submit();
            }
       }
    
        return false;
    });
    
    if($("#service-promo-open").find("input[name=promo]").val()!=""){
        setTimeout(function () {
            $("#service-promo-open").find("button").click();
        },500);
    }
    
});
</script>

<form id="service-promo-modal" class="" method="post" action="https://www.mtexpress.com/content/tncms/live/" data-endpoint="https://www.mtexpress.com/tncms/subscription/services/?promoCode=">
    <input type="hidden" name="serviceid" value=""/>
    <input type="hidden" name="referer_url" value="/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"/>

    <div class="modal fade">
        <div class="modal-dialog">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></button>
                    <div class="form-group">
                        <label class="" for="promo">Have a promo code?</label>
                    </div>
                    <div class="form-group">
                        <div class="input-group">
                            <input type="text" class="form-control" name="promo" placeholder="Enter Code" value="">
                            <span class="input-group-btn"><button type="submit" class="btn btn-primary">Find Offers</button></span>
                        </div>
                    </div>
                </div>
                <div class="modal-body">
                    <template class="template promo-not-found-template">
                        <div class="promo-not-found-warning alert alert-warning">
    <p><strong>Sorry</strong>, no promotional deals were found matching that code.</p>
</div></template>
                    <template class="template promo-found-message-template">
                        <div class="promo-found-message alert alert-success clearfix">
    <p><strong>Promotional Rates</strong> were found for your code.
    
    </p>
</div></template>
                    <template class="template promo-error-template">
                        <div class="promo-error alert alert-warning">
    <p><strong>Sorry</strong>, an error occurred.</p>
</div></template>
                    
                    <div class="row">
                    <h2 class="promo-loading text-center font-larger" style="display:none;"><span class="fas tnt-spinner tnt-spin"></span></h2><div class="col-xs-12 service-promo-status-message"></div>
                    <div class="col-xs-12 output"></div>
                    </div>
                    
                    <template class="template-promo-service hide">
                        <div class="promotion-service subscription-service panel panel-default">
                            <h3 class="panel-heading"></h3>
                            <div class="panel-body">
                                <div class="service-note alert alert-info"></div>
                                <p class="description"></p>
                                <div class="rate-output"><p class="hide">do not remove</p></div>
                            </div>
                        </div>
                    </template>
                    <template class="template-promo-rate hide">
                        <div class="promotion subscription-service panel panel-default">
                            <div class="panel-body">
                                <h4 class="rate-name"></h4>
                                <div class="clearfix">
                                    <span class="pull-left">
                                        <div class="terms-automatic">
                                            <strong><span class="price"></span> <span class="duration"></span></strong>
                                            <small class="fine-print"></small>
                                        </div>
                                        <div class="terms-manual"></div>
                                    </span>
                                    <a data-subscription-service="" class="pull-right btn btn-primary rate-link">Get Started</a>
                                </div>
                            </div>
                        </div>
                    </template>

                </div>
                <div class="modal-footer">
                    <button type="button" class="btn btn-default pull-left" data-dismiss="modal">Back</button>
                </div>
            </div>
        </div>
    </div>
</form>
<script>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</script><script>

    $(function(){
        $('#service-promo-modal').on('submit',function(){
            var promoEl = $('#service-promo-modal');
            var promoVal = promoEl.find('input[name=promo]').val();
        
            __tnt.subscription.promos.fetch(promoEl, promoVal);
            
            $("#service-promo-modal").find("[data-dismiss=modal]").on('click',function(){
                if(promoOpenedFromModal){ 
                    $("#template-metering").find('.metering-modal').first().modal();
                    promoOpenedFromModal = true;
                }
            });

            return false;
        });
    });
</script>

<script>
    $(function(){
        var i = 0;
        $('#subscription-modal').find('.subscription-services').find('.subscription-service').each(function(){
            $(this).attr('id','service-tab-'+i);
        
            $(this).find('.panel-heading h3').html('<a href="" data-toggle="collapse" data-parent="services-modal-collapsable-tabs" aria-expanded="false" aria-controls="service-tab-'+i+'">'+$(this).find('.panel-heading h3').text()+'</a>')
            $(this).find('.panel-body').addClass('panel-collapse collapse').attr('role','tabpanel');
            
            if(i==0){
                $(this).find('.panel-collapse').collapse('show');
                $(this).find('.panel-footer').show();
            }else{
                $(this).find('.panel-footer').hide();
            }
        
            i++;
        });
    
        $('.subscription-services-filter').hide();
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').css({'padding':'0px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a').css({'display':'block','padding':'10px 15px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a[data-toggle=collapse]').on('click',function(event){
            var id = $(this).attr('aria-controls');
            var open = $('#'+id).find('.collapse').hasClass('in');
            
            $('#subscription-modal').find('.subscription-services .subscription-service').each(function(){
                if(this.id == id){
                    $(this).find('.panel-collapse').collapse('show');
                    $(this).find('.panel-footer').show();
                }else{
                    $(this).find('.panel-collapse').collapse('hide');
                    $(this).find('.panel-footer').hide();
                }
            });
        });
        
        $('#asset-content').find('.subscription-required').find('.panel-footer').find('a[data-toggle=collapse]').on('click',function(event){
            $(this).parents('.panel-footer').find('.collapse.collapse-rates').collapse('toggle');
        });
        
        
        $('#asset-content').find('.meter-modal-open').on('click',function(){
            $('#asset-content').find('.alert.notification').css({'z-index':'900'});
            $("#template-metering").find('.metering-modal').first().modal();
        
        });
        
        $('#eedition-subscription').find('.meter-modal-open').on('click',function(){
            $("#template-metering").find('.metering-modal').first().modal();
        });
    });
    
</script>

    
</div>
<script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                
                bloxServiceIDs.push(3787);
                
                bloxServiceIDs.push(7650);
                
                bloxServiceIDs.push(3806);
                
                bloxServiceIDs.push(3793);
                
                bloxServiceIDs.push(3786);
                
                bloxServiceIDs.push(3794);
                
                bloxServiceIDs.push(3795);
                
                bloxServiceIDs.push(3796);
                
                bloxServiceIDs.push(3812);
                
                bloxServiceIDs.push(7488);
                
                bloxServiceIDs.push(4550);
                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/wood_river_journal\/community","refresh":false}' style="display:none;"></div>
        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.mtexpress.com/tncms/admin/editorial-asset/?edit=2594e858-0c15-11ec-b042-efe19fb3f72b"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs" aria-label="Right Main Menu" aria-expanded="false" tabindex="-1">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/news"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/sun_valley/"  class="nav-link tnt-section-sun-valley">Sun Valley</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/ketchum/"  class="nav-link tnt-section-ketchum">Ketchum</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/hailey/"  class="nav-link tnt-section-hailey">Hailey</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/carey/"  class="nav-link tnt-section-carey">Carey</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/bellevue/"  class="nav-link tnt-section-bellevue">Bellevue</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/cops_courts/"  class="nav-link tnt-section-copscourts">Cops/Courts</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/blaine_county/"  class="nav-link tnt-section-blaine-county">Blaine County</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/state_regional/"  class="nav-link tnt-section-stateregional">State/Regional</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/environment/"  class="nav-link tnt-section-environment">Environment</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/recreation/"  class="nav-link tnt-section-recreation">Recreation</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/education"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/business/"  class="nav-link tnt-section-business">Business</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/elections/"  class="nav-link tnt-section-elections">Elections</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/transportation/"  class="nav-link tnt-section-transportation">Transportation</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/briefs"  class="nav-link tnt-section-briefs">Briefs</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/archives.html"  class="nav-link tnt-section-archives">Archives</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/submit_news"  class="nav-link tnt-section-submit-news-tip">Submit News Tip</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://idaho.column.us/"  target="_blank" rel="noopener" class="nav-link tnt-section-legal-notices">Legal Notices</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/coronavirus_covid-19_info/"  class="nav-link tnt-section-coronavirus-info">Coronavirus Info</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/wood_river_journal/"  class="nav-link tnt-section-wood-river-journal">Wood River Journal</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/features/"  class="nav-link tnt-section-features">Features</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/valley_people/"  class="nav-link tnt-section-valley-people">Valley People</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/news_of_record/"  class="nav-link tnt-section-news-of-record">News of Record</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/obituaries"  class="nav-link tnt-section-obituaries">Obituaries</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/mountain_town_news/"  class="nav-link tnt-section-mountain-town-news">Mountain Town News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/special_sections/"  class="nav-link tnt-section-special-section">Special Section</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/community/"  class="nav-link tnt-section-community">Community</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/best_of_the_valley/"  class="nav-link tnt-section-best-of-the-valley">Best of the Valley</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/arts_and_events/"  class="nav-link tnt-section-arts-events">Arts & Events</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/arts_and_events/arts/"  class="nav-link tnt-section-arts">Arts</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/arts_and_events/music/"  class="nav-link tnt-section-music">Music</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/arts_and_events/events/"  class="nav-link tnt-section-events">Events</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/arts_and_events/around_town/"  class="nav-link tnt-section-around-town">Around Town</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-5" data-target="#mobile-nav-right_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/sports"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/high_school/"  class="nav-link tnt-section-high-school">High School</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/mountain_sports/"  class="nav-link tnt-section-mountain-sports">Mountain Sports</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/sports_summary/"  class="nav-link tnt-section-sports-summary">Sports Summary</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/sports_extras/"  class="nav-link tnt-section-sports-extras">Sports Extras</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/opinion"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editorials"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/guest_opinions/"  class="nav-link tnt-section-guest-opinions">Guest Opinions</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters-to-editor">Letters to Editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/cartoon/"  class="nav-link tnt-section-cartoon">Cartoon</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/poll"  class="nav-link tnt-section-weekly-poll">Weekly Poll</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-7" data-target="#mobile-nav-right_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="http://classified.mtexpress.com/showads"  target="_blank" rel="noopener" class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://classified.mtexpress.com/showads"  target="_blank" rel="noopener" class="nav-link tnt-section-classified-listings">Classified Listings</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://classified.mtexpress.com/placead"  target="_blank" rel="noopener" class="nav-link tnt-section-submit-an-ad">Submit an Ad</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://www.mtexpress.com/app/rate_card/Ratecardclass-2021.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-advertising-rates">Advertising Rates</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-8" data-target="#mobile-nav-right_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true"   class="nav-link tnt-section-advertise">Advertise</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://www.mtexpress.com/app/rate_card/Ratecard-2021.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-printed-advertising-rates">Printed Advertising Rates</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://www.mtexpress.com/app/rate_card/web advertising.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-online-advertising-rates">Online Advertising Rates</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/submit_news/request_advertising_information/"  class="nav-link tnt-section-request-information">Request Information</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-9" data-target="#mobile-nav-right_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/calendar"  class="nav-link tnt-section-calendar">Calendar</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/calendar"  class="nav-link tnt-section-calendar-listings">Calendar Listings</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/users/admin/calendar/event/"  class="nav-link tnt-section-submit-an-event">Submit an Event</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-10" data-target="#mobile-nav-right_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/obituaries"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/obituaries"  class="nav-link tnt-section-read-obituaries">Read Obituaries</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/announcements/obituary"  class="nav-link tnt-section-submit-an-obituary">Submit an Obituary</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/area_guides/"  class="nav-link tnt-section-area-guides">Area Guides</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/area_history/"  class="nav-link tnt-section-area-history">Area History</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="http://www.sunvalley-realestate.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-real-estate-guide">Real Estate Guide</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-14" data-target="#mobile-nav-right_menu-child-14">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="http://www.mtexpress.com/site/best_of_the_valley.html"  target="_blank" rel="noopener" class="nav-link tnt-section-best-of-the-valley">Best of the Valley</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-14" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.mtexpress.com/wood_river_journal/best_of_the_valley/how-you-voted/article_254c0df2-d148-11eb-8419-0fbf3dcb68dc.html#tncms-source=login"  target="_blank" rel="noopener" class="nav-link tnt-section-results">Results</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.mtexpress.com/special/page-1/page_24561b2b-ccba-5634-882e-b45922e88976.html"  target="_blank" rel="noopener" class="nav-link tnt-section-e-edition">E-edition</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.mtexpress.com/app/Best_of_the_Valley/best promo for business-color.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-printable-posters-for-your-window-color">Printable posters for your window (color)</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.mtexpress.com/app/Best_of_the_Valley/best promo for business-bw.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-printable-poster-for-your-window-bw">Printable poster for your window (b&w)</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/site/services/"  class="nav-link tnt-section-subscribe">Subscribe</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/eedition/"  class="nav-link tnt-section-e-edition">e-Edition</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-1312172" class="tncms-block">
        <div id="blox-ad-position-block-leaderboard-header1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-header","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list" ><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/services"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition"  tabindex="0">
                    <span class="nav-label">e-Edition</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit"  href="/site/forms/online_services"  tabindex="0">
                    <span class="nav-label">Submit</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-topbar-col-two" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-two-nav" class="tncms-region-nav"><ul id="topbar-col-two-nav_menu" class="list-inline nav-list" ></ul></div></div>
    <div id="topbar-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-topbar-col-three" class="tncms-region "><div id="tncms-block-1210229" class="tncms-block"><div id="user-controls-1210229" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.mtexpress.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1210229').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.mtexpress.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.mtexpress.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.mtexpress.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1210229').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.mtexpress.com/users/logout/" id="user-logout-form-1210229"><input type="hidden" name="referer_url" value="https://www.mtexpress.com/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                  
<div class="row header-advertising">
<div class="col-md-8 col-lg-9"><div id="tncms-region-option-header-ad-left" class="tncms-region "></div></div>
<div class="col-md-4 col-lg-3"><div id="tncms-region-option-header-ad-right" class="tncms-region "><div id="tncms-block-1210232" class="tncms-block"><div id="weather-1210232" class="weather-current size-large pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=83353" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-cloud"></span>
                </span>
                <span class="pull-left temp-desc large">
                    <span class="temp">61&deg;</span>
                    
                        <span class="cond">Smoke <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="83353"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a id="weather_zip_toggle_1210232" class="pull-right zip-update-link" aria-label="weather_zip_toggle"><span class="fas tnt-cog"></span></a><h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Sun Valley, ID
                                
                                 <small>(83353)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Clear skies. Low 38F. Winds NW at 5 to 10 mph..</p>
                            <h5>Tonight</h5>
                            <p>Clear skies. Low 38F. Winds NW at 5 to 10 mph.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: September 2, 2021 @ 8:16 pm</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=83353"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
</div>

                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "></div></div>
    <div id="masthead-col-two" class="col-md-9 col-sm-9"><div id="tncms-region-masthead-col-two" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "><div id="tncms-block-1210206" class="tncms-block center-image"><section id="block-1210206" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=150%2C24 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=200%2C31 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=225%2C35 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=300%2C47 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=400%2C63 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=540%2C85 540w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=640%2C100 640w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=750%2C118 750w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=990%2C155 990w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png 1035w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="1000"
                height="157"
                alt=""></a></div></section></div></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button  type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right" aria-label="Right Main Menu" aria-expanded="false" >
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>

                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1210207" class="tncms-block"><section id="block-1210207" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/f1b90b88-d5d1-11ea-90dd-eb8bc0dcdb5e.png?resize=150%2C27 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/f1b90b88-d5d1-11ea-90dd-eb8bc0dcdb5e.png?resize=200%2C35 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/f1b90b88-d5d1-11ea-90dd-eb8bc0dcdb5e.png?resize=225%2C40 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/f1b90b88-d5d1-11ea-90dd-eb8bc0dcdb5e.png 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="300"
                height="53"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news"  tabindex="0">
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-sun-valley"  href="/news/sun_valley/"  tabindex="0">
                    <span class="nav-label">Sun Valley</span>
                </a></li><li>
                <a class="nav-link   tnt-section-ketchum"  href="/news/ketchum/"  tabindex="0">
                    <span class="nav-label">Ketchum</span>
                </a></li><li>
                <a class="nav-link   tnt-section-hailey"  href="/news/hailey/"  tabindex="0">
                    <span class="nav-label">Hailey</span>
                </a></li><li>
                <a class="nav-link   tnt-section-carey"  href="/news/carey/"  tabindex="0">
                    <span class="nav-label">Carey</span>
                </a></li><li>
                <a class="nav-link   tnt-section-bellevue"  href="/news/bellevue/"  tabindex="0">
                    <span class="nav-label">Bellevue</span>
                </a></li><li>
                <a class="nav-link   tnt-section-copscourts"  href="/news/cops_courts/"  tabindex="0">
                    <span class="nav-label">Cops/Courts</span>
                </a></li><li>
                <a class="nav-link   tnt-section-blaine-county"  href="/news/blaine_county/"  tabindex="0">
                    <span class="nav-label">Blaine County</span>
                </a></li><li>
                <a class="nav-link   tnt-section-stateregional"  href="/news/state_regional/"  tabindex="0">
                    <span class="nav-label">State/Regional</span>
                </a></li><li>
                <a class="nav-link   tnt-section-environment"  href="/news/environment/"  tabindex="0">
                    <span class="nav-label">Environment</span>
                </a></li><li>
                <a class="nav-link   tnt-section-recreation"  href="/news/recreation/"  tabindex="0">
                    <span class="nav-label">Recreation</span>
                </a></li><li>
                <a class="nav-link   tnt-section-education"  href="/news/education"  tabindex="0">
                    <span class="nav-label">Education</span>
                </a></li><li>
                <a class="nav-link   tnt-section-business"  href="/news/business/"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-elections"  href="/news/elections/"  tabindex="0">
                    <span class="nav-label">Elections</span>
                </a></li><li>
                <a class="nav-link   tnt-section-transportation"  href="/news/transportation/"  tabindex="0">
                    <span class="nav-label">Transportation</span>
                </a></li><li>
                <a class="nav-link   tnt-section-briefs"  href="/news/briefs"  tabindex="0">
                    <span class="nav-label">Briefs</span>
                </a></li><li>
                <a class="nav-link   tnt-section-archives"  href="/site/archives.html"  tabindex="0">
                    <span class="nav-label">Archives</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-news-tip"  href="/site/forms/online_services/submit_news"  tabindex="0">
                    <span class="nav-label">Submit News Tip</span>
                </a></li><li>
                <a class="nav-link   tnt-section-legal-notices"  href="https://idaho.column.us/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Legal Notices</span>
                </a></li><li>
                <a class="nav-link   tnt-section-coronavirus-info"  href="/news/coronavirus_covid-19_info/"  tabindex="0">
                    <span class="nav-label">Coronavirus Info</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-wood-river-journal"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/wood_river_journal/"  tabindex="0">
                    <span class="nav-label">Wood River Journal</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-features"  href="/wood_river_journal/features/"  tabindex="0">
                    <span class="nav-label">Features</span>
                </a></li><li>
                <a class="nav-link   tnt-section-valley-people"  href="/wood_river_journal/valley_people/"  tabindex="0">
                    <span class="nav-label">Valley People</span>
                </a></li><li>
                <a class="nav-link   tnt-section-news-of-record"  href="/wood_river_journal/news_of_record/"  tabindex="0">
                    <span class="nav-label">News of Record</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-mountain-town-news"  href="/wood_river_journal/mountain_town_news/"  tabindex="0">
                    <span class="nav-label">Mountain Town News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-special-section"  href="/wood_river_journal/special_sections/"  tabindex="0">
                    <span class="nav-label">Special Section</span>
                </a></li><li>
                <a class="nav-link   tnt-section-community"  href="/wood_river_journal/community/"  tabindex="0">
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link   tnt-section-best-of-the-valley"  href="/wood_river_journal/best_of_the_valley/"  tabindex="0">
                    <span class="nav-label">Best of the Valley</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-arts-events"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/arts_and_events/"  tabindex="0">
                    <span class="nav-label">Arts & Events</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-arts"  href="/arts_and_events/arts/"  tabindex="0">
                    <span class="nav-label">Arts</span>
                </a></li><li>
                <a class="nav-link   tnt-section-music"  href="/arts_and_events/music/"  tabindex="0">
                    <span class="nav-label">Music</span>
                </a></li><li>
                <a class="nav-link   tnt-section-events"  href="/arts_and_events/events/"  tabindex="0">
                    <span class="nav-label">Events</span>
                </a></li><li>
                <a class="nav-link   tnt-section-around-town"  href="/arts_and_events/around_town/"  tabindex="0">
                    <span class="nav-label">Around Town</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-high-school"  href="/sports/high_school/"  tabindex="0">
                    <span class="nav-label">High School</span>
                </a></li><li>
                <a class="nav-link   tnt-section-mountain-sports"  href="/sports/mountain_sports/"  tabindex="0">
                    <span class="nav-label">Mountain Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports-summary"  href="/sports/sports_summary/"  tabindex="0">
                    <span class="nav-label">Sports Summary</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports-extras"  href="/sports/sports_extras/"  tabindex="0">
                    <span class="nav-label">Sports Extras</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-editorials"  href="/opinion/editorials"  tabindex="0">
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link   tnt-section-guest-opinions"  href="/opinion/guest_opinions/"  tabindex="0">
                    <span class="nav-label">Guest Opinions</span>
                </a></li><li>
                <a class="nav-link   tnt-section-letters-to-editor"  href="/opinion/letters_to_editor/"  tabindex="0">
                    <span class="nav-label">Letters to Editor</span>
                </a></li><li>
                <a class="nav-link   tnt-section-cartoon"  href="/opinion/cartoon/"  tabindex="0">
                    <span class="nav-label">Cartoon</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weekly-poll"  href="/opinion/poll"  tabindex="0">
                    <span class="nav-label">Weekly Poll</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="http://classified.mtexpress.com/showads"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-classified-listings"  href="http://classified.mtexpress.com/showads"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Classified Listings</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-an-ad"  href="https://classified.mtexpress.com/placead"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Submit an Ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-advertising-rates"  href="http://www.mtexpress.com/app/rate_card/Ratecardclass-2021.pdf"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Advertising Rates</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-advertise"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0">
                    <span class="nav-label">Advertise</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-printed-advertising-rates"  href="http://www.mtexpress.com/app/rate_card/Ratecard-2021.pdf"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Printed Advertising Rates</span>
                </a></li><li>
                <a class="nav-link   tnt-section-online-advertising-rates"  href="http://www.mtexpress.com/app/rate_card/web advertising.pdf"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Online Advertising Rates</span>
                </a></li><li>
                <a class="nav-link   tnt-section-request-information"  href="/site/forms/online_services/submit_news/request_advertising_information/"  tabindex="0">
                    <span class="nav-label">Request Information</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-calendar"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/calendar"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-calendar-listings"  href="/calendar"  tabindex="0">
                    <span class="nav-label">Calendar Listings</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-an-event"  href="/users/admin/calendar/event/"  tabindex="0">
                    <span class="nav-label">Submit an Event</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-obituaries"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/obituaries"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a><ul id="main-nav_menu-child-10" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-read-obituaries"  href="/obituaries"  tabindex="0">
                    <span class="nav-label">Read Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-an-obituary"  href="/site/forms/announcements/obituary"  tabindex="0">
                    <span class="nav-label">Submit an Obituary</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-area-guides"  href="/area_guides/"  tabindex="0">
                    <span class="nav-label">Area Guides</span>
                </a></li><li>
                <a class="nav-link   tnt-section-area-history"  href="/area_history/"  tabindex="0">
                    <span class="nav-label">Area History</span>
                </a></li><li>
                <a class="nav-link   tnt-section-real-estate-guide"  href="http://www.sunvalley-realestate.com/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Real Estate Guide</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-best-of-the-valley"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="http://www.mtexpress.com/site/best_of_the_valley.html"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Best of the Valley</span>
                </a><ul id="main-nav_menu-child-14" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-results"  href="https://www.mtexpress.com/wood_river_journal/best_of_the_valley/how-you-voted/article_254c0df2-d148-11eb-8419-0fbf3dcb68dc.html#tncms-source=login"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Results</span>
                </a></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="https://www.mtexpress.com/special/page-1/page_24561b2b-ccba-5634-882e-b45922e88976.html"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">E-edition</span>
                </a></li><li>
                <a class="nav-link   tnt-section-printable-posters-for-your-window-color"  href="https://www.mtexpress.com/app/Best_of_the_Valley/best promo for business-color.pdf"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Printable posters for your window (color)</span>
                </a></li><li>
                <a class="nav-link   tnt-section-printable-poster-for-your-window-bw"  href="https://www.mtexpress.com/app/Best_of_the_Valley/best promo for business-bw.pdf"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Printable poster for your window (b&w)</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/services/"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition/"  tabindex="0">
                    <span class="nav-label">e-Edition</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
              


            <div class="option-under-nav container">
            <div class="row">
                <div class="col-md-3"><div id="tncms-region--option-left" class="tncms-region "><div id="tncms-block-1210216" class="tncms-block hidden-xs hidden-sm hidden-md"><div class="follow-links-1210216 default">
    
    <section id="block-1210216" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/MountainExpress/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/IdahoMtExpress" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
            <li>
                <a href="https://www.instagram.com/idmtexpress/" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.mtexpress.com",
  "sameAs" : ["https://www.facebook.com/MountainExpress/","https://twitter.com/IdahoMtExpress","https://www.instagram.com/idmtexpress/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                <div class="col-md-6"><div id="tncms-region--option-middle" class="tncms-region "><div id="tncms-block-1210230" class="tncms-block hidden-md hidden-lg"><div id="user-controls-1210230" class="user-controls show-onload clearfix pull-right"><div class="large-user-avatar pull-left">
            <div class="tn-user-avatar pull-left"><!-- user avatar --></div>
        </div>
        <div class="large-user-controls pull-left">
            <div class="user-welcome">Welcome, <span class="tn-user-screenname">Guest</span></div><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html" class=" user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html" class=" user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.mtexpress.com/users/admin/">Dashboard</a></li>
                    <li><a class="logout-btn" onclick="document.getElementById('user-logout-form-1210230').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><span class="user-control-link">My Account</span>
                    <b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.mtexpress.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.mtexpress.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.mtexpress.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1210230').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

    </div>

<form method="post" action="https://www.mtexpress.com/users/logout/" id="user-logout-form-1210230"><input type="hidden" name="referer_url" value="https://www.mtexpress.com/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1219208" class="tncms-block"><p style="text-align:center;">Serving Sun Valley, Ketchum, Hailey, Bellevue and Carey</p>
<p style="text-align:center;margin-top:-10px;">September 2, 2021</p></div></div></div>
                <div class="col-md-3"><div id="tncms-region--option-right" class="tncms-region "><div id="tncms-block-1210213" class="tncms-block"><section id="block-1210213" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1210213" class="search-form-container card clearfix text-center hidden-print well">
    <form id="site-search-1210213" aria-labelledby="site-search-button-1210213" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal ">
        <input id="site-search-1210213-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1210213-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-1210213" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1210213-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1210213').submit();
        return false;
    });

    $('#site-search-1210213').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1210213 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1210213 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1210213-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
            </div>
            </div>



        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1210184" class="tncms-block"></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1210117" class="tncms-block">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1210118" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-tile-header1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-tile-header","slot":"1","fold":"","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><div id="modal-image-45c6c042-0c15-11ec-a3e2-5321da1b3c7c" class="modal fullscreen in modal-image image-default modal-45c6c042-0c15-11ec-a3e2-5321da1b3c7c" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=400%2C300"
                    srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=150%2C113 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=200%2C150 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=225%2C169 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=300%2C225 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=400%2C300 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=540%2C405 540w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=640%2C480 640w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=750%2C563 750w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=990%2C743 990w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=1035%2C777 1035w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=1200%2C900 1200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=1333%2C1000 1333w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=1476%2C1107 1476w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=1662%2C1247 2008w"
                    sizes="100vw"
                    
                    width="1662"
                    height="1247"
                    alt="Sawtooth Valley, smoke"
                    class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-45c6c042-0c15-11ec-a3e2-5321da1b3c7c" data-target=".caption-inner-modal-image-45c6c042-0c15-11ec-a3e2-5321da1b3c7c">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-45c6c042-0c15-11ec-a3e2-5321da1b3c7c collapse in"><div class="caption-text"><div class="subscriber-preview"><p class="PullQuote">A volunteer-driven cleanup effort in the Sawtooth National Forest will run from September 12-25.</p></div></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span id="author-ed80ee64-6052-11e4-b694-0bd0d85f21ae-asset-45c6c042-0c15-11ec-a3e2-5321da1b3c7c" class="tnt-byline asset-byline"  ><a href="https://www.mtexpress.com/users/profile/Roland%20Lane">Express photo by Roland Lane</a></span>
                </li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.mtexpress.com%2Fsawtooth-valley-smoke%2Fimage_45c6c042-0c15-11ec-a3e2-5321da1b3c7c.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sawtooth-valley-smoke/image_45c6c042-0c15-11ec-a3e2-5321da1b3c7c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"45c6c042-0c15-11ec-a3e2-5321da1b3c7c"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Sawtooth%20Valley%2C%20smoke&via=IdahoMtExpress&url=https%3A%2F%2Fwww.mtexpress.com%2Fsawtooth-valley-smoke%2Fimage_45c6c042-0c15-11ec-a3e2-5321da1b3c7c.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sawtooth-valley-smoke/image_45c6c042-0c15-11ec-a3e2-5321da1b3c7c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"45c6c042-0c15-11ec-a3e2-5321da1b3c7c"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.mtexpress.com/sawtooth-valley-smoke/image_45c6c042-0c15-11ec-a3e2-5321da1b3c7c.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sawtooth-valley-smoke/image_45c6c042-0c15-11ec-a3e2-5321da1b3c7c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"45c6c042-0c15-11ec-a3e2-5321da1b3c7c"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.mtexpress.com/tncms/asset/editorial/45c6c042-0c15-11ec-a3e2-5321da1b3c7c" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"45c6c042-0c15-11ec-a3e2-5321da1b3c7c"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Mountain%20Express%5D%20Sawtooth%20Valley%2C%20smoke&body=https%3A%2F%2Fwww.mtexpress.com%2Fsawtooth-valley-smoke%2Fimage_45c6c042-0c15-11ec-a3e2-5321da1b3c7c.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"45c6c042-0c15-11ec-a3e2-5321da1b3c7c"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sawtooth-valley-smoke/image_45c6c042-0c15-11ec-a3e2-5321da1b3c7c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"45c6c042-0c15-11ec-a3e2-5321da1b3c7c"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-45c6c042-0c15-11ec-a3e2-5321da1b3c7c-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="45c6c042-0c15-11ec-a3e2-5321da1b3c7c" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="45c6c042-0c15-11ec-a3e2-5321da1b3c7c" class="save-list-45c6c042-0c15-11ec-a3e2-5321da1b3c7c-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="45c6c042-0c15-11ec-a3e2-5321da1b3c7c" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-45c6c042-0c15-11ec-a3e2-5321da1b3c7c img { max-height: 720px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-2594e858-0c15-11ec-b042-efe19fb3f72b" class="asset article-default"  data-url="https://www.mtexpress.com/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="A self-guided project to address months of heavy traffic and littering in the Sawtooth National Recreation Area will begin on Sunday, Sept. 12, with volunteers in high demand. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=840%2C630">
            <meta itemprop="width" content="840">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="mtexpress.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.mtexpress.com/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html" />
    <style>
                .asset-paging .direction {
                    color: #c00826;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.mtexpress.com\/tncms\/search\/mlt\/?origin=2594e858-0c15-11ec-b042-efe19fb3f72b&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-2594e858-0c15-11ec-b042-efe19fb3f72b" class="asset-paging">
                <div id="paging-prev-2594e858-0c15-11ec-b042-efe19fb3f72b" class="paging-link prev offset"></div>
                <div id="paging-next-2594e858-0c15-11ec-b042-efe19fb3f72b" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper has-flags">
        
            <div class="asset-label-flags has-work">
                <span class="tnt-flag label label-flag label-flag-default label-flag-featured">featured</span> 
            </div>
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            Volunteers sought in SNRA cleanup
        </span>
    </h1>
    
    <h2 itemprop="alternativeHeadline" class="subhead">
            <span>End-of-season effort to address heavy visitor use </span>
        </h2><div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2021-09-02T11:42:00-06:00" class="tnt-date asset-date text-muted">
            Sep 2, 2021
        </time></li>
            <li class="hidden-print">
        <time datetime="2021-09-02T11:42:00-06:00" class="tnt-date asset-date text-muted">8 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count comment-counter">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-09-02T11:42:00-06:00">
    <meta itemprop="datePublished" content="2021-09-02T11:42:00-06:00">
    <meta itemprop="dateModified" content="2021-09-02T11:42:00-06:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Volunteers%20sought%20in%20SNRA%20cleanup&via=IdahoMtExpress&url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.mtexpress.com/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.mtexpress.com/tncms/asset/editorial/2594e858-0c15-11ec-b042-efe19fb3f72b" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Mountain%20Express%5D%20Volunteers%20sought%20in%20SNRA%20cleanup&body=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-45c6c042-0c15-11ec-a3e2-5321da1b3c7c" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-45c6c042-0c15-11ec-a3e2-5321da1b3c7c" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1662">
            <meta itemprop="height" content="1247">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=1396%2C1047">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=1396%2C1047">
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=400%2C300"
                    srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=150%2C113 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=200%2C150 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=225%2C169 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=300%2C225 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=400%2C300 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=540%2C405 540w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=640%2C480 640w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=750%2C563 750w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=990%2C743 990w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=1035%2C777 1035w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=1200%2C900 1200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=1333%2C1000 1333w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=1476%2C1107 1476w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/5c/45c6c042-0c15-11ec-a3e2-5321da1b3c7c/61310d63c8471.image.jpg?resize=1662%2C1247 2008w"
                    sizes="(min-width: 1396px) 881px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                    
                    width="1662"
                    height="1247"
                    alt="Sawtooth Valley, smoke"
                    class="img-responsive full tnt-restrict-img-45c6c042-0c15-11ec-a3e2-5321da1b3c7c default" />
            </div><style>
                .tnt-restrict-img-45c6c042-0c15-11ec-a3e2-5321da1b3c7c {
                    max-width: 960px;
                }
            </style>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p class="PullQuote">A volunteer-driven cleanup effort in the Sawtooth National Forest will run from September 12-25.</p>
                                </span>
                            
                        
                            
                                <span class="credit">
                                    <span id="author-ed80ee64-6052-11e4-b694-0bd0d85f21ae-asset-45c6c042-0c15-11ec-a3e2-5321da1b3c7c" class="tnt-byline asset-byline"  ><a href="https://www.mtexpress.com/users/profile/Roland%20Lane">Express photo by Roland Lane</a></span>
                
                                </span>
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="2594e858-0c15-11ec-b042-efe19fb3f72b">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Volunteers%20sought%20in%20SNRA%20cleanup&via=IdahoMtExpress&url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.mtexpress.com/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.mtexpress.com/tncms/asset/editorial/2594e858-0c15-11ec-b042-efe19fb3f72b" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Mountain%20Express%5D%20Volunteers%20sought%20in%20SNRA%20cleanup&body=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-2594e858-0c15-11ec-b042-efe19fb3f72b-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="2594e858-0c15-11ec-b042-efe19fb3f72b" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="2594e858-0c15-11ec-b042-efe19fb3f72b" class="save-list-2594e858-0c15-11ec-b042-efe19fb3f72b-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="2594e858-0c15-11ec-b042-efe19fb3f72b" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  p402_premium subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p>A self-guided project to address months of heavy traffic and littering in the Sawtooth National Recreation Area will begin on Sunday, Sept. 12, with volunteers in high demand.</p></div><div class="subscriber-preview"><p>Spearheaded by the National Forest Foundation, Idaho Conservation League, Sawtooth Society and Sawtooth Interpretive and Historical Association, the project goal is to restore the central Idaho landscape to its natural state.</p></div><div class="subscriber-preview"><p>Other partners involved include the Environmental Resource Center, Pulaski Users Group and The National Forest Foundation.</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/wood_river_journal\/community","refresh":true}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top-asset', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>“We’re hoping to have good participation this year from across Idaho. Last year’s clean up involved more than 900 volunteer hours that resulted in 300 pounds of trash picked up and 150 campsites restored,” said Dani Southard with the National Forest Foundation. “We’d very much appreciate support in getting the word out this year.”</p></div><div class="subscriber-only"><p>Individuals and small groups are encouraged to sign up, and anyone who completes a brief report about their cleanup efforts will be entered into a raffle for a set of Hydroflask insulated coffee containers donated by the National Forest Foundation, a Steri Pen water purifier donated by Backwoods Mountain Sports and a gift card donated by The Elephant’s Perch.</p></div><div class="subscriber-only"><p>Participants can choose from a list of front-country or backcountry locations or write in their own. To volunteer, <a href="http://%20https//tinyurl.com/snracleanup21" target="_blank">click here</a>, choose a project and select when you plan to go. Participants will receive an email with additional instructions.</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/wood_river_journal\/community","refresh":true}' style="display:none;"></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Volunteers%20sought%20in%20SNRA%20cleanup&via=IdahoMtExpress&url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.mtexpress.com/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.mtexpress.com/tncms/asset/editorial/2594e858-0c15-11ec-b042-efe19fb3f72b" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Mountain%20Express%5D%20Volunteers%20sought%20in%20SNRA%20cleanup&body=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2594e858-0c15-11ec-b042-efe19fb3f72b"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-2594e858-0c15-11ec-b042-efe19fb3f72b-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="2594e858-0c15-11ec-b042-efe19fb3f72b" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="2594e858-0c15-11ec-b042-efe19fb3f72b" class="save-list-2594e858-0c15-11ec-b042-efe19fb3f72b-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="2594e858-0c15-11ec-b042-efe19fb3f72b" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22environmental%20volunteering%22#tncms-source=keyword" class="tag-environmental-volunteering label label-default" >Environmental Volunteering</a>
            </li> <li>
                <a href="/search/?k=%22sawtooth%20national%20recreation%20area%22#tncms-source=keyword" class="tag-sawtooth-national-recreation-area label label-default" >Sawtooth National Recreation Area</a>
            </li> <li>
                <a href="/search/?k=%22idaho%20conservation%20league%22#tncms-source=keyword" class="tag-idaho-conservation-league label label-default" >Idaho Conservation League</a>
            </li> <li>
                <a href="/search/?k=%22national%20forest%20foundation%22#tncms-source=keyword" class="tag-national-forest-foundation label label-default" >National Forest Foundation</a>
            </li> <li>
                <a href="/search/?k=%22sawtooth%20society%22#tncms-source=keyword" class="tag-sawtooth-society label label-default" >Sawtooth Society</a>
            </li> <li>
                <a href="/search/?k=%22litter%22#tncms-source=keyword" class="tag-litter label label-default" >Litter</a>
            </li> <li>
                <a href="/search/?k=%22outdoors%22#tncms-source=keyword" class="tag-outdoors label label-default" >Outdoors</a>
            </li> <li>
                <a href="/search/?k=%22outdoor%20tourism%22#tncms-source=keyword" class="tag-outdoor-tourism label label-default" >Outdoor Tourism</a>
            </li> <li>
                <a href="/search/?k=%22idaho%20outdoors%22#tncms-source=keyword" class="tag-idaho-outdoors label label-default" >Idaho Outdoors</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print"><a id="comments-collapsible-toggle" class="btn btn-block btn-lg btn-default"><i class="fas tnt-sync"></i> Load comments</a><div id="comments-collapsible" class="comments-container-collapsible collapsed">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="2594e858-0c15-11ec-b042-efe19fb3f72b" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/wood_river_journal/community/volunteers-sought-in-snra-cleanup/article_2594e858-0c15-11ec-b042-efe19fb3f72b.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="2594e858-0c15-11ec-b042-efe19fb3f72b" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container ">
        <section id="comments" class=" p402_hide subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fwood_river_journal%2Fcommunity%2Fvolunteers-sought-in-snra-cleanup%2Farticle_2594e858-0c15-11ec-b042-efe19fb3f72b.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules">
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/wood_river_journal\/community","refresh":true}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1219539" class="tncms-block card-grid-increase-max-height card-grid-hide-asset-content"><section id="block-1219539" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1219539 ">
        <div class="block-title-inner">
            <h4>
                
                Current E-Edition
                
            </h4>
        </div>
    </div></div><div class="card-grid   card-img-lg card-bg-color card-heading-color card-compact">
        
        
            <div class=" ">
        
        <div class="  last-grid-item">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-1219539-1c471475-d7f9-5d6c-90b1-3e868ce476a5" class="tnt-asset-type-edition clearfix card summary has-image image-top inherit letterbox-style-default  tnt-section-eedition">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-1c471475-d7f9-5d6c-90b1-3e868ce476a5 media-preview edition-asset" data-aspect="original"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/eedition/friday-september-3-2021/edition_1c471475-d7f9-5d6c-90b1-3e868ce476a5.html" class="tnt-asset-link" >                
                
                
                
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Friday, September 3, 2021"
                    class="img-responsive lazyload  letterbox default"
                    width="792"
                    height="1224"
                    data-src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/eedition/1/c4/1c471475-d7f9-5d6c-90b1-3e868ce476a5/613160cad8df9.preview-792.jpg?resize=792%2C1224" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/eedition/friday-september-3-2021/edition_1c471475-d7f9-5d6c-90b1-3e868ce476a5.html" class="tnt-asset-link">
        

        
            Friday, September 3, 2021</a></h3></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
            
        
        
        
        
        </div>
        </div></section></div><div id="tncms-block-1227526" class="tncms-block">
        <div id="blox-ad-position-block-side-rectangle1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-side-rectangle","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1506677" class="tncms-block">
        <div id="blox-ad-position-block-lower-rectangle1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-lower-rectangle","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1210186" class="tncms-block"><section id="block-1210186" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1210186 ">
        <div class="block-title-inner">
            <h4>
                
                Online Poll
                
            </h4>
        </div>
    </div></div>
        
            
                <div class="poll-panel panel">
                    <div class="panel-body">
            
            <h4 class="tnt-headline ">
        
             <a href="/opinion/poll/what-s-your-favorite-part-of-labor-day/poll_ed9ff512-0aa4-11ec-bfd6-e76e372a62b0.html" class="tnt-asset-link">
        

        
            What’s your favorite part of Labor Day?</a></h4>
            <div id="poll-ed9ff512-0aa4-11ec-bfd6-e76e372a62b0-1210186" data-charted="false" class="card poll-content"><div class="loading-poll hide-onload text-center"><i class="fas tnt-spinner tnt-spin tnt-2x"></i></div>
            <div class="show-onload">
                <div id="poll-ed9ff512-0aa4-11ec-bfd6-e76e372a62b0-1210186-your-vote-container" class="alert alert-warning hide">
                    <strong>You voted:</strong> <span id="poll-ed9ff512-0aa4-11ec-bfd6-e76e372a62b0-1210186-your-vote"></span>
                </div>
                <div id="poll-ed9ff512-0aa4-11ec-bfd6-e76e372a62b0-1210186-results" class="tnt-poll-results hide"></div>
                <div id="poll-ed9ff512-0aa4-11ec-bfd6-e76e372a62b0-1210186-container">
                    <form id="poll-ed9ff512-0aa4-11ec-bfd6-e76e372a62b0-1210186-form" class="tnt-poll-form" role="form" method="post" action="/opinion/poll/what-s-your-favorite-part-of-labor-day/poll_ed9ff512-0aa4-11ec-bfd6-e76e372a62b0.html">
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Wagon Days" value="C9803A3F-2780-0001-2B5A1B4E57091068"> Wagon Days
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Backyard BBQs" value="C9803A44-43F0-0001-831316A03E9E1DAE"> Backyard BBQs
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Enjoying the outdoors" value="C9803A48-B9F0-0001-4C4F10FD91D41EBC"> Enjoying the outdoors
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Bellevue’s Labor Day parade" value="C9803A4D-4510-0001-2917B969E3A089E0"> Bellevue’s Labor Day parade
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="A day off from work" value="C9803A51-7700-0001-ADAA10C0769B115E"> A day off from work
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Other" value="C9803A55-E070-0001-D5B3ED7358601A78"> Other
                                </label>
                            </div>
                        
                        <button type="submit" class="btn btn-primary" >Vote</button>
                        <button id="poll-ed9ff512-0aa4-11ec-bfd6-e76e372a62b0-1210186-get-results" class="btn btn-default" >View Results</button>
                    </form>
                </div>
            </div>
            <div id="poll-ed9ff512-0aa4-11ec-bfd6-e76e372a62b0-1210186-back-vote" class="padding-top hide">
                <button id="poll-ed9ff512-0aa4-11ec-bfd6-e76e372a62b0-1210186-back-btn" class="btn btn-default">Back</button>
            </div>
        </div>
            
                    </div>
                </div>
            
        
    </section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/wood_river_journal\/community","refresh":true}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1210282" class="tncms-block"><section id="block-1210282" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1210282 dark">
        <div class="block-title-inner">
            <h4>
                
                    <a href="http://www.mtexpress.com/newsletters/" target="_blank" rel="noopener">
                
                Sign up for The Roundup email
                
                    </a>
                
            </h4>
        </div>
    </div></div><div class=" card-bg-color card-heading-color"><div class="card-panel panel">
            <div class="panel-body"><div class="card email-signup">
        <div class="alert alert-success" role="alert" style="display:none;">
            <p>
                <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
            </p>
        </div>
        <div class="alert alert-danger" role="alert" style="display:none;">
            <p>
                <strong>Error!</strong> There was an error processing your request.
            </p>
        </div>
        <div class="mailinglist-container">
                <form
                    id="mailinglist-form-1210282"
                    class="mailinglist-form form-validate"
                    action="/tncms/mailinglist/signup/"
                    method="post">
                    <input type="hidden" name="submit" value="1">
                    <div class="form-group mailing-lists ">
                        
                            <div class="mailinglist-item priority-10 ">
                                
                                    <input class="mailinglist-id-1210282" type="checkbox" name="list_id[]" value="88a2d7ba-4044-11e4-9d25-bbebbda52923" data-name="News Updates" title="News Updates" style="display:none;" checked>
                                    <h4 class="mailinglist-title">News Updates</h4>
                                    
                                        <p>Would you like to receive our news updates? <strong>Signup today!</strong></p>
                                    
                                
                            </div>
                        
                    </div>

                    

                    <div class="form-group  email-address">
                        <div class="input-group">
                            <span class="input-group-addon"><i class="fas tnt-envelope"></i></span>
                            <input id="email-1210282" class="form-control email" title="email" name="email" type="email" placeholder="Enter email address">
                        </div>
                        <label class="warning-email hide has-error text-danger" for="email">Please enter a valid email address.</label>
                    </div>
                    <div class="row">
                        <div class="mailinglist-btn-container col-sm-6">
                            <button class="mailinglist-save btn btn-primary btn-block">Sign up<i class="fas tnt-spinner tnt-spin" style="display:none; margin-left:5px;"></i></button>
                        </div>
                        <div class="mailinglist-btn-container col-sm-6">
                            <a class="btn btn-default btn-block" href="https://www.mtexpress.com/users/admin/mailinglist/">Manage your lists</a>
                        </div>
                    </div>
                </form>
            </div>
        
    </div></div>
        </div></div></section></div><div id="tncms-block-1210209" class="tncms-block increase-font-size hidden-xs"><section id="block-1210209" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1210209 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1210209" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1210209" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#collections-1210209" data-toggle="tab"><i class="far tnt-copy" title="Collections"></i><span class="tab-text"> Collections</span></a>
            </li>
        
        
            <li >
                <a href="#commented-1210209" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1210209" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc border border-solid"><li><a href="/news/coronavirus_covid-19_info/blaine-county-s-covid-19-risk-level-raised-to-critical/article_df7d4bfa-0767-11ec-ac14-a3ee4a69397c.html">Blaine County’s COVID-19 risk level raised to ‘critical’</a></li><li><a href="/news/environment/boundary-fire-showing-extreme-activity-near-stanley/article_bd4f1048-0a7f-11ec-b753-1b8c42550a03.html">Boundary Fire showing 'extreme activity' near Stanley</a></li><li><a href="/news/coronavirus_covid-19_info/governor-idaho-dangerously-close-to-care-rationing/article_06e9ea1e-0a9b-11ec-9b72-e3e0a2001808.html">Governor: Idaho ‘dangerously close’ to care rationing</a></li><li><a href="/news/blaine_county/lt-gov-blaine-sheriff-spar-over-vulnerable-population-registry/article_81ecd42c-06c4-11ec-b41e-8fde3a9dfa44.html">Lt. Gov., Blaine Sheriff spar over vulnerable population registry</a></li><li><a href="/news/coronavirus_covid-19_info/state-covid-surge-has-hospitals-pushing-capacity/article_e13349e6-06c1-11ec-8939-8fa194c1c9b2.html">State: COVID surge has hospitals pushing capacity</a></li><li><a href="/news/state_regional/custer-county-commission-backs-boren-airstrip/article_548f3480-0696-11ec-8f4e-0fd06752a3f9.html">Custer County Commission backs Boren airstrip</a></li><li><a href="/news/coronavirus_covid-19_info/district-eyes-covid-caseload-as-classes-resume/article_037064cc-0a9f-11ec-87dd-17baaf0bd01d.html">District eyes COVID caseload as classes resume</a></li><li><a href="/news/sun_valley/sun-valley-leaders-to-review-hillside-rules/article_f4778918-09cd-11ec-8c7b-0309969e198b.html">Sun Valley leaders to review hillside rules</a></li><li><a href="/obituaries/mick-john-martin-mickelson/article_54a33590-0aa4-11ec-950e-d778fc753e13.html">Mick John Martin Mickelson</a></li><li><a href="/obituaries/lona-worthington/article_4fc8eeb6-06c6-11ec-9571-7fe37fb34379.html">Lona Worthington</a></li></ul></div>
        
        
            <div id="images-1210209" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/sports/high_school/2021-wrhs-cross-country/image_fccb662e-06b3-11ec-b383-534dbb6b39ea.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="2021 WRHS Cross Country"
                            class="img-responsive lazyload full default"
                            width="463"
                            height="463"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/cc/fccb662e-06b3-11ec-b383-534dbb6b39ea/612818b5ce3b3.image.jpg?crop=463%2C463%2C182%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/cc/fccb662e-06b3-11ec-b383-534dbb6b39ea/612818b5ce3b3.image.jpg?crop=463%2C463%2C182%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/cc/fccb662e-06b3-11ec-b383-534dbb6b39ea/612818b5ce3b3.image.jpg?crop=463%2C463%2C182%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/cc/fccb662e-06b3-11ec-b383-534dbb6b39ea/612818b5ce3b3.image.jpg?crop=463%2C463%2C182%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/cc/fccb662e-06b3-11ec-b383-534dbb6b39ea/612818b5ce3b3.image.jpg?crop=463%2C463%2C182%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/cc/fccb662e-06b3-11ec-b383-534dbb6b39ea/612818b5ce3b3.image.jpg?crop=463%2C463%2C182%2C0&resize=463%2C463&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/sports/high_school/2021-wrhs-swimming/image_a962e2cc-06b4-11ec-8afd-371a83ad70f7.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="2021 WRHS Swimming"
                            class="img-responsive lazyload full default"
                            width="434"
                            height="434"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/a/96/a962e2cc-06b4-11ec-8afd-371a83ad70f7/61281892ab56b.image.jpg?crop=434%2C434%2C196%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/a/96/a962e2cc-06b4-11ec-8afd-371a83ad70f7/61281892ab56b.image.jpg?crop=434%2C434%2C196%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/a/96/a962e2cc-06b4-11ec-8afd-371a83ad70f7/61281892ab56b.image.jpg?crop=434%2C434%2C196%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/a/96/a962e2cc-06b4-11ec-8afd-371a83ad70f7/61281892ab56b.image.jpg?crop=434%2C434%2C196%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/a/96/a962e2cc-06b4-11ec-8afd-371a83ad70f7/61281892ab56b.image.jpg?crop=434%2C434%2C196%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/a/96/a962e2cc-06b4-11ec-8afd-371a83ad70f7/61281892ab56b.image.jpg?crop=434%2C434%2C196%2C0&resize=434%2C434&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/sports/high_school/2021-carey-cross-country/image_c4d5481a-06b4-11ec-971e-5b9b4dbf8462.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="2021 Carey Cross Country"
                            class="img-responsive lazyload full default"
                            width="498"
                            height="498"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/4d/c4d5481a-06b4-11ec-971e-5b9b4dbf8462/612818a274be0.image.jpg?crop=498%2C498%2C164%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/4d/c4d5481a-06b4-11ec-971e-5b9b4dbf8462/612818a274be0.image.jpg?crop=498%2C498%2C164%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/4d/c4d5481a-06b4-11ec-971e-5b9b4dbf8462/612818a274be0.image.jpg?crop=498%2C498%2C164%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/4d/c4d5481a-06b4-11ec-971e-5b9b4dbf8462/612818a274be0.image.jpg?crop=498%2C498%2C164%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/4d/c4d5481a-06b4-11ec-971e-5b9b4dbf8462/612818a274be0.image.jpg?crop=498%2C498%2C164%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/4d/c4d5481a-06b4-11ec-971e-5b9b4dbf8462/612818a274be0.image.jpg?crop=498%2C498%2C164%2C0&resize=498%2C498&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/wagon-days-2021/image_800c8ec6-0b2f-11ec-b584-7f1a4fab46b2.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Wagon Days 2021"
                            class="img-responsive lazyload full default"
                            width="775"
                            height="775"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/8/00/800c8ec6-0b2f-11ec-b584-7f1a4fab46b2/612f8bd5c0c2a.image.jpg?crop=775%2C775%2C0%2C211&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/8/00/800c8ec6-0b2f-11ec-b584-7f1a4fab46b2/612f8bd5c0c2a.image.jpg?crop=775%2C775%2C0%2C211&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/8/00/800c8ec6-0b2f-11ec-b584-7f1a4fab46b2/612f8bd5c0c2a.image.jpg?crop=775%2C775%2C0%2C211&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/8/00/800c8ec6-0b2f-11ec-b584-7f1a4fab46b2/612f8bd5c0c2a.image.jpg?crop=775%2C775%2C0%2C211&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/8/00/800c8ec6-0b2f-11ec-b584-7f1a4fab46b2/612f8bd5c0c2a.image.jpg?crop=775%2C775%2C0%2C211&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/8/00/800c8ec6-0b2f-11ec-b584-7f1a4fab46b2/612f8bd5c0c2a.image.jpg?crop=775%2C775%2C0%2C211&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/8/00/800c8ec6-0b2f-11ec-b584-7f1a4fab46b2/612f8bd5c0c2a.image.jpg?crop=775%2C775%2C0%2C211&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/8/00/800c8ec6-0b2f-11ec-b584-7f1a4fab46b2/612f8bd5c0c2a.image.jpg?crop=775%2C775%2C0%2C211&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/8/00/800c8ec6-0b2f-11ec-b584-7f1a4fab46b2/612f8bd5c0c2a.image.jpg?crop=775%2C775%2C0%2C211&resize=775%2C775&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/john-and-diane-peavey/image_d8a3d7d6-09b0-11ec-959b-f35fff8b9855.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="John and Diane Peavey"
                            class="img-responsive lazyload full default"
                            width="447"
                            height="447"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/d/8a/d8a3d7d6-09b0-11ec-959b-f35fff8b9855/612d09f066d0d.image.jpg?crop=447%2C447%2C162%2C127&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/d/8a/d8a3d7d6-09b0-11ec-959b-f35fff8b9855/612d09f066d0d.image.jpg?crop=447%2C447%2C162%2C127&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/d/8a/d8a3d7d6-09b0-11ec-959b-f35fff8b9855/612d09f066d0d.image.jpg?crop=447%2C447%2C162%2C127&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/d/8a/d8a3d7d6-09b0-11ec-959b-f35fff8b9855/612d09f066d0d.image.jpg?crop=447%2C447%2C162%2C127&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/d/8a/d8a3d7d6-09b0-11ec-959b-f35fff8b9855/612d09f066d0d.image.jpg?crop=447%2C447%2C162%2C127&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/d/8a/d8a3d7d6-09b0-11ec-959b-f35fff8b9855/612d09f066d0d.image.jpg?crop=447%2C447%2C162%2C127&resize=447%2C447&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/opinion/cartoon/nothing-for-nothing/image_c90211c4-0aac-11ec-937b-33578a01cf76.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Nothing for Nothing"
                            class="img-responsive lazyload full default"
                            width="555"
                            height="555"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/90/c90211c4-0aac-11ec-937b-33578a01cf76/612eb09c709b3.image.jpg?crop=555%2C555%2C136%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/90/c90211c4-0aac-11ec-937b-33578a01cf76/612eb09c709b3.image.jpg?crop=555%2C555%2C136%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/90/c90211c4-0aac-11ec-937b-33578a01cf76/612eb09c709b3.image.jpg?crop=555%2C555%2C136%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/90/c90211c4-0aac-11ec-937b-33578a01cf76/612eb09c709b3.image.jpg?crop=555%2C555%2C136%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/90/c90211c4-0aac-11ec-937b-33578a01cf76/612eb09c709b3.image.jpg?crop=555%2C555%2C136%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/90/c90211c4-0aac-11ec-937b-33578a01cf76/612eb09c709b3.image.jpg?crop=555%2C555%2C136%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/c/90/c90211c4-0aac-11ec-937b-33578a01cf76/612eb09c709b3.image.jpg?crop=555%2C555%2C136%2C0&resize=555%2C555&order=crop%2Cresize 640w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        
        
        
            <div id="collections-1210209" class="tab-pane tab-pane-collections fade in ">
                <h4 class="tab-content-heading">Collections</h4><ul class="tab-content-list bullet-disc border border-solid"><li><a href="/gallery/first-day-of-school/collection_a7cc894c-0518-11ec-ab13-5775ce221843.html">First Day of School</a></li><li><a href="/gallery/scenes-from-the-summer/collection_5ed0792a-f9fa-11eb-8d48-37e337ba075a.html">Scenes From The Summer</a></li></ul></div>
        
        
            <div id="commented-1210209" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-disc border border-solid"><li><a href="/news/education/protestors-halt-bcsd-mask-vote/article_f16e08fa-ffb9-11eb-8f82-8f21684cec4d.html">Protestors halt BCSD mask vote</a> (46)</li><li><a href="/news/coronavirus_covid-19_info/blaine-schools-to-require-masks/article_f9e3de36-0169-11ec-bbd0-4f9890cc4422.html">Blaine schools to require masks</a> (45)</li><li><a href="/news/coronavirus_covid-19_info/as-variant-spreads-school-board-weighs-covid-19-safety-masks/article_540acefc-fbb0-11eb-8023-ef762b9c933f.html">As variant spreads, school board weighs COVID-19 safety, masks</a> (39)</li><li><a href="/news/coronavirus_covid-19_info/governor-idaho-dangerously-close-to-care-rationing/article_06e9ea1e-0a9b-11ec-9b72-e3e0a2001808.html">Governor: Idaho ‘dangerously close’ to care rationing</a> (37)</li><li><a href="/news/business/ketchum-eyes-raising-local-taxes-to-fund-community-housing/article_82c77f90-ffb3-11eb-88e4-4b420cac0e37.html">Ketchum eyes raising local taxes to fund community housing</a> (37)</li><li><a href="/news/business/gas-prices-eclipse-4-in-the-wood-river-valley/article_1e9c9974-f62b-11eb-b935-77087e4a59b4.html">Gas prices eclipse $4 in the Wood River Valley</a> (30)</li><li><a href="/opinion/guest_opinions/we-must-keep-schools-open-this-is-the-way/article_51ac452c-ff9e-11eb-a5ea-538722d8bf38.html">We must keep schools open. This is the way.</a> (30)</li><li><a href="/news/blaine_county/for-cities-housing-crunch-hits-home/article_4bf0ac0a-f4b7-11eb-a205-cbf248c6489c.html">For cities, housing crunch hits home</a> (23)</li><li><a href="/news/blaine_county/state-health-experts-warn-of-major-covid-19-spike/article_b1551ca4-0144-11ec-88a6-07674bc1dd70.html">State health experts warn of major COVID-19 spike</a> (23)</li><li><a href="/news/hailey/hailey-leaders-approve-heart-of-hailey-purchase/article_5332661a-fa35-11eb-9c95-7b3d8387552d.html">Hailey leaders approve ‘Heart of Hailey’ purchase</a> (20)</li><li><a href="/news/business/staff-shortages-plague-valley-employers/article_bf1014bc-0535-11ec-85fa-b37fcf3b7d61.html">Staff shortages plague valley employers</a> (19)</li><li><a href="/news/sun_valley/sun-valley-inches-toward-changes-to-hillside-development-rules/article_5b98a1d0-fa2f-11eb-9ac8-4b24dcb47d9f.html">Sun Valley inches toward changes to hillside development rules</a> (18)</li><li><a href="/news/ketchum/ketchum-p-z-to-review-bluebird-village-on-tuesday/article_5515663a-f94f-11eb-9c42-2f56400b94b8.html">Ketchum P&Z to review Bluebird Village on Tuesday</a> (16)</li><li><a href="/news/elections/ketchum-mayor-launches-bid-for-second-term/article_b90fa066-fee9-11eb-b72b-636d3da6938f.html">Ketchum mayor launches bid for second term</a> (16)</li><li><a href="/news/hailey/hailey-leaders-mayor-scrap-croy-campground-plans/article_ea59a178-0536-11ec-a29c-33a72c57ebd4.html">Hailey leaders, mayor scrap Croy Campground plans</a> (16)</li><li><a href="/news/sun_valley/sun-valley-leaders-to-consider-new-allowances-for-hillside-development/article_aaea4d06-f606-11eb-adb8-93b3f3f1b87e.html">Sun Valley leaders to consider new allowances for hillside development</a> (14)</li><li><a href="/opinion/editorials/closing-the-wealth-gap-would-benefit-all-americans/article_e43d1ed6-0a9b-11ec-8dd6-ab4ab3a621fb.html">Closing the wealth gap would benefit all Americans</a> (13)</li><li><a href="/opinion/guest_opinions/forest-health-plans-offer-false-hope/article_0a4689c4-f4a7-11eb-9576-57af100b36bd.html">‘Forest health’ plans offer false hope</a> (12)</li><li><a href="/news/coronavirus_covid-19_info/hailey-leaders-urge-business-owners-to-require-masks/article_1e60fdf6-05e4-11ec-a508-0f7ef686aa8d.html">Hailey leaders urge business owners to require masks</a> (12)</li><li><a href="/news/blaine_county/lt-gov-blaine-sheriff-spar-over-vulnerable-population-registry/article_81ecd42c-06c4-11ec-b41e-8fde3a9dfa44.html">Lt. Gov., Blaine Sheriff spar over vulnerable population registry</a> (12)</li><li><a href="/opinion/letters_to_editor/roark-owes-us-an-apology/article_019cb70e-0522-11ec-8917-0ba4011e7226.html">Roark owes us an apology</a> (11)</li><li><a href="/opinion/letters_to_editor/stop-ketchum-mayor-s-slush-fund/article_2c21951c-ffa0-11eb-b65e-47d2c381f346.html">Stop Ketchum mayor’s slush fund</a> (11)</li><li><a href="/news/state_regional/custer-county-commission-backs-boren-airstrip/article_548f3480-0696-11ec-8f4e-0fd06752a3f9.html">Custer County Commission backs Boren airstrip</a> (9)</li><li><a href="/news/ketchum/ketchum-p-z-approves-bluebird-village/article_bd291f4c-fad4-11eb-938a-77059e415d34.html">Ketchum P&Z approves Bluebird Village</a> (9)</li><li><a href="/news/hailey/hailey-to-hold-final-budget-bond-election-hearings-consider-higher-development-impact-fees/article_30eec822-09db-11ec-845d-4b49fe291bdd.html">Hailey to hold final budget, bond election hearings; consider higher development impact fees</a> (8)</li><li><a href="/news/coronavirus_covid-19_info/cdc-blaine-county-s-covid-19-spread-is-substantial/article_504c1074-f4b6-11eb-83e6-ab438600a5ee.html">CDC: Blaine County’s COVID-19 spread is ‘substantial’</a> (8)</li><li><a href="/opinion/guest_opinions/the-unvaccinated-by-choice-should-know-they-re-being-judged-harshly/article_ad62cfaa-fbaf-11eb-94a8-8b0b0e3ab2ad.html">The unvaccinated-by-choice should know they’re being judged harshly</a> (8)</li><li><a href="/news/hailey/hailey-budget-targets-big-ticket-projects-sustainability/article_c1a3638e-fbc4-11eb-a612-835159754d27.html">Hailey budget targets big-ticket projects, sustainability</a> (8)</li><li><a href="/news/sun_valley/sun-valley-leaders-to-review-hillside-rules/article_f4778918-09cd-11ec-8c7b-0309969e198b.html">Sun Valley leaders to review hillside rules</a> (8)</li><li><a href="/opinion/letters_to_editor/bluebird-must-be-the-beginning/article_08f4d962-ffa2-11eb-b0a0-7fd642f58c00.html">Bluebird must be the beginning</a> (7)</li><li><a href="/news/blaine_county/idaho-power-seeks-surcharge-on-blaine-county-customers/article_5ab69718-0141-11ec-aa0f-f739d84341cc.html">Idaho Power seeks surcharge on Blaine County customers</a> (7)</li><li><a href="/news/coronavirus_covid-19_info/blaine-county-covid-19-risk-raised-to-high/article_7ea11078-fc63-11eb-ba9d-6f15bb97ab0d.html">Blaine County COVID-19 risk raised to ‘high’</a> (7)</li><li><a href="/news/ketchum/ketchum-launches-10m-campaign-to-buy-warm-springs-open-space/article_9e92230e-fbc3-11eb-ba4f-f33c45dee093.html">Ketchum launches $10M campaign to buy Warm Springs open space</a> (7)</li><li><a href="/opinion/letters_to_editor/thank-you-school-board/article_cd1ee844-0521-11ec-a0ff-27b5c5f63446.html">Thank you, School Board</a> (7)</li><li><a href="/news/coronavirus_covid-19_info/blaine-county-s-covid-19-risk-level-raised-to-critical/article_df7d4bfa-0767-11ec-ac14-a3ee4a69397c.html">Blaine County’s COVID-19 risk level raised to ‘critical’</a> (7)</li><li><a href="/news/coronavirus_covid-19_info/as-delta-variant-spikes-sun-valley-leaders-debate-need-for-covid-19-mandates/article_136d0b1e-fa32-11eb-9c1d-9f68d2be430b.html">As delta variant spikes, Sun Valley leaders debate need for COVID-19 mandates</a> (6)</li><li><a href="/news/ketchum/bluebird-village-plan-flies-to-next-stage/article_183a92a6-fbc7-11eb-b667-f3eaab8493c4.html">Bluebird Village plan flies to next stage</a> (6)</li><li><a href="/opinion/guest_opinions/biden-s-afghanistan-fiasco-is-fault-of-many/article_22ea5cfc-06af-11ec-8910-177e17fb356a.html">Biden’s Afghanistan fiasco is fault of many</a> (6)</li><li><a href="/news/coronavirus_covid-19_info/st-luke-s-limits-elective-surgeries-as-covid-cases-surge/article_2a261832-fbc7-11eb-a558-23ffd06ce306.html">St. Luke’s limits elective surgeries as COVID cases surge</a> (6)</li><li><a href="/news/ketchum/in-ketchum-the-hawk-has-landed/article_3a042b6a-0138-11ec-96cc-ef0147a4e25c.html">In Ketchum, the HAWK has landed</a> (6)</li><li><a href="/arts_and_events/music/believe-it-or-not-the-blue-flames-are-here-to-stay/article_5ab992c4-f638-11eb-bdc1-4b516ba1d2de.html">Believe it or not,  The Blue Flames are here to stay</a> (6)</li><li><a href="/news/elections/veteran-councilwoman-announces-re-election-bid/article_7e4f2914-06c4-11ec-a311-4fb8ba6217dd.html">Veteran councilwoman announces re-election bid</a> (6)</li><li><a href="/news/ketchum/bluebird-village-plan-heading-to-city-council/article_c9e384ac-06c3-11ec-8b77-1b0785ddff72.html">Bluebird Village plan heading to City Council</a> (6)</li><li><a href="/opinion/editorials/show-up-and-speak-up-about-community-housing/article_ed01ccc2-f62f-11eb-b5fb-2f277faddecb.html">Show up and speak up about community housing</a> (6)</li><li><a href="/opinion/guest_opinions/western-wildfires-need-science-based-solutions-right-now/article_09c13568-fa28-11eb-ab6b-eba8e7097807.html">Western wildfires need science-based solutions right now</a> (5)</li><li><a href="/news/coronavirus_covid-19_info/as-new-school-year-approaches-covid-19-still-looms/article_51a42d50-fa13-11eb-8b80-4343fe886de9.html">As new school year approaches, COVID-19 still looms</a> (5)</li><li><a href="/news/bellevue/bellevue-p-z-supports-apartment-housing-on-main-street/article_746c0734-0447-11ec-a053-ff6bdc6c0926.html">Bellevue P&Z supports apartment housing on Main Street</a> (5)</li><li><a href="/news/ketchum/ketchum-to-study-potential-changes-to-main-street-warm-springs-road/article_ca5c082a-f4b5-11eb-9991-93dbf8e82e9e.html">Ketchum to study potential changes to Main Street, Warm Springs Road</a> (5)</li><li><a href="/news/blaine_county/amid-shortage-sheriff-s-office-asks-for-housing-stipend-in-2022/article_f0282994-f63b-11eb-a43c-977dfbb35518.html">Amid shortage, Sheriff’s Office asks for housing stipend in 2022</a> (5)</li><li><a href="/opinion/letters_to_editor/guest-opinion-gets-it-wrong/article_23f2edfc-fa26-11eb-88f7-67ed020dbe17.html">Guest opinion gets it wrong</a> (4)</li><li><a href="/news/hailey/hailey-leaders-to-vote-on-croy-campground-tonight/article_2a67bfbe-0462-11ec-af7a-c7dbbea80d2b.html">Hailey leaders to vote on Croy Campground tonight</a> (4)</li><li><a href="/opinion/letters_to_editor/school-board-protest-was-childish/article_30a89234-0522-11ec-898d-73728f151612.html">School board protest was childish</a> (4)</li><li><a href="/news/hailey/eyeing-heart-of-hailey-city-council-raises-budget-by-1-15-million/article_41f5dd0e-ffb3-11eb-b659-a39920f8f608.html">Eyeing ‘Heart of Hailey,’ City Council raises budget by $1.15 million</a> (4)</li><li><a href="/opinion/editorials/take-it-off-the-streets/article_4905bbe4-fbaf-11eb-85bd-e3effe2f8fae.html">Take it off the streets</a> (4)</li><li><a href="/opinion/guest_opinions/right-now-local-government-can-cut-your-property-taxes/article_4d327012-0a9c-11ec-b681-8341dccdbdd4.html">Right now, local government can cut your property taxes</a> (4)</li><li><a href="/news/hailey/hailey-oks-higher-development-impact-fees-to-offset-cost-of-growth/article_4e1420cc-f613-11eb-857f-97abda68e4b5.html">Hailey OKs higher development impact fees to offset cost of growth</a> (4)</li><li><a href="/news/business/ketchum-lot-receipts-signal-strong-tourism-rebound/article_88cc09d0-f63d-11eb-9fd5-0b0d92fadacc.html">Ketchum LOT receipts signal strong tourism rebound</a> (4)</li><li><a href="/news/coronavirus_covid-19_info/governor-health-experts-issue-covid-19-warnings/article_918df7c2-f63d-11eb-9f00-2ff39640918e.html">Governor, health experts issue COVID-19 warnings</a> (4)</li><li><a href="/opinion/letters_to_editor/make-your-voice-heard-by-the-puc/article_959223cc-0522-11ec-a437-a73a8feebb17.html">Make your voice heard by the PUC</a> (4)</li><li><a href="/news/blaine_county/wood-river-fire-rescue-sending-17m-fire-station-bond-measure-to-voters/article_a2f4d6a4-0aae-11ec-9e37-2f06be248f45.html">Wood River Fire & Rescue sending $17M fire station bond measure to voters</a> (4)</li><li><a href="/opinion/editorials/humans-must-begin-now-to-reverse-climate-change/article_bb5efaf6-ff9d-11eb-829d-a700228cea53.html">Humans must begin now to reverse climate change</a> (4)</li><li><a href="/news/bellevue/in-bellevue-new-homes-may-soon-need-outlets-that-can-charge-electric-cars/article_e0c50816-fa21-11eb-be65-076d30c5a5b8.html">In Bellevue, new homes may soon need outlets that can charge electric cars</a> (4)</li><li><a href="/news/ketchum/former-leaders-propose-real-estate-tax-for-housing/article_e5fdc120-ffac-11eb-9e7d-7f46284456ac.html">Former leaders propose  real estate tax for housing</a> (4)</li><li><a href="/news/update-crews-extinguish-red-devil-fire/article_e68d4412-f6ce-11eb-a15e-1b54bc540167.html">Update: Crews extinguish Red Devil Fire</a> (4)</li><li><a href="/news/hailey/hailey-city-council-approves-budget-sets-bond-election-for-heart-of-hailey/article_0c4a5646-0ab5-11ec-ae5b-8ba26f0ba2c8.html">Hailey City Council approves budget, sets bond election for ‘Heart of Hailey’</a> (3)</li><li><a href="/news/environment/blm-fire-restrictions-lifted-for-south-central-idaho-on-wednesday/article_5e8ca72e-0ab0-11ec-b146-ef1e168f644e.html">BLM fire restrictions lifted for south central Idaho on Wednesday</a> (3)</li><li><a href="/opinion/editorials/fix-stuff-then-go-for-more/article_730a5df2-f4a5-11eb-a3f0-d79112f87af2.html">Fix stuff, then go for more</a> (3)</li><li><a href="/news/bellevue/land-trust-secures-111k-for-bellevue-river-restoration/article_a653daa0-f4ad-11eb-9b09-cbd5b9b6444b.html">Land Trust secures $111K for Bellevue river restoration</a> (3)</li><li><a href="/news/hailey/eyeing-heart-of-hailey-council-plans-to-add-1-15-million-into-current-budget/article_ab81da6a-fec9-11eb-88d5-cb45b07d227f.html">Eyeing 'Heart of Hailey,' council plans to add $1.15 million into current budget</a> (3)</li><li><a href="/news/blaine_county/forest-project-aims-to-cut-wildfire-threat-economic-losses-in-blaine/article_cbc02b58-0142-11ec-a62a-b31b023cc7b0.html">Forest project aims to cut wildfire threat, economic losses in Blaine</a> (3)</li><li><a href="/news/hailey/hailey-advances-bond-for-heart-of-hailey-acquisition/article_f6397aac-06be-11ec-a322-0ffd1b5a33cf.html">Hailey advances bond for  ‘Heart of Hailey’ acquisition</a> (3)</li><li><a href="/opinion/letters_to_editor/we-must-adapt-to-a-dry-climate/article_f682afea-f49b-11eb-851b-cfdcef7fd16e.html">We must adapt to a dry climate</a> (3)</li><li><a href="/news/environment/wildfire-east-of-hailey-forces-evacuations/article_0a9ec23e-f66d-11eb-9913-b32e5dc1f295.html">Wildfire east of Hailey forces evacuations</a> (2)</li><li><a href="/opinion/letters_to_editor/kudos-to-sun-valley-raspberries-to-ketchum/article_0bf596b6-f4a2-11eb-82a3-bf77de454306.html">Kudos to Sun Valley, raspberries to Ketchum</a> (2)</li><li><a href="/sports/mountain_sports/the-123-smiles-of-derek-percoski/article_146e691c-fa15-11eb-88b5-87775c4abc29.html">The 123 smiles of Derek Percoski</a> (2)</li><li><a href="/arts_and_events/events/free-conference-to-focus-on-middle-east-relations/article_23c039a4-fbc3-11eb-8597-176494c1bdf0.html">Free conference to focus on Middle East relations</a> (2)</li><li><a href="/news/transportation/airport-finishes-out-strong-fiscal-year/article_34abfda8-ffb4-11eb-b429-2ff4608df28e.html">Airport finishes out strong fiscal year</a> (2)</li><li><a href="/news/environment/in-hailey-red-devil-fire-brings-danger-home/article_6d6a25e4-fa36-11eb-b7fb-eb97e19809d0.html">In Hailey, Red Devil Fire brings danger home</a> (2)</li><li><a href="/news/environment/hailey-conservation-group-secures-640-acre-grazing-lease-in-white-clouds/article_91256de0-013e-11ec-b030-1b4a79a49fd5.html">Hailey conservation group secures 640-acre grazing lease in White Clouds</a> (2)</li><li><a href="/opinion/guest_opinions/substance-not-slush/article_a6d2c3dc-0520-11ec-950c-1f80e58108f9.html">Substance, not slush</a> (2)</li><li><a href="/news/state_regional/hearing-on-sawtooth-airstrip-appeal-set-for-aug-25/article_b1b1b4b2-ffb6-11eb-bac3-773a2f677b76.html">Hearing on Sawtooth airstrip appeal set for Aug. 25</a> (2)</li><li><a href="/opinion/guest_opinions/when-wildfires-keep-coming-back/article_ba7a933c-ff9f-11eb-bfed-1ba37dcedafb.html">When wildfires keep coming back</a> (2)</li><li><a href="/opinion/guest_opinions/hands-off-the-rocks/article_c09ae0e0-0135-11ec-b7a3-4b2dbeecf86c.html">Hands off the rocks</a> (2)</li><li><a href="/news/ketchum/ketchum-kicks-off-10m-campaign-to-buy-preserve-warm-springs-property/article_cb5c793e-fa2e-11eb-97c4-478ff194efd4.html">Ketchum kicks off $10M campaign to buy, preserve Warm Springs property</a> (2)</li><li><a href="/news/bellevue/bellevue-p-z-will-consider-new-apartment-zoning-increased-density-on-thursday/article_d1f4b2f6-feb7-11eb-a887-5ff891e70ff6.html">Bellevue P&Z will consider new apartment zoning, increased density on Thursday</a> (2)</li><li><a href="/news/hailey/hailey-council-to-consider-health-order-extension-town-square-bond/article_e832adbc-f95c-11eb-a0e5-9bbc62da2ce0.html">Hailey Council to consider health order extension, Town Square bond</a> (2)</li><li><a href="/news/coronavirus_covid-19_info/district-eyes-covid-caseload-as-classes-resume/article_037064cc-0a9f-11ec-87dd-17baaf0bd01d.html">District eyes COVID caseload as classes resume</a> (1)</li><li><a href="/news/coronavirus_covid-19_info/hailey-stays-course-on-covid-regulations/article_0d63c75c-fb91-11eb-a9d7-1f7b3ce242e7.html">Hailey stays course on COVID regulations</a> (1)</li><li><a href="/news/environment/boundary-fire-swells-toward-12-000-acres/article_157bf070-0c41-11ec-8cc8-a3a9962e53e9.html">Boundary Fire swells toward 12,000 acres</a> (1)</li><li><a href="/news/hailey/heart-of-hailey-hearings-continue/article_3813e8a8-fbc6-11eb-b9d0-cf6e044ef4a3.html">‘Heart of Hailey’ hearings continue</a> (1)</li><li><a href="/arts_and_events/arts/in-return-ballet-sun-valley-is-en-pointe/article_3962bab2-0527-11ec-9598-fb2686e687ba.html">In return, Ballet Sun Valley is ‘en pointe’</a> (1)</li><li><a href="/wood_river_journal/community/sawtooth-wilderness-riders-1937-trek-commemorated-with-new-map/article_551681e8-0523-11ec-b2af-4b54ea76e169.html">Sawtooth Wilderness Riders’ 1937 trek commemorated with new map</a> (1)</li><li><a href="/news/state_regional/one-time-tax-rebates-to-go-out-to-idaho-residents/article_5a6c83c6-f633-11eb-aa43-1b0f86a1dfd3.html">One-time tax rebates to go out to Idaho residents</a> (1)</li><li><a href="/opinion/editorials/read-the-smoke-signals/article_64e1de36-0520-11ec-b412-777ca79284ce.html">Read the smoke signals</a> (1)</li></ul></div>
        
    </div>
</div></section></div><div id="tncms-block-1402605" class="tncms-block"><iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2FMountainExpress%2F&amp;tabs=timeline&amp;width=340&amp;height=500&amp;small_header=false&amp;adapt_container_width=true&amp;hide_cover=false&amp;show_facepile=true&amp;appId" width="340" height="500" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowtransparency="true"></iframe></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/wood_river_journal\/community","refresh":true}' style="display:none;"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1690905" class="tncms-block"><section id="block-1690905" class="block emphasis-h3  heading-color  " ><div class="clearfix">
        <ul class="list-inline block-links pos-top ">
            
                
                    <li><a href="https://www.mtexpress.com/wood_river_journal/best_of_the_valley/" class="">More Best of the Valley stories</a></li>
                
            
            
        </ul>
    
    <div class="block-title title-1690905 dark">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/news/">
                
                Best of the Valley
                
                    </a>
                
            </h3>
        </div>
    </div></div>
          
        
            
                <div class="card-bg-color">
                    <div class="card-panel panel">
                        <div class="panel-body">
            
            <article id="card-feature-1690905-baf63f2c-d426-11eb-9622-df196d9c5a15" class="clearfix card feature feature-overlay-none feature-hover-none letterbox-style-default has-image ">
        <div class="card-container">
            <div class="stage-wrapper">
                <div class="centered-content-stage has-image"><div class="media-preview-baf63f2c-d426-11eb-9622-df196d9c5a15 media-preview link-asset" data-aspect="original"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="https://www.mtexpress.com/special/page-1/page_a6ce7b19-f771-584e-8cdc-5e243fed9b6d.html" class="tnt-asset-link" >                
                
                    <div class="asset-icon"><i class="fas tnt-external-link-alt tnt-fw" title="Link"></i></div>
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Best of the Valley"
                            class="img-responsive lazyload full default"
                            width="775"
                            height="1007"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/b/af/baf63f2c-d426-11eb-9622-df196d9c5a15/60d336cb527b2.preview.jpg?resize=150%2C195 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/b/af/baf63f2c-d426-11eb-9622-df196d9c5a15/60d336cb527b2.preview.jpg?resize=200%2C260 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/b/af/baf63f2c-d426-11eb-9622-df196d9c5a15/60d336cb527b2.preview.jpg?resize=225%2C292 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/b/af/baf63f2c-d426-11eb-9622-df196d9c5a15/60d336cb527b2.preview.jpg?resize=300%2C390 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/b/af/baf63f2c-d426-11eb-9622-df196d9c5a15/60d336cb527b2.preview.jpg?resize=400%2C520 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/b/af/baf63f2c-d426-11eb-9622-df196d9c5a15/60d336cb527b2.preview.jpg?resize=540%2C702 540w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/b/af/baf63f2c-d426-11eb-9622-df196d9c5a15/60d336cb527b2.preview.jpg?resize=640%2C832 640w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/b/af/baf63f2c-d426-11eb-9622-df196d9c5a15/60d336cb527b2.preview.jpg?resize=750%2C975 750w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/b/af/baf63f2c-d426-11eb-9622-df196d9c5a15/60d336cb527b2.preview.jpg?resize=775%2C1007 990w" />
                </a>
                
            </div>
            
        </figure></div>
                    <div class="centered-content-container content-overlay text-center vert-align-center">
                        <a href="https://www.mtexpress.com/special/page-1/page_a6ce7b19-f771-584e-8cdc-5e243fed9b6d.html"  class="centered-content-link content-overlay">
                            <span class="sr-only">Best of the Valley</span>
                        </a>
                        <div class="centered-content">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="https://www.mtexpress.com/special/page-1/page_a6ce7b19-f771-584e-8cdc-5e243fed9b6d.html" class="tnt-asset-link">
        

        
            Best of the Valley</a></h4></div>
    
                                <div class="card-lead">
                                    <p></p>
                                </div>
                            
                            
                        </div>
                    </div>
                    
                </div>
            </div></div>
    </article>
            
                        </div>
                    </div>
                </div>
            
        
     
    </section></div><div id="tncms-block-1210220" class="tncms-block"><section id="block-1210220" class="block emphasis-h4    tnt-has-block-bg" ><div class="clearfix">
    
    <div class="block-title title-1210220 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/site/forms/online_services/submit_news">
                
                Submit Your News
                
                    </a>
                
            </h4>
        </div>
    </div></div><article class="card promo media"><div class="media-body"><p>We're always interested in hearing about news in our community. Let us know what's going on!</p><a href="/site/forms/online_services/submit_news">
                <button type="button" class="btn btn-primary  ">Submit News Item</button>
            </a></div>
</article><span class="clearfix"></span></section></div><div id="tncms-block-1210226" class="tncms-block"><section id="block-1210226" class="block emphasis-h4    tnt-has-block-bg" ><div class="clearfix">
    
    <div class="block-title title-1210226 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/place_an_ad">
                
                Want to Run an Ad?
                
                    </a>
                
            </h4>
        </div>
    </div></div><article class="card promo media"><div class="media-body"><p>If you're interested in advertising with us, fill out this form to get more information.</p><a href="https://www.mtexpress.com/site/forms/online_services/submit_news/request_advertising_information/">
                <button type="button" class="btn btn-primary  ">Info Request Form</button>
            </a></div>
</article><span class="clearfix"></span></section></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article><template class="hidden" id="infinity-asset-top">  
            <div id="tncms-region-infinity_asset_top" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-first">
            <div id="tncms-region-infinity_asset_after_first" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-third">
            <div id="tncms-region-infinity_asset_after_third" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-fifth">
            <div id="tncms-region-infinity_asset_after_fifth" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-eighth">
            <div id="tncms-region-infinity_asset_after_eighth" class="tncms-region "></div>
        </template>

    <div id="infinite-container" class="infinity-summary-container hidden-print">
        <div id="infinite-more" data-next-url="https://www.mtexpress.com/tncms/search/mlt/?origin=2594e858-0c15-11ec-b042-efe19fb3f72b&app=editorial&inline=infinity&type=article%2Ccollection%2Cvideo%2Cyoutube">
            <i class="fas tnt-spinner tnt-pulse"></i>
        </div>
    </div>

    <script>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</script>
    
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1210119" class="tncms-block">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1210120" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1210194" class="tncms-block"><section id="block-1210194" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1210194 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-news"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-wood-river-journal"  href="/wood_river_journal/"  tabindex="0">
                    <span class="nav-label">Wood River Journal</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-opinion"  href="/opinion/"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-arts-events"  href="/arts_and_events/"  tabindex="0">
                    <span class="nav-label">Arts & Events</span>
                </a></li><li>
                <a class="nav-link   tnt-section-calendar"  href="/calendar"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries/"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="http://classified.mtexpress.com/showads"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link   tnt-section-area-guides"  href="/area_guides/"  tabindex="0">
                    <span class="nav-label">Area Guides</span>
                </a></li><li>
                <a class="nav-link   tnt-section-real-estate-guide"  href="http://www.sunvalley-realestate.com/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Real Estate Guide</span>
                </a></li><li>
                <a class="nav-link   tnt-section-special-sections"  href="/special/"  tabindex="0">
                    <span class="nav-label">Special Sections</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather/"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1210195" class="tncms-block"><section id="block-1210195" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1210195 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-advertise"  href="https://www.mtexpress.com/site/forms/online_services/submit_news/request_advertising_information/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Advertise</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-personnel"  href="/site/personnel.html"  tabindex="0">
                    <span class="nav-label">Personnel</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscription-services"  href="/site/services"  tabindex="0">
                    <span class="nav-label">Subscription Services</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submission-forms"  href="/site/forms"  tabindex="0">
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link   tnt-section-rack-locations"  href="/site/rack_locations.html"  tabindex="0">
                    <span class="nav-label">Rack Locations</span>
                </a></li><li>
                <a class="nav-link   tnt-section-email-alerts"  href="/newsletters"  tabindex="0">
                    <span class="nav-label">Email Alerts</span>
                </a></li><li>
                <a class="nav-link   tnt-section-employment"  href="https://www.mtexpress.com/site/employment.html"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Employment</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1210208" class="tncms-block padding-bottom"><section id="block-1210208" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/89adca7a-ef9d-11e5-b176-438b3732dd45.png?resize=150%2C24 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/89adca7a-ef9d-11e5-b176-438b3732dd45.png?resize=200%2C31 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/89adca7a-ef9d-11e5-b176-438b3732dd45.png?resize=225%2C35 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/89adca7a-ef9d-11e5-b176-438b3732dd45.png 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="300"
                height="47"
                alt=""></a></div></section></div><div id="tncms-block-1210200" class="tncms-block"><section id="block-1210200" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1210200 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>mtexpress.com</strong><br>
    PO Box 1013<br>
    Ketchum, ID 83340
    <br>
    
        <strong>Phone:</strong> 208-726-8060<br>
        <strong>Email:</strong> <a href="mailto:publisher@mtexpress.com">publisher@mtexpress.com</a><br>
    
</address></section></div><div id="tncms-block-1372263" class="tncms-block"><br>Newsroom: <a href="mailto:news@mtexpress.com">news@mtexpress.com</a>
<br>Subscription Dept: <a href="mailto:adsales@mtexpress.com">subs@mtexpress.com</a>
<br>Advertising Dept: <a href="mailto:adsales@mtexpress.com">adsales@mtexpress.com</a>
<br>Classified Dept: <a href="mailto:classifieds@mtexpress.com">classifieds@mtexpress.com</a>
<br><br></div><div id="tncms-block-1210217" class="tncms-block padding-bottom"><div class="follow-links-1210217 default">
    
    <section id="block-1210217" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1210217 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/MountainExpress/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href=" https://twitter.com/IdahoMtExpress" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.mtexpress.com",
  "sameAs" : ["https://www.facebook.com/MountainExpress/"," https://twitter.com/IdahoMtExpress"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
<script type="text/javascript" language="javascript"> 
$(document).ready(function() 
{ 
$('img').bind('contextmenu', function(e){ 
return false; 
}).delay(6000); 
}); 
</script>

            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1210201" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1210201"><div class="col-md-7"><small>&copy; Copyright 2021 <a href="/">Idaho Mountain Express</a>, PO Box 1013 Ketchum, ID</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    <div id="sticky-anchor"><div id="tncms-region-page_sticky_anchor" class="tncms-region hidden-print collapse in"><div id="tncms-block-1836935" class="tncms-block">
        <div id="blox-ad-position-sticky-frontpage-ad1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"sticky-frontpage-ad","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/wood_river_journal\/community","refresh":false}' style="display:none;"></div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("2594e858-0c15-11ec-b042-efe19fb3f72b")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.7e2e0b303de1e8619d0517c270f18503.js"></script>
<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': ["wood_river_journal/community", "news/environment"],
            'tncms.asset.flags': ["featured"],
            'tncms.asset.keywords': ["environmental volunteering", "sawtooth national recreation area", "idaho conservation league", "national forest foundation", "sawtooth society", "litter", "outdoors", "outdoor tourism", "idaho outdoors"]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/metering/resources/scripts/tnt.metering.c1fd4b9015c14b57a58acdbc3ee4daca.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                                    $('#weather_zip_toggle_1210232').click(function(e){
                                        $('#weather-1210232 .zip-update-form').toggle('fast');
                                        return false; 
                                    });
                                }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ $("#comments-collapsible-toggle").click(function() { $("#comments-collapsible, #comments-collapsible-toggle").toggleClass("collapsed"); }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/editorial/resources/scripts/tnt.poll.aa4a56a35da582e986ed8bbce2004ea4.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/maillist_signup.deacc71a82fe583ccc361b42498ff614.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.54d9f15b0d238de6bb20ec82ed8307ac.js"></script>
<script>/*<![CDATA[*/ __tnt.regions.stickyAnchor.init(); /*]]>*/</script></body>
</html>