
  









<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.mtexpress.com/content/tncms/live/" />
<meta name="keywords" content="steve harkins, saint alphonsus regional medical center, todd michael fowler, smiley creek, nampa" />
<meta name="news_keywords" content="steve harkins, saint alphonsus regional medical center, todd michael fowler, smiley creek, nampa" />
<meta name="description" content="A Nampa man died Tuesday night following a motorcycle crash on state Highway 75 north of the Smiley Creek Store." />
<meta name="author" content="Express Staff" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="googlebot" content="noarchive" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.mtexpress.com/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=400%2C400" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="400" />
<meta property="og:title" content="Nampa man dies in Smiley Creek crash" />
<meta property="og:description" content="A Nampa man died Tuesday night following a motorcycle crash on state Highway 75 north of the Smiley Creek Store." />
<meta property="og:site_name" content="Idaho Mountain Express Newspaper" />
<meta property="og:section" content="Cops/Courts" />
<meta property="fb:app_id" content="135817296433862" />
<meta property="article:publisher" content="https://www.facebook.com/MountainExpress/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@IdahoMtExpress" />
<meta name="twitter:image:alt" content="Blaine County Sheriff Logo" />
<meta property="tncms:subs" content="2.0" />
<meta property="tncms:ads" content="refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.8fedb444880893a324cb54415c321896.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.da34fee69fbd9a506f70c74c56e2ccfa.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/live/global/resources/styles/site.css?_dc=1455636824"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,600%7CDroid+Serif:400,700%7CNews+Cycle:400,700"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.59.0"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"banded","style":"default","path":"\/news\/cops_courts","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"asset":{"author":"Express Staff","keywords":"['steve harkins','saint alphonsus regional medical center','todd michael fowler','smiley creek','nampa']","flags":"['']","start_hour":"15","presentation":null,"id":"68a5078e-f56f-11eb-abc5-03a73030860a","app":"editorial","ga_page":"\/news\/cops_courts\/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"},"infinity_scroll":{"display":"summary_siderail","order":"latest"},"vendor":{"outbrain":"disabled","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":337},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-56941017-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms/subscription.js"></script>
<script>/*<![CDATA[*/ TNCMS.Subscription.initialize({"service_id": "3787,7650,3806,3793,3786,3794,3795,3796,3812,7488,4550", "prefix": ""}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.440cdcae2c3272df39c09befc9eb3dd6.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/ads/impressions.js?_dc=1628186717.temp"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/ads/traffic.js?_dc=1628145314"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/ads/settings.js?_dc=1613517699"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.status.828de94349981272665c0fb0107f3e49.js"></script>
<script>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</script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/ads/fixed-big-ad-top-asset/1.js?_dc=1625767772"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/search/resources/scripts/tnt.followed.notifications.6600e99595fd219e961e9882c796e61c.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/ads/fixed-big-ad-top/1.js?_dc=1628022583"></script>
<script>/*<![CDATA[*/ window.poll_config || (window.poll_config = []); window.poll_config.push({"id":"3aca1e40-f4b5-11eb-bd75-5b338dd6ae43-1210186","asset_id":"3aca1e40-f4b5-11eb-bd75-5b338dd6ae43","title":"How has the COVID-19 pandemic affected your family\u2019s income?","url":"\/opinion\/poll\/how-has-the-covid-19-pandemic-affected-your-family-s-income\/poll_3aca1e40-f4b5-11eb-bd75-5b338dd6ae43.html","results":"https:\/\/www.mtexpress.com\/opinion\/poll\/how-has-the-covid-19-pandemic-affected-your-family-s-income\/poll_3aca1e40-f4b5-11eb-bd75-5b338dd6ae43.html?action=poll:results&format=json","chart":"bar"}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/ads/fixed-big-ad-middle/1.js?_dc=1626177664"></script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"bg_color":"#ffffff","heading_bg_color":"#ffffff","heading_tag":"h4","heading_text_color":"dark","require_user_account":"","signup_lists_only":"1","note":"","links_position":"top","text_color":"inherit","list_ids":"","sign_up_text":"Sign up","manage_button_text":"Manage your lists","show_select_all":"","show_audience":"","hide_audience":"","block_id":"1210282"}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>Nampa man dies in Smiley Creek crash | Cops/Courts | mtexpress.com</title>
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.mtexpress.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/14cc261c-ef9c-11e5-8918-535c37aa0e67.png?resize=180%2C180" />
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Nampa man dies in Smiley Creek crash | Cops/Courts | mtexpress.com" href="http://www.mtexpress.com/search/?f=rss&amp;t=article&amp;c=news/cops_courts&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.mtexpress.com/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            
   
    
        </head>
        <body class="app-editorial grid-banded blox-asset uuid-68a5078e-f56f-11eb-abc5-03a73030860a  section-news section-cops-courts type-article infinity-summary-siderail" data-authors='[]' data-path="/news/cops_courts">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.mtexpress.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.59.0&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=banded&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews%2Fcops_courts&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.asset.author=Express+Staff&amp;tncms.asset.keywords=%5B%27steve+harkins%27%2C%27saint+alphonsus+regional+medical+center%27%2C%27todd+michael+fowler%27%2C%27smiley+creek%27%2C%27nampa%27%5D&amp;tncms.asset.flags=%5B%27%27%5D&amp;tncms.asset.start_hour=15&amp;tncms.asset.id=68a5078e-f56f-11eb-abc5-03a73030860a&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fnews%2Fcops_courts%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html&amp;tncms.infinity_scroll.display=summary_siderail&amp;tncms.infinity_scroll.order=latest&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=blox&amp;tncms.system.render_time=337&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.google.ua=UA-56941017-1&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.mtexpress.com",
  secureDomain: "mtexpress.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        
        <script>
    (function() { 
        var ARTICLE_URL = window.location.href; 
        var CONTENT_ID = 'everything';
        document.write(
            '<scr'+'ipt '+ 
            'src="//survey.g.doubleclick.net/survey?site=_furuh2j6ras66vpwrwoeisuq6e'+ 
            '&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
            (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
            '&amp;random='+(new Date).getTime()+ 
            '">'+'\x3C/scr'+'ipt>'
        );
    })();
</script>

        <script>
            document.addEventListener("DOMContentLoaded", function(event) {
                __tnt.metering.access.d.push(function(){
                    //DMP logging
                    if(window._cc){
                        __tnt.log("Logging DMP data")
                        var paywallDmpData = 'Paywall : Viewed Paywall';
                        // Call to cms.dmp.js_behavior_action is here
                        
                    }
                });
            });
        </script>
    

    <div id="template-metering" data-message-mode="basic">
    <template class="template meter subscription">
        <div class="meter message" data-message="blox regissub subscription wall">
        <div class="wall panel panel-default">
            <div class="panel-body">
                <h4 class="meter-heading media-heading">
                    Thank you for reading!
                </h4>

                <p>Please purchase a subscription to read our premium content. If you have a subscription, please log in or sign up for an account on our website to continue.
</p>

                
                <div class="col-xs-12">
                    <div class="pull-right">
                        <a class="btn btn-default btn-block meter-modal-open">Purchase a Subscription</a>
                    </div>
                </div>
                
            </div>
        </div>
        </div>
</template>
    
    <template class="template meter registration">
        
    <div class="meter message wall panel panel-default" data-message="blox registration wall">
        <div class="panel-body">
            <h4 class="meter-heading media-heading">
                Thank you for reading!

            </h4>
            <p>Please <span class="not-logged-in">log in, or sign up for a new account</span> to continue reading.</p>

            <div class="col-xs-12">
                <div class="row not-logged-in">
                
                    <div class="col-xs-6">
                        
    <a  class="btn btn-default btn-block" href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html">Sign Up</a>
                    </div>
                    <div class="col-xs-6">
                        
    <a class="btn btn-primary btn-block" href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html">Log In</a>
                    </div>
                </div>
                
                <div class="row logged-in">
                    <a class="btn btn-default" href="https://www.mtexpress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.mtexpress.com%252Fnews%252Fcops_courts%252Fnampa-man-dies-in-smiley-creek-crash%252Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html">Purchase a Subscription
</a>
                </div>
            </div>
        </div>
    </div>
</template>
    
    <template class="template meter referred">
        <div class="meter notification referred alert alert-dismissable alert-info" data-message="blox user referred">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
         
        <p><strong>Thank you for reading!
</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    
    
    <template class="template meter access" data-count="1">
        <div class="meter notification access alert alert-dismissable alert-info hidden-print" data-message="blox first free">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
         
        <p><strong>Welcome!</strong> We hope that you enjoy our free content.</p>
    </div>
</template>
    
    <template class="template meter access" data-count="5" data-registered="false">
        <div class="meter notification access alert alert-dismissable alert-warning hidden-print" data-message="blox login prompt">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        
        <p><strong>Thank you for reading!
</strong> On your next view you will be asked to <span class="not-logged-in"><a class="alert-link" href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html">log in</a> to your subscriber account or <a class="alert-link" href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html">create an account</a> and subscribe</span><span class="logged-in"><a href="https://www.mtexpress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.mtexpress.com%252Fnews%252Fcops_courts%252Fnampa-man-dies-in-smiley-creek-crash%252Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html">purchase a subscription</a></span> to continue reading.</p>
        </div>
</template>
    
    <template class="template meter access" data-count="5">
        <div class="meter notification access alert alert-dismissable alert-warning hidden-print" data-message="blox last free">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for reading!
</strong> On your next view you will be asked to <span class="not-logged-in"><a class="alert-link" href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html">log in</a> to your subscriber account or <a class="alert-link" href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html">create an account</a> and subscribe</span><span class="logged-in"><a href="https://www.mtexpress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.mtexpress.com%252Fnews%252Fcops_courts%252Fnampa-man-dies-in-smiley-creek-crash%252Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html">purchase a subscription</a></span> to continue reading.</p>
    </div>
</template>
    
    <template class="template meter access" data-registered="true" data-after-wall="true">
        <div class="meter notification alert alert-dismissable alert-info" data-message="blox after login">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            
            <span class="remaining"></span> remaining of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for signing in!</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    
<div id="subscription-modal" class="subscription metering-modal modal fade" data-message="blox modal subscription">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="modal-title">Support journalism you can trust about the valley you love.</h4>
            </div>

            <div class="modal-body">
                <div class="row">
                    <div class="col-xs-12">
                    <div class="not-logged-in">
                            <p>Thank you for reading! Please purchase a subscription or log into an existing subscription to continue reading the Idaho Mountain Express.</p>
                           <span class="sitelogo"></span>
                       </div>
            
                        <div class="logged-in">
                            <div class="no-services" style="display:none">
                                <p>Thank you for reading! Please purchase a subscription or log into an existing subscription to continue reading the Idaho Mountain Express.</p>
                               <span class="sitelogo"></span>
                            </div>
                
                            <div class="has-services" style="display:none">
                                <p>Your current subscription does not provide access to this content.
</p>
                            </div>
                        </div>

                        <div class="col-xs-12">
                            <div class="row not-logged-in padding-bottom">
                                <div class="col-xs-6">
                                    <a class="btn btn-primary btn-block" href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html">Subscribe</a>
                                </div>
                                <div class="col-xs-6">
                                    
    <a class="btn btn-default btn-block" href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html">Log In</a>
                                </div>
                            </div>
                        </div>
                    <div class="col-xs-12">
                            <div class="row logged-in">
                                <div>
                                    <a class="btn btn-default" style="background-color: #bb112d; border-color: #bb112d; color: #fff;" href="https://www.mtexpress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.mtexpress.com%252Fnews%252Fcops_courts%252Fnampa-man-dies-in-smiley-creek-crash%252Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html">Subscribe</a>
                                </div>
                            </div>
                            </div>
                        
                        
                    </div>
                </div>
            </div>
            <div class="modal-footer">
                
            </div>
        </div>
    </div>
</div>

<script>
var promoOpenedFromModal = false;
$(function(){
    $('#service-promo-open').on('submit',function(){
    
        if($('#service-promo-open').find('input[name=promo]').val()!=""){
            $('#service-promo-modal').find('input[name=promo]').val($('#service-promo-open').find('input[name=promo]').val());
            $('#service-promo-modal').find('.promo-loading').show();
    
            if($('#subscription-modal').is(':visible')){
                $('#subscription-modal').modal('toggle');
                promoOpenedFromModal = true;
                setTimeout(function () {
                    $('#service-promo-modal').find('.modal').modal('toggle').submit();
                },500);
            }else{
                $('#service-promo-modal').find('.modal').modal('toggle').submit();
            }
       }
    
        return false;
    });
    
    if($("#service-promo-open").find("input[name=promo]").val()!=""){
        setTimeout(function () {
            $("#service-promo-open").find("button").click();
        },500);
    }
    
});
</script>

<form id="service-promo-modal" class="" method="post" action="https://www.mtexpress.com/content/tncms/live/" data-endpoint="https://www.mtexpress.com/tncms/subscription/services/?promoCode=">
    <input type="hidden" name="serviceid" value=""/>
    <input type="hidden" name="referer_url" value="/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"/>

    <div class="modal fade">
        <div class="modal-dialog">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></button>
                    <div class="form-group">
                        <label class="" for="promo">Have a promo code?</label>
                    </div>
                    <div class="form-group">
                        <div class="input-group">
                            <input type="text" class="form-control" name="promo" placeholder="Enter Code" value="">
                            <span class="input-group-btn"><button type="submit" class="btn btn-primary">Find Offers</button></span>
                        </div>
                    </div>
                </div>
                <div class="modal-body">
                    <template class="template promo-not-found-template">
                        <div class="promo-not-found-warning alert alert-warning">
    <p><strong>Sorry</strong>, no promotional deals were found matching that code.</p>
</div></template>
                    <template class="template promo-found-message-template">
                        <div class="promo-found-message alert alert-success clearfix">
    <p><strong>Promotional Rates</strong> were found for your code.
    
    </p>
</div></template>
                    <template class="template promo-error-template">
                        <div class="promo-error alert alert-warning">
    <p><strong>Sorry</strong>, an error occurred.</p>
</div></template>
                    
                    <div class="row">
                    <h2 class="promo-loading text-center font-larger" style="display:none;"><span class="fas tnt-spinner tnt-spin"></span></h2><div class="col-xs-12 service-promo-status-message"></div>
                    <div class="col-xs-12 output"></div>
                    </div>
                    
                    <template class="template-promo-service hide">
                        <div class="promotion-service subscription-service panel panel-default">
                            <h3 class="panel-heading"></h3>
                            <div class="panel-body">
                                <div class="service-note alert alert-info"></div>
                                <p class="description"></p>
                                <div class="rate-output"><p class="hide">do not remove</p></div>
                            </div>
                        </div>
                    </template>
                    <template class="template-promo-rate hide">
                        <div class="promotion subscription-service panel panel-default">
                            <div class="panel-body">
                                <h4 class="rate-name"></h4>
                                <div class="clearfix">
                                    <span class="pull-left">
                                        <div class="terms-automatic">
                                            <strong><span class="price"></span> <span class="duration"></span></strong>
                                            <small class="fine-print"></small>
                                        </div>
                                        <div class="terms-manual"></div>
                                    </span>
                                    <a data-subscription-service="" class="pull-right btn btn-primary rate-link">Get Started</a>
                                </div>
                            </div>
                        </div>
                    </template>

                </div>
                <div class="modal-footer">
                    <button type="button" class="btn btn-default pull-left" data-dismiss="modal">Back</button>
                </div>
            </div>
        </div>
    </div>
</form>
<script>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</script><script>

    $(function(){
        $('#service-promo-modal').on('submit',function(){
            var promoEl = $('#service-promo-modal');
            var promoVal = promoEl.find('input[name=promo]').val();
        
            __tnt.subscription.promos.fetch(promoEl, promoVal);
            
            $("#service-promo-modal").find("[data-dismiss=modal]").on('click',function(){
                if(promoOpenedFromModal){ 
                    $("#template-metering").find('.metering-modal').first().modal();
                    promoOpenedFromModal = true;
                }
            });

            return false;
        });
    });
</script>

<script>
    $(function(){
        var i = 0;
        $('#subscription-modal').find('.subscription-services').find('.subscription-service').each(function(){
            $(this).attr('id','service-tab-'+i);
        
            $(this).find('.panel-heading h3').html('<a href="" data-toggle="collapse" data-parent="services-modal-collapsable-tabs" aria-expanded="false" aria-controls="service-tab-'+i+'">'+$(this).find('.panel-heading h3').text()+'</a>')
            $(this).find('.panel-body').addClass('panel-collapse collapse').attr('role','tabpanel');
            
            if(i==0){
                $(this).find('.panel-collapse').collapse('show');
                $(this).find('.panel-footer').show();
            }else{
                $(this).find('.panel-footer').hide();
            }
        
            i++;
        });
    
        $('.subscription-services-filter').hide();
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').css({'padding':'0px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a').css({'display':'block','padding':'10px 15px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a[data-toggle=collapse]').on('click',function(event){
            var id = $(this).attr('aria-controls');
            var open = $('#'+id).find('.collapse').hasClass('in');
            
            $('#subscription-modal').find('.subscription-services .subscription-service').each(function(){
                if(this.id == id){
                    $(this).find('.panel-collapse').collapse('show');
                    $(this).find('.panel-footer').show();
                }else{
                    $(this).find('.panel-collapse').collapse('hide');
                    $(this).find('.panel-footer').hide();
                }
            });
        });
        
        $('#asset-content').find('.subscription-required').find('.panel-footer').find('a[data-toggle=collapse]').on('click',function(event){
            $(this).parents('.panel-footer').find('.collapse.collapse-rates').collapse('toggle');
        });
        
        
        $('#asset-content').find('.meter-modal-open').on('click',function(){
            $('#asset-content').find('.alert.notification').css({'z-index':'900'});
            $("#template-metering").find('.metering-modal').first().modal();
        
        });
        
        $('#eedition-subscription').find('.meter-modal-open').on('click',function(){
            $("#template-metering").find('.metering-modal').first().modal();
        });
    });
    
</script>

    
</div>
<script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                
                bloxServiceIDs.push(3787);
                
                bloxServiceIDs.push(7650);
                
                bloxServiceIDs.push(3806);
                
                bloxServiceIDs.push(3793);
                
                bloxServiceIDs.push(3786);
                
                bloxServiceIDs.push(3794);
                
                bloxServiceIDs.push(3795);
                
                bloxServiceIDs.push(3796);
                
                bloxServiceIDs.push(3812);
                
                bloxServiceIDs.push(7488);
                
                bloxServiceIDs.push(4550);
                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/news\/cops_courts","refresh":false}' style="display:none;"></div>
        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container"><div id="asset-contribute-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-certificate tnt-fw"></i></div>
                <div class="asset-edit-message">You are the owner of this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" href="https://www.mtexpress.com/users/admin/contribute/article/?assetid=68a5078e-f56f-11eb-abc5-03a73030860a&assettype=article"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit Article</a>
                    
                        <a class="btn btn-danger btn-sm" href="https://www.mtexpress.com/users/admin/contribute/article/?from_section=/news/cops_courts"><i class="fas tnt-plus tnt-fw"></i> Add New Article</a>
                    
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.mtexpress.com/tncms/admin/editorial-asset/?edit=68a5078e-f56f-11eb-abc5-03a73030860a"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs" aria-label="Right Main Menu" aria-expanded="false" tabindex="-1">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/news"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/sun_valley/"  class="nav-link tnt-section-sun-valley">Sun Valley</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/ketchum/"  class="nav-link tnt-section-ketchum">Ketchum</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/hailey/"  class="nav-link tnt-section-hailey">Hailey</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/carey/"  class="nav-link tnt-section-carey">Carey</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/bellevue/"  class="nav-link tnt-section-bellevue">Bellevue</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/cops_courts/"  class="nav-link tnt-section-copscourts">Cops/Courts</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/blaine_county/"  class="nav-link tnt-section-blaine-county">Blaine County</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/state_regional/"  class="nav-link tnt-section-stateregional">State/Regional</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/environment/"  class="nav-link tnt-section-environment">Environment</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/recreation/"  class="nav-link tnt-section-recreation">Recreation</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/education"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/business/"  class="nav-link tnt-section-business">Business</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/elections/"  class="nav-link tnt-section-elections">Elections</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/transportation/"  class="nav-link tnt-section-transportation">Transportation</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/briefs"  class="nav-link tnt-section-briefs">Briefs</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/archives.html"  class="nav-link tnt-section-archives">Archives</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/submit_news"  class="nav-link tnt-section-submit-news-tip">Submit News Tip</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://idaho.column.us/"  target="_blank" rel="noopener" class="nav-link tnt-section-legal-notices">Legal Notices</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/coronavirus_covid-19_info/"  class="nav-link tnt-section-coronavirus-info">Coronavirus Info</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/wood_river_journal/"  class="nav-link tnt-section-wood-river-journal">Wood River Journal</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/features/"  class="nav-link tnt-section-features">Features</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/valley_people/"  class="nav-link tnt-section-valley-people">Valley People</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/news_of_record/"  class="nav-link tnt-section-news-of-record">News of Record</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/obituaries"  class="nav-link tnt-section-obituaries">Obituaries</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/mountain_town_news/"  class="nav-link tnt-section-mountain-town-news">Mountain Town News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/special_sections/"  class="nav-link tnt-section-special-section">Special Section</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/community/"  class="nav-link tnt-section-community">Community</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wood_river_journal/best_of_the_valley/"  class="nav-link tnt-section-best-of-the-valley">Best of the Valley</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/arts_and_events/"  class="nav-link tnt-section-arts-events">Arts & Events</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/arts_and_events/arts/"  class="nav-link tnt-section-arts">Arts</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/arts_and_events/music/"  class="nav-link tnt-section-music">Music</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/arts_and_events/events/"  class="nav-link tnt-section-events">Events</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/arts_and_events/around_town/"  class="nav-link tnt-section-around-town">Around Town</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-5" data-target="#mobile-nav-right_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/sports"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/high_school/"  class="nav-link tnt-section-high-school">High School</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/mountain_sports/"  class="nav-link tnt-section-mountain-sports">Mountain Sports</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/sports_summary/"  class="nav-link tnt-section-sports-summary">Sports Summary</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/sports_extras/"  class="nav-link tnt-section-sports-extras">Sports Extras</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/opinion"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editorials"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/guest_opinions/"  class="nav-link tnt-section-guest-opinions">Guest Opinions</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters-to-editor">Letters to Editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/cartoon/"  class="nav-link tnt-section-cartoon">Cartoon</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/poll"  class="nav-link tnt-section-weekly-poll">Weekly Poll</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-7" data-target="#mobile-nav-right_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="http://classified.mtexpress.com/showads"  target="_blank" rel="noopener" class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://classified.mtexpress.com/showads"  target="_blank" rel="noopener" class="nav-link tnt-section-classified-listings">Classified Listings</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://classified.mtexpress.com/placead"  target="_blank" rel="noopener" class="nav-link tnt-section-submit-an-ad">Submit an Ad</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://www.mtexpress.com/app/rate_card/Ratecardclass-2021.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-advertising-rates">Advertising Rates</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-8" data-target="#mobile-nav-right_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true"   class="nav-link tnt-section-advertise">Advertise</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://www.mtexpress.com/app/rate_card/Ratecard-2021.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-printed-advertising-rates">Printed Advertising Rates</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://www.mtexpress.com/app/rate_card/web advertising.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-online-advertising-rates">Online Advertising Rates</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/submit_news/request_advertising_information/"  class="nav-link tnt-section-request-information">Request Information</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-9" data-target="#mobile-nav-right_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/calendar"  class="nav-link tnt-section-calendar">Calendar</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/calendar"  class="nav-link tnt-section-calendar-listings">Calendar Listings</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/users/admin/calendar/event/"  class="nav-link tnt-section-submit-an-event">Submit an Event</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-10" data-target="#mobile-nav-right_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/obituaries"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/obituaries"  class="nav-link tnt-section-read-obituaries">Read Obituaries</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/announcements/obituary"  class="nav-link tnt-section-submit-an-obituary">Submit an Obituary</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/area_guides/"  class="nav-link tnt-section-area-guides">Area Guides</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/area_history/"  class="nav-link tnt-section-area-history">Area History</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="http://www.sunvalley-realestate.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-real-estate-guide">Real Estate Guide</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-14" data-target="#mobile-nav-right_menu-child-14">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="http://www.mtexpress.com/site/best_of_the_valley.html"  target="_blank" rel="noopener" class="nav-link tnt-section-best-of-the-valley">Best of the Valley</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-14" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.mtexpress.com/wood_river_journal/best_of_the_valley/how-you-voted/article_254c0df2-d148-11eb-8419-0fbf3dcb68dc.html#tncms-source=login"  target="_blank" rel="noopener" class="nav-link tnt-section-results">Results</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.mtexpress.com/special/page-1/page_24561b2b-ccba-5634-882e-b45922e88976.html"  target="_blank" rel="noopener" class="nav-link tnt-section-e-edition">E-edition</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.mtexpress.com/app/Best_of_the_Valley/best promo for business-color.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-printable-posters-for-your-window-color">Printable posters for your window (color)</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.mtexpress.com/app/Best_of_the_Valley/best promo for business-bw.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-printable-poster-for-your-window-bw">Printable poster for your window (b&w)</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/site/services/"  class="nav-link tnt-section-subscribe">Subscribe</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/eedition/"  class="nav-link tnt-section-e-edition">e-Edition</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-1312172" class="tncms-block">
        <div id="blox-ad-position-block-leaderboard-header1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-header","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list" ><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/services"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition"  tabindex="0">
                    <span class="nav-label">e-Edition</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit"  href="/site/forms/online_services"  tabindex="0">
                    <span class="nav-label">Submit</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-topbar-col-two" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-two-nav" class="tncms-region-nav"><ul id="topbar-col-two-nav_menu" class="list-inline nav-list" ></ul></div></div>
    <div id="topbar-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-topbar-col-three" class="tncms-region "><div id="tncms-block-1210229" class="tncms-block"><div id="user-controls-1210229" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.mtexpress.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1210229').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.mtexpress.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.mtexpress.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.mtexpress.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1210229').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.mtexpress.com/users/logout/" id="user-logout-form-1210229"><input type="hidden" name="referer_url" value="https://www.mtexpress.com/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                  
<div class="row header-advertising">
<div class="col-md-8 col-lg-9"><div id="tncms-region-option-header-ad-left" class="tncms-region "></div></div>
<div class="col-md-4 col-lg-3"><div id="tncms-region-option-header-ad-right" class="tncms-region "><div id="tncms-block-1210232" class="tncms-block"><div id="weather-1210232" class="weather-current size-large pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=83353" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-day-cloudy"></span>
                </span>
                <span class="pull-left temp-desc large">
                    <span class="temp">78&deg;</span>
                    
                        <span class="cond">Partly Cloudy <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="83353"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a id="weather_zip_toggle_1210232" class="pull-right zip-update-link" aria-label="weather_zip_toggle"><span class="fas tnt-cog"></span></a><h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Sun Valley, ID
                                
                                 <small>(83353)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Considerable clouds this morning. Some decrease in clouds later in the day. A stray shower or thunderstorm is possible. High 84F. Winds SSE at 10 to 15 mph..</p>
                            <h5>Tonight</h5>
                            <p>Partly cloudy skies. A stray shower or thunderstorm is possible. Low 53F. Winds W at 5 to 10 mph.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: August 5, 2021 @ 11:59 am</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=83353"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
</div>

                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "></div></div>
    <div id="masthead-col-two" class="col-md-9 col-sm-9"><div id="tncms-region-masthead-col-two" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "><div id="tncms-block-1210206" class="tncms-block center-image"><section id="block-1210206" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=150%2C24 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=200%2C31 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=225%2C35 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=300%2C47 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=400%2C63 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=540%2C85 540w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=640%2C100 640w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=750%2C118 750w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png?resize=990%2C155 990w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/7b2695c6-d698-11e6-86f2-dff2cad2196c.png 1035w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="1000"
                height="157"
                alt=""></a></div></section></div></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button  type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right" aria-label="Right Main Menu" aria-expanded="false" >
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>

                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1210207" class="tncms-block"><section id="block-1210207" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/f1b90b88-d5d1-11ea-90dd-eb8bc0dcdb5e.png?resize=150%2C27 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/f1b90b88-d5d1-11ea-90dd-eb8bc0dcdb5e.png?resize=200%2C35 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/f1b90b88-d5d1-11ea-90dd-eb8bc0dcdb5e.png?resize=225%2C40 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/f1b90b88-d5d1-11ea-90dd-eb8bc0dcdb5e.png 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="300"
                height="53"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news"  tabindex="0">
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-sun-valley"  href="/news/sun_valley/"  tabindex="0">
                    <span class="nav-label">Sun Valley</span>
                </a></li><li>
                <a class="nav-link   tnt-section-ketchum"  href="/news/ketchum/"  tabindex="0">
                    <span class="nav-label">Ketchum</span>
                </a></li><li>
                <a class="nav-link   tnt-section-hailey"  href="/news/hailey/"  tabindex="0">
                    <span class="nav-label">Hailey</span>
                </a></li><li>
                <a class="nav-link   tnt-section-carey"  href="/news/carey/"  tabindex="0">
                    <span class="nav-label">Carey</span>
                </a></li><li>
                <a class="nav-link   tnt-section-bellevue"  href="/news/bellevue/"  tabindex="0">
                    <span class="nav-label">Bellevue</span>
                </a></li><li>
                <a class="nav-link   tnt-section-copscourts"  href="/news/cops_courts/"  tabindex="0">
                    <span class="nav-label">Cops/Courts</span>
                </a></li><li>
                <a class="nav-link   tnt-section-blaine-county"  href="/news/blaine_county/"  tabindex="0">
                    <span class="nav-label">Blaine County</span>
                </a></li><li>
                <a class="nav-link   tnt-section-stateregional"  href="/news/state_regional/"  tabindex="0">
                    <span class="nav-label">State/Regional</span>
                </a></li><li>
                <a class="nav-link   tnt-section-environment"  href="/news/environment/"  tabindex="0">
                    <span class="nav-label">Environment</span>
                </a></li><li>
                <a class="nav-link   tnt-section-recreation"  href="/news/recreation/"  tabindex="0">
                    <span class="nav-label">Recreation</span>
                </a></li><li>
                <a class="nav-link   tnt-section-education"  href="/news/education"  tabindex="0">
                    <span class="nav-label">Education</span>
                </a></li><li>
                <a class="nav-link   tnt-section-business"  href="/news/business/"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-elections"  href="/news/elections/"  tabindex="0">
                    <span class="nav-label">Elections</span>
                </a></li><li>
                <a class="nav-link   tnt-section-transportation"  href="/news/transportation/"  tabindex="0">
                    <span class="nav-label">Transportation</span>
                </a></li><li>
                <a class="nav-link   tnt-section-briefs"  href="/news/briefs"  tabindex="0">
                    <span class="nav-label">Briefs</span>
                </a></li><li>
                <a class="nav-link   tnt-section-archives"  href="/site/archives.html"  tabindex="0">
                    <span class="nav-label">Archives</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-news-tip"  href="/site/forms/online_services/submit_news"  tabindex="0">
                    <span class="nav-label">Submit News Tip</span>
                </a></li><li>
                <a class="nav-link   tnt-section-legal-notices"  href="https://idaho.column.us/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Legal Notices</span>
                </a></li><li>
                <a class="nav-link   tnt-section-coronavirus-info"  href="/news/coronavirus_covid-19_info/"  tabindex="0">
                    <span class="nav-label">Coronavirus Info</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-wood-river-journal"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/wood_river_journal/"  tabindex="0">
                    <span class="nav-label">Wood River Journal</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-features"  href="/wood_river_journal/features/"  tabindex="0">
                    <span class="nav-label">Features</span>
                </a></li><li>
                <a class="nav-link   tnt-section-valley-people"  href="/wood_river_journal/valley_people/"  tabindex="0">
                    <span class="nav-label">Valley People</span>
                </a></li><li>
                <a class="nav-link   tnt-section-news-of-record"  href="/wood_river_journal/news_of_record/"  tabindex="0">
                    <span class="nav-label">News of Record</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-mountain-town-news"  href="/wood_river_journal/mountain_town_news/"  tabindex="0">
                    <span class="nav-label">Mountain Town News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-special-section"  href="/wood_river_journal/special_sections/"  tabindex="0">
                    <span class="nav-label">Special Section</span>
                </a></li><li>
                <a class="nav-link   tnt-section-community"  href="/wood_river_journal/community/"  tabindex="0">
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link   tnt-section-best-of-the-valley"  href="/wood_river_journal/best_of_the_valley/"  tabindex="0">
                    <span class="nav-label">Best of the Valley</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-arts-events"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/arts_and_events/"  tabindex="0">
                    <span class="nav-label">Arts & Events</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-arts"  href="/arts_and_events/arts/"  tabindex="0">
                    <span class="nav-label">Arts</span>
                </a></li><li>
                <a class="nav-link   tnt-section-music"  href="/arts_and_events/music/"  tabindex="0">
                    <span class="nav-label">Music</span>
                </a></li><li>
                <a class="nav-link   tnt-section-events"  href="/arts_and_events/events/"  tabindex="0">
                    <span class="nav-label">Events</span>
                </a></li><li>
                <a class="nav-link   tnt-section-around-town"  href="/arts_and_events/around_town/"  tabindex="0">
                    <span class="nav-label">Around Town</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-high-school"  href="/sports/high_school/"  tabindex="0">
                    <span class="nav-label">High School</span>
                </a></li><li>
                <a class="nav-link   tnt-section-mountain-sports"  href="/sports/mountain_sports/"  tabindex="0">
                    <span class="nav-label">Mountain Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports-summary"  href="/sports/sports_summary/"  tabindex="0">
                    <span class="nav-label">Sports Summary</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports-extras"  href="/sports/sports_extras/"  tabindex="0">
                    <span class="nav-label">Sports Extras</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-editorials"  href="/opinion/editorials"  tabindex="0">
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link   tnt-section-guest-opinions"  href="/opinion/guest_opinions/"  tabindex="0">
                    <span class="nav-label">Guest Opinions</span>
                </a></li><li>
                <a class="nav-link   tnt-section-letters-to-editor"  href="/opinion/letters_to_editor/"  tabindex="0">
                    <span class="nav-label">Letters to Editor</span>
                </a></li><li>
                <a class="nav-link   tnt-section-cartoon"  href="/opinion/cartoon/"  tabindex="0">
                    <span class="nav-label">Cartoon</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weekly-poll"  href="/opinion/poll"  tabindex="0">
                    <span class="nav-label">Weekly Poll</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="http://classified.mtexpress.com/showads"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-classified-listings"  href="http://classified.mtexpress.com/showads"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Classified Listings</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-an-ad"  href="https://classified.mtexpress.com/placead"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Submit an Ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-advertising-rates"  href="http://www.mtexpress.com/app/rate_card/Ratecardclass-2021.pdf"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Advertising Rates</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-advertise"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0">
                    <span class="nav-label">Advertise</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-printed-advertising-rates"  href="http://www.mtexpress.com/app/rate_card/Ratecard-2021.pdf"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Printed Advertising Rates</span>
                </a></li><li>
                <a class="nav-link   tnt-section-online-advertising-rates"  href="http://www.mtexpress.com/app/rate_card/web advertising.pdf"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Online Advertising Rates</span>
                </a></li><li>
                <a class="nav-link   tnt-section-request-information"  href="/site/forms/online_services/submit_news/request_advertising_information/"  tabindex="0">
                    <span class="nav-label">Request Information</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-calendar"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/calendar"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-calendar-listings"  href="/calendar"  tabindex="0">
                    <span class="nav-label">Calendar Listings</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-an-event"  href="/users/admin/calendar/event/"  tabindex="0">
                    <span class="nav-label">Submit an Event</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-obituaries"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/obituaries"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a><ul id="main-nav_menu-child-10" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-read-obituaries"  href="/obituaries"  tabindex="0">
                    <span class="nav-label">Read Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-an-obituary"  href="/site/forms/announcements/obituary"  tabindex="0">
                    <span class="nav-label">Submit an Obituary</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-area-guides"  href="/area_guides/"  tabindex="0">
                    <span class="nav-label">Area Guides</span>
                </a></li><li>
                <a class="nav-link   tnt-section-area-history"  href="/area_history/"  tabindex="0">
                    <span class="nav-label">Area History</span>
                </a></li><li>
                <a class="nav-link   tnt-section-real-estate-guide"  href="http://www.sunvalley-realestate.com/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Real Estate Guide</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-best-of-the-valley"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="http://www.mtexpress.com/site/best_of_the_valley.html"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Best of the Valley</span>
                </a><ul id="main-nav_menu-child-14" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-results"  href="https://www.mtexpress.com/wood_river_journal/best_of_the_valley/how-you-voted/article_254c0df2-d148-11eb-8419-0fbf3dcb68dc.html#tncms-source=login"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Results</span>
                </a></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="https://www.mtexpress.com/special/page-1/page_24561b2b-ccba-5634-882e-b45922e88976.html"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">E-edition</span>
                </a></li><li>
                <a class="nav-link   tnt-section-printable-posters-for-your-window-color"  href="https://www.mtexpress.com/app/Best_of_the_Valley/best promo for business-color.pdf"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Printable posters for your window (color)</span>
                </a></li><li>
                <a class="nav-link   tnt-section-printable-poster-for-your-window-bw"  href="https://www.mtexpress.com/app/Best_of_the_Valley/best promo for business-bw.pdf"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Printable poster for your window (b&w)</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/services/"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition/"  tabindex="0">
                    <span class="nav-label">e-Edition</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
              


            <div class="option-under-nav container">
            <div class="row">
                <div class="col-md-3"><div id="tncms-region--option-left" class="tncms-region "><div id="tncms-block-1210216" class="tncms-block hidden-xs hidden-sm hidden-md"><div class="follow-links-1210216 default">
    
    <section id="block-1210216" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/MountainExpress/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/IdahoMtExpress" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
            <li>
                <a href="https://www.instagram.com/idmtexpress/" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.mtexpress.com",
  "sameAs" : ["https://www.facebook.com/MountainExpress/","https://twitter.com/IdahoMtExpress","https://www.instagram.com/idmtexpress/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                <div class="col-md-6"><div id="tncms-region--option-middle" class="tncms-region "><div id="tncms-block-1210230" class="tncms-block hidden-md hidden-lg"><div id="user-controls-1210230" class="user-controls show-onload clearfix pull-right"><div class="large-user-avatar pull-left">
            <div class="tn-user-avatar pull-left"><!-- user avatar --></div>
        </div>
        <div class="large-user-controls pull-left">
            <div class="user-welcome">Welcome, <span class="tn-user-screenname">Guest</span></div><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html" class=" user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html" class=" user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.mtexpress.com/users/admin/">Dashboard</a></li>
                    <li><a class="logout-btn" onclick="document.getElementById('user-logout-form-1210230').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><span class="user-control-link">My Account</span>
                    <b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.mtexpress.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.mtexpress.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.mtexpress.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1210230').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

    </div>

<form method="post" action="https://www.mtexpress.com/users/logout/" id="user-logout-form-1210230"><input type="hidden" name="referer_url" value="https://www.mtexpress.com/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1219208" class="tncms-block"><p style="text-align:center;">Serving Sun Valley, Ketchum, Hailey, Bellevue and Carey</p>
<p style="text-align:center;margin-top:-10px;">August 5, 2021</p></div></div></div>
                <div class="col-md-3"><div id="tncms-region--option-right" class="tncms-region "><div id="tncms-block-1210213" class="tncms-block"><section id="block-1210213" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1210213" class="search-form-container card clearfix text-center hidden-print well">
    <form id="site-search-1210213" aria-labelledby="site-search-button-1210213" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal ">
        <input id="site-search-1210213-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1210213-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-1210213" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1210213-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1210213').submit();
        return false;
    });

    $('#site-search-1210213').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1210213 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1210213 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1210213-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
            </div>
            </div>



        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1210184" class="tncms-block"><section id="block-1210184" class="block emphasis-h2   " ><div class="clearfix"></div><div class="breaking show-images">
        <div class="breaking-container clearfix">
            <div id="breaking-title-1210184" class="breaking-title text-left light">
                <h4>Breaking News</h4>
            </div>
            <div id="breaking-content-1210184" class="breaking-content card-img-sm card-compact card-bg-color">
                        <article id="card-summary-1210184-76333a28-f552-11eb-8c01-93f5d36d7f47" class="tnt-asset-type-article clearfix card summary has-image inherit letterbox-style-default  tnt-section-news">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-76333a28-f552-11eb-8c01-93f5d36d7f47 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/trail-creek-road-reopens/article_76333a28-f552-11eb-8c01-93f5d36d7f47.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Trail Creek Road reopens"
                            class="img-responsive lazyload full default"
                            width="640"
                            height="360"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/0e/20e1d3ca-f3e7-11eb-a089-135f64dfef82/61087c3f79257.image.jpg?crop=640%2C360%2C0%2C60&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/0e/20e1d3ca-f3e7-11eb-a089-135f64dfef82/61087c3f79257.image.jpg?crop=640%2C360%2C0%2C60&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/0e/20e1d3ca-f3e7-11eb-a089-135f64dfef82/61087c3f79257.image.jpg?crop=640%2C360%2C0%2C60&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/0e/20e1d3ca-f3e7-11eb-a089-135f64dfef82/61087c3f79257.image.jpg?crop=640%2C360%2C0%2C60&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/0e/20e1d3ca-f3e7-11eb-a089-135f64dfef82/61087c3f79257.image.jpg?crop=640%2C360%2C0%2C60&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/0e/20e1d3ca-f3e7-11eb-a089-135f64dfef82/61087c3f79257.image.jpg?crop=640%2C360%2C0%2C60&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/0e/20e1d3ca-f3e7-11eb-a089-135f64dfef82/61087c3f79257.image.jpg?crop=640%2C360%2C0%2C60&resize=640%2C360&order=crop%2Cresize 640w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/trail-creek-road-reopens/article_76333a28-f552-11eb-8c01-93f5d36d7f47.html" class="tnt-asset-link">
        

        
            Trail Creek Road reopens</a></h3></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2021-08-04T12:33:00-06:00" class="tnt-date asset-date text-muted">23 hrs ago</time></li><li class="card-comment-count"></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                    </div>
        </div>
    </div></section></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1210117" class="tncms-block">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1210118" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-tile-header1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-tile-header","slot":"1","fold":"","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><div id="modal-image-e4b319f0-746b-11ea-8ae4-03b246045c48" class="modal fullscreen in modal-image image-mugshot modal-e4b319f0-746b-11ea-8ae4-03b246045c48" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=400%2C400"
                    srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=150%2C150 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=200%2C200 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=225%2C225 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=300%2C300 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=400%2C400 400w"
                    sizes="100vw"
                    
                    width="400"
                    height="400"
                    alt="Blaine County Sheriff Logo"
                    class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-e4b319f0-746b-11ea-8ae4-03b246045c48" data-target=".caption-inner-modal-image-e4b319f0-746b-11ea-8ae4-03b246045c48">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-e4b319f0-746b-11ea-8ae4-03b246045c48 collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.mtexpress.com%2Fblaine-county-sheriff-logo%2Fimage_e4b319f0-746b-11ea-8ae4-03b246045c48.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/blaine-county-sheriff-logo/image_e4b319f0-746b-11ea-8ae4-03b246045c48.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e4b319f0-746b-11ea-8ae4-03b246045c48"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Blaine%20County%20Sheriff%20Logo&via=IdahoMtExpress&url=https%3A%2F%2Fwww.mtexpress.com%2Fblaine-county-sheriff-logo%2Fimage_e4b319f0-746b-11ea-8ae4-03b246045c48.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/blaine-county-sheriff-logo/image_e4b319f0-746b-11ea-8ae4-03b246045c48.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e4b319f0-746b-11ea-8ae4-03b246045c48"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.mtexpress.com/blaine-county-sheriff-logo/image_e4b319f0-746b-11ea-8ae4-03b246045c48.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/blaine-county-sheriff-logo/image_e4b319f0-746b-11ea-8ae4-03b246045c48.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e4b319f0-746b-11ea-8ae4-03b246045c48"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.mtexpress.com/tncms/asset/editorial/e4b319f0-746b-11ea-8ae4-03b246045c48" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"e4b319f0-746b-11ea-8ae4-03b246045c48"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Mountain%20Express%5D%20Blaine%20County%20Sheriff%20Logo&body=https%3A%2F%2Fwww.mtexpress.com%2Fblaine-county-sheriff-logo%2Fimage_e4b319f0-746b-11ea-8ae4-03b246045c48.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"e4b319f0-746b-11ea-8ae4-03b246045c48"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/blaine-county-sheriff-logo/image_e4b319f0-746b-11ea-8ae4-03b246045c48.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e4b319f0-746b-11ea-8ae4-03b246045c48"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-e4b319f0-746b-11ea-8ae4-03b246045c48-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="e4b319f0-746b-11ea-8ae4-03b246045c48" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="e4b319f0-746b-11ea-8ae4-03b246045c48" class="save-list-e4b319f0-746b-11ea-8ae4-03b246045c48-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="e4b319f0-746b-11ea-8ae4-03b246045c48" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-e4b319f0-746b-11ea-8ae4-03b246045c48 img { max-height: 400px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-68a5078e-f56f-11eb-abc5-03a73030860a" class="asset article-default"  data-url="https://www.mtexpress.com/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="A Nampa man died Tuesday night following a motorcycle crash on state Highway 75 north of the Smiley Creek Store. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=400%2C400">
            <meta itemprop="width" content="400">
            <meta itemprop="height" content="400">
        </div>
        <meta itemprop="name" content="mtexpress.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.mtexpress.com/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html" />
    <style>
                .asset-paging .direction {
                    color: #c00826;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.mtexpress.com\/tncms\/search\/mlt\/?origin=68a5078e-f56f-11eb-abc5-03a73030860a&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-68a5078e-f56f-11eb-abc5-03a73030860a" class="asset-paging">
                <div id="paging-prev-68a5078e-f56f-11eb-abc5-03a73030860a" class="paging-link prev offset"></div>
                <div id="paging-next-68a5078e-f56f-11eb-abc5-03a73030860a" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper no-flags">
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            Nampa man dies in Smiley Creek crash
        </span>
    </h1>
    
    <h2 itemprop="alternativeHeadline" class="subhead">
            <span>Todd Michael Fowler appears to have lost control of motorcycle, BCSO says</span>
        </h2><div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-popup-17563238-605f-11e4-b6f1-ebba4f77c657-asset-68a5078e-f56f-11eb-abc5-03a73030860a" class="tnt-byline asset-byline" rel="popover" itemprop="author"><a href="https://www.mtexpress.com/users/profile/Express%20Staff">Express Staff</a></span>
                
                    <div id="author-popup-17563238-605f-11e4-b6f1-ebba4f77c657-asset-68a5078e-f56f-11eb-abc5-03a73030860a-content" class="hide">
                        <article class="clearfix card author popup-content card-author-17563238-605f-11e4-b6f1-ebba4f77c657">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.mtexpress.com/users/profile/Express%20Staff" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        
    
        <img
            alt="Express Staff"
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
            data-src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/avatars/1/75/632/17563238-605f-11e4-b6f1-ebba4f77c657.198d0eb5e88e0aba3d32ff1967baa949.png?_dc=1445446396"
            class="img-responsive lazyload tnt-user-avatar" />
    

                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.mtexpress.com/users/profile/Express%20Staff" rel="author" class="tnt-user-profile-link tnt-user-name">Express Staff</a>
                                </h4>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="mailto:news@mtexpress.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul></div>
                        </div>
                    </div>
                </div>
            </article>
                    </div>
                    <script>
                        $('#author-popup-17563238-605f-11e4-b6f1-ebba4f77c657-asset-68a5078e-f56f-11eb-abc5-03a73030860a').popover({
                            content: $('#author-popup-17563238-605f-11e4-b6f1-ebba4f77c657-asset-68a5078e-f56f-11eb-abc5-03a73030860a-content').html(),
                            container: 'body',
                            html:true,
                            sanitize: false,
                            trigger:'hover',
                            placement:'top',
                            delay:{ show:100, hide:200 }
                        });
                    </script>
                </li>
        
        
            <li class="visible-print">
        <time datetime="2021-08-04T15:45:00-06:00" class="tnt-date asset-date text-muted">
            Aug 4, 2021
        </time></li>
            <li class="hidden-print">
        <time datetime="2021-08-04T15:45:00-06:00" class="tnt-date asset-date text-muted">20 hrs ago</time></li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-08-04T15:45:00-06:00">
    <meta itemprop="datePublished" content="2021-08-04T15:45:00-06:00">
    <meta itemprop="dateModified" content="2021-08-04T15:45:00-06:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Nampa%20man%20dies%20in%20Smiley%20Creek%20crash&via=IdahoMtExpress&url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.mtexpress.com/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.mtexpress.com/tncms/asset/editorial/68a5078e-f56f-11eb-abc5-03a73030860a" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Mountain%20Express%5D%20Nampa%20man%20dies%20in%20Smiley%20Creek%20crash&body=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    
        <div class="asset-related-mugshot inline-asset inline-image hover-expand visible-xs" data-photo-target=".photo-e4b319f0-746b-11ea-8ae4-03b246045c48" data-toggle="modal" data-instance="#gallery-items-68a5078e-f56f-11eb-abc5-03a73030860a-photo-modal" data-target="#photo-carousel-68a5078e-f56f-11eb-abc5-03a73030860a">
            <span class="expand"><span class="fas tnt-camera"></span>
            </span><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="400">
            <meta itemprop="height" content="400">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Blaine County Sheriff Logo"
                            class="img-responsive lazyload full default"
                            width="400"
                            height="400"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=150%2C150 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=200%2C200 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=225%2C225 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=300%2C300 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=400%2C400 400w" />
            </div>
                
                
            </div>
            
                
                
            
        </figure></div>
    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="68a5078e-f56f-11eb-abc5-03a73030860a">
                

                <div class="row">
                    <div class="col-lg-8 col-md-12 col-sm-8 col-lg-push-4 col-md-push-0 col-sm-push-4" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Nampa%20man%20dies%20in%20Smiley%20Creek%20crash&via=IdahoMtExpress&url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.mtexpress.com/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.mtexpress.com/tncms/asset/editorial/68a5078e-f56f-11eb-abc5-03a73030860a" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Mountain%20Express%5D%20Nampa%20man%20dies%20in%20Smiley%20Creek%20crash&body=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-68a5078e-f56f-11eb-abc5-03a73030860a-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="68a5078e-f56f-11eb-abc5-03a73030860a" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="68a5078e-f56f-11eb-abc5-03a73030860a" class="save-list-68a5078e-f56f-11eb-abc5-03a73030860a-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="68a5078e-f56f-11eb-abc5-03a73030860a" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  p402_premium subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p>A Nampa man died Tuesday night following a motorcycle crash on state Highway 75 north of the Smiley Creek Store.</p></div><div class="subscriber-preview"><p>Fifty-one-year-old Todd Michael Fowler succumbed to his injuries after he was airlifted to Saint Alphonsus Regional Medical Center in Boise, according to Blaine County Sheriff Steve Harkins.</p></div><div class="subscriber-preview"><p>Fowler was headed south on a 2002 Honda motorcycle when he lost control making a turn near milepost 166 and went off the road into the sagebrush, Harkins said. First responders found Fowler about 40 yards from the highway, according to emergency communications monitored by the Express on Tuesday night.</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/cops_courts","refresh":true}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top-asset', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>By 8:03 p.m., about a half hour after the initial call, an air ambulance from Air St. Luke’s was en route to the scene. Emergency personnel initiated resuscitation efforts shortly thereafter, according to scanner traffic.</p></div><div class="subscriber-only"><p>Fowler was wearing a helmet, Harkins said.</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/cops_courts","refresh":true}' style="display:none;"></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Nampa%20man%20dies%20in%20Smiley%20Creek%20crash&via=IdahoMtExpress&url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.mtexpress.com/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.mtexpress.com/tncms/asset/editorial/68a5078e-f56f-11eb-abc5-03a73030860a" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Mountain%20Express%5D%20Nampa%20man%20dies%20in%20Smiley%20Creek%20crash&body=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/cops_courts/nampa-man-dies-in-smiley-creek-crash/article_68a5078e-f56f-11eb-abc5-03a73030860a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"68a5078e-f56f-11eb-abc5-03a73030860a"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-68a5078e-f56f-11eb-abc5-03a73030860a-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="68a5078e-f56f-11eb-abc5-03a73030860a" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="68a5078e-f56f-11eb-abc5-03a73030860a" class="save-list-68a5078e-f56f-11eb-abc5-03a73030860a-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="68a5078e-f56f-11eb-abc5-03a73030860a" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div><div class="col-lg-4 col-md-12 col-sm-4 col-md-pull-0 col-sm-pull-8 col-lg-pull-8" data-subscription-required-remove>
                            <aside class="related-sidebar default  p402_hide subscriber-hide">

                                

                                <div id="tncms-region-article_aside_top" class="tncms-region hidden-print"></div>

                                
                                

                                

                                

                                

                                
                                                <div class="asset-related-mugshot inline-asset inline-image hidden-xs">
                                                    <div class="hover-expand" data-toggle="modal" data-target=".modal-e4b319f0-746b-11ea-8ae4-03b246045c48">
                                                        <span class="expand"><span class="fas tnt-camera"></span>
                                                        </span><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="400">
            <meta itemprop="height" content="400">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Blaine County Sheriff Logo"
                            class="img-responsive lazyload full default"
                            width="400"
                            height="400"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=150%2C150 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=200%2C200 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=225%2C225 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=300%2C300 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/4b/e4b319f0-746b-11ea-8ae4-03b246045c48/5e851c294ba86.image.jpg?resize=400%2C400 400w" />
            </div>
                
                
            </div>
            
                
                
            
        </figure></div></div>
                                            

                                

                                

                                

                                

                                

                                

                                <div id="tncms-region-article_aside_bottom" class="tncms-region hidden-print"></div>

                                

                                <div id="article-aside-sticky-spacer"><div id="tncms-region-article_aside_sticky" class="tncms-region hidden-print"></div></div>

                            </aside>
                        </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22steve%20harkins%22#tncms-source=keyword" class="tag-steve-harkins label label-default" >Steve Harkins</a>
            </li> <li>
                <a href="/search/?k=%22saint%20alphonsus%20regional%20medical%20center%22#tncms-source=keyword" class="tag-saint-alphonsus-regional-medical-center label label-default" >Saint Alphonsus Regional Medical Center</a>
            </li> <li>
                <a href="/search/?k=%22todd%20michael%20fowler%22#tncms-source=keyword" class="tag-todd-michael-fowler label label-default" >Todd Michael Fowler</a>
            </li> <li>
                <a href="/search/?k=%22smiley%20creek%22#tncms-source=keyword" class="tag-smiley-creek label label-default" >Smiley Creek</a>
            </li> <li>
                <a href="/search/?k=%22nampa%22#tncms-source=keyword" class="tag-nampa label label-default" >Nampa</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    
                        
                            <div class="asset-author">
                                <article class="clearfix card author  card-author-17563238-605f-11e4-b6f1-ebba4f77c657">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.mtexpress.com/users/profile/Express%20Staff" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        
    
        <img
            alt="Express Staff"
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
            data-src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/avatars/1/75/632/17563238-605f-11e4-b6f1-ebba4f77c657.198d0eb5e88e0aba3d32ff1967baa949.png?_dc=1445446396"
            class="img-responsive lazyload tnt-user-avatar" />
    

                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.mtexpress.com/users/profile/Express%20Staff" rel="author" class="tnt-user-profile-link tnt-user-name">Express Staff</a>
                                </h4>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="mailto:news@mtexpress.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul><div class="followed-notify-link hidden-print"><button id="follow-author-17563238-605f-11e4-b6f1-ebba4f77c657" class="followed-notify-btn btn btn-success btn-sm" disabled data-params="?a=17563238-605f-11e4-b6f1-ebba4f77c657&amp;s=start_time&amp;sd=desc" data-subject="Express Staff" data-description="Whenever Express Staff posts new content, you'll get an email delivered to your inbox with a link." data-name="Express Staff notification" data-author-id="17563238-605f-11e4-b6f1-ebba4f77c657" data-user-url="https://www.mtexpress.com/users/">
        <i class="fas tnt-star"></i> Follow Express Staff
    </button><template id="follow-this-modal-logged-in">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Get email notifications on {{subject}} daily!</h4>
                    </div>
                    <div class="modal-body">
                        <div class="alert alert-success" style="display:none;">
                            Your notification has been saved.
                        </div>
                        <div class="alert alert-danger" style="display:none;">
                            There was a problem saving your notification.
                        </div>
                        <p class="notification-description">{{description}}</p>
                        <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                        <form id="follow-notify-form" class="follow-notify-form" action="{{action}}" method="post">
                            <input class="input-notification-name" type="hidden" name="title" value="{{title}}">
                            <div class="row">
                                <div class="col-sm-6">
                                    <button class="btn btn-success btn-block follow-btn" >
                                        <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                    </button>
                                </div>
                                <div class="col-sm-6">
                                    <a class="btn btn-default btn-block" href="https://www.mtexpress.com/users/admin/savedsearch/">Manage followed notifications</a>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </template>

        <template id="follow-this-modal-logged-out">
            <div class="modal-dialog modal-sm">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Followed notifications</h4>
                    </div>
                    <div class="modal-body">
                        <div class="user-login padding-bottom">
                            <h4>Please log in to use this feature</h4>
                            <a class="btn btn-block btn-primary" href="https://www.mtexpress.com/users/login/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html" rel="nofollow">Log In</a>
                        </div>
                        <div class="user-signup">
                            <strong>Don't have an account?</strong> <a href="https://www.mtexpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.mtexpress.com%2Fnews%2Fcops_courts%2Fnampa-man-dies-in-smiley-creek-crash%2Farticle_68a5078e-f56f-11eb-abc5-03a73030860a.html" rel="nofollow">Sign Up Today</a>
                        </div>
                    </div>
                </div>
            </div>
        </template>

        <div id="follow-this-modal" class="modal fade follow-this-modal">
            <div class="modal-dialog"></div>
        </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
                            </div>
                        
                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print"></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/cops_courts","refresh":true}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1219539" class="tncms-block card-grid-increase-max-height card-grid-hide-asset-content"><section id="block-1219539" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1219539 ">
        <div class="block-title-inner">
            <h4>
                
                Current E-Edition
                
            </h4>
        </div>
    </div></div><div class="card-grid   card-img-lg card-bg-color card-heading-color card-compact">
        
        
            <div class=" ">
        
        <div class="  last-grid-item">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-1219539-6689de36-6044-5445-8513-82badc8a5bac" class="tnt-asset-type-edition clearfix card summary has-image image-top inherit letterbox-style-default  tnt-section-eedition">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-6689de36-6044-5445-8513-82badc8a5bac media-preview edition-asset" data-aspect="original"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/eedition/wednesday-august-4-2021/edition_6689de36-6044-5445-8513-82badc8a5bac.html" class="tnt-asset-link" >                
                
                
                
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Wednesday, August 4, 2021"
                    class="img-responsive lazyload  letterbox default"
                    width="775"
                    height="1198"
                    data-src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/eedition/6/68/6689de36-6044-5445-8513-82badc8a5bac/6109d73d85efc.preview-775.jpg?resize=775%2C1198" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/eedition/wednesday-august-4-2021/edition_6689de36-6044-5445-8513-82badc8a5bac.html" class="tnt-asset-link">
        

        
            Wednesday, August 4, 2021</a></h3></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
            
        
        
        
        
        </div>
        </div></section></div><div id="tncms-block-1227526" class="tncms-block">
        <div id="blox-ad-position-block-side-rectangle1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-side-rectangle","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1506677" class="tncms-block">
        <div id="blox-ad-position-block-lower-rectangle1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-lower-rectangle","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1210186" class="tncms-block"><section id="block-1210186" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1210186 ">
        <div class="block-title-inner">
            <h4>
                
                Online Poll
                
            </h4>
        </div>
    </div></div>
        
            
                <div class="poll-panel panel">
                    <div class="panel-body">
            
            <h4 class="tnt-headline ">
        
             <a href="/opinion/poll/how-has-the-covid-19-pandemic-affected-your-family-s-income/poll_3aca1e40-f4b5-11eb-bd75-5b338dd6ae43.html" class="tnt-asset-link">
        

        
            How has the COVID-19 pandemic affected your family’s income?</a></h4>
            <div id="poll-3aca1e40-f4b5-11eb-bd75-5b338dd6ae43-1210186" data-charted="false" class="card poll-content"><div class="loading-poll hide-onload text-center"><i class="fas tnt-spinner tnt-spin tnt-2x"></i></div>
            <div class="show-onload">
                <div id="poll-3aca1e40-f4b5-11eb-bd75-5b338dd6ae43-1210186-your-vote-container" class="alert alert-warning hide">
                    <strong>You voted:</strong> <span id="poll-3aca1e40-f4b5-11eb-bd75-5b338dd6ae43-1210186-your-vote"></span>
                </div>
                <div id="poll-3aca1e40-f4b5-11eb-bd75-5b338dd6ae43-1210186-results" class="tnt-poll-results hide"></div>
                <div id="poll-3aca1e40-f4b5-11eb-bd75-5b338dd6ae43-1210186-container">
                    <form id="poll-3aca1e40-f4b5-11eb-bd75-5b338dd6ae43-1210186-form" class="tnt-poll-form" role="form" method="post" action="/opinion/poll/how-has-the-covid-19-pandemic-affected-your-family-s-income/poll_3aca1e40-f4b5-11eb-bd75-5b338dd6ae43.html">
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="We’re making more now than before" value="C9773E09-BF00-0001-E5C51E669C40E4C0"> We’re making more now than before
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="We’re making about the same" value="C9773E0D-3210-0001-C054C5B614F01DF5"> We’re making about the same
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="We’re making less than before" value="C9773E11-1B00-0001-9A8D146E4F401148"> We’re making less than before
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Not applicable, I don’t work" value="C9773E14-9C00-0001-E66C12B1681016E1"> Not applicable, I don’t work
                                </label>
                            </div>
                        
                        <button type="submit" class="btn btn-primary" >Vote</button>
                        <button id="poll-3aca1e40-f4b5-11eb-bd75-5b338dd6ae43-1210186-get-results" class="btn btn-default" >View Results</button>
                    </form>
                </div>
            </div>
            <div id="poll-3aca1e40-f4b5-11eb-bd75-5b338dd6ae43-1210186-back-vote" class="padding-top hide">
                <button id="poll-3aca1e40-f4b5-11eb-bd75-5b338dd6ae43-1210186-back-btn" class="btn btn-default">Back</button>
            </div>
        </div>
            
                    </div>
                </div>
            
        
    </section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/cops_courts","refresh":true}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1210282" class="tncms-block"><section id="block-1210282" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1210282 dark">
        <div class="block-title-inner">
            <h4>
                
                    <a href="http://www.mtexpress.com/newsletters/" target="_blank" rel="noopener">
                
                Sign up for The Roundup email
                
                    </a>
                
            </h4>
        </div>
    </div></div><div class=" card-bg-color card-heading-color"><div class="card-panel panel">
            <div class="panel-body"><div class="card email-signup">
        <div class="alert alert-success" role="alert" style="display:none;">
            <p>
                <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
            </p>
        </div>
        <div class="alert alert-danger" role="alert" style="display:none;">
            <p>
                <strong>Error!</strong> There was an error processing your request.
            </p>
        </div>
        <div class="mailinglist-container">
                <form
                    id="mailinglist-form-1210282"
                    class="mailinglist-form form-validate"
                    action="/tncms/mailinglist/signup/"
                    method="post">
                    <input type="hidden" name="submit" value="1">
                    <div class="form-group mailing-lists ">
                        
                            <div class="mailinglist-item priority-10 ">
                                
                                    <input class="mailinglist-id-1210282" type="checkbox" name="list_id[]" value="88a2d7ba-4044-11e4-9d25-bbebbda52923" data-name="News Updates" title="News Updates" style="display:none;" checked>
                                    <h4 class="mailinglist-title">News Updates</h4>
                                    
                                        <p>Would you like to receive our news updates? <strong>Signup today!</strong></p>
                                    
                                
                            </div>
                        
                    </div>

                    

                    <div class="form-group  email-address">
                        <div class="input-group">
                            <span class="input-group-addon"><i class="fas tnt-envelope"></i></span>
                            <input id="email-1210282" class="form-control email" title="email" name="email" type="email" placeholder="Enter email address">
                        </div>
                        <label class="warning-email hide has-error text-danger" for="email">Please enter a valid email address.</label>
                    </div>
                    <div class="row">
                        <div class="mailinglist-btn-container col-sm-6">
                            <button class="mailinglist-save btn btn-primary btn-block">Sign up<i class="fas tnt-spinner tnt-spin" style="display:none; margin-left:5px;"></i></button>
                        </div>
                        <div class="mailinglist-btn-container col-sm-6">
                            <a class="btn btn-default btn-block" href="https://www.mtexpress.com/users/admin/mailinglist/">Manage your lists</a>
                        </div>
                    </div>
                </form>
            </div>
        
    </div></div>
        </div></div></section></div><div id="tncms-block-1210209" class="tncms-block increase-font-size hidden-xs"><section id="block-1210209" class="block emphasis-h4  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1210209 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1210209" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1210209" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#collections-1210209" data-toggle="tab"><i class="far tnt-copy" title="Collections"></i><span class="tab-text"> Collections</span></a>
            </li>
        
        
            <li >
                <a href="#commented-1210209" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1210209" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc border border-solid"><li><a href="/news/blaine_county/rockslide-closes-trail-creek/article_4998cd56-f3e6-11eb-978d-5be066f3401d.html">Rockslide closes Trail Creek</a></li><li><a href="/news/environment/wildfires-threaten-central-idaho-wilderness/article_d9b34ba6-f0b6-11eb-b373-6b24abe4742b.html">Wildfires threaten central Idaho wilderness</a></li><li><a href="/news/coronavirus_covid-19_info/cdc-blaine-county-s-covid-19-spread-is-substantial/article_504c1074-f4b6-11eb-83e6-ab438600a5ee.html">CDC: Blaine County’s COVID-19 spread is ‘substantial’</a></li><li><a href="/news/cops_courts/sun-valley-man-faces-third-dui/article_000cf6ac-f0c2-11eb-a838-97ea710d62e4.html">Sun Valley man faces third DUI</a></li><li><a href="/news/cops_courts/hailey-man-drowns-in-apparent-east-idaho-river-accident/article_e366bcaa-f0b1-11eb-a767-cb02fdcc88d8.html">Hailey man drowns in apparent east Idaho river accident</a></li><li><a href="/news/environment/flash-flood-puts-dent-in-historic-drought/article_86da35fe-f4b5-11eb-b6a2-53633275db95.html">Flash flood puts dent in historic drought</a></li><li><a href="/news/highway-crash-reported-near-smiley-creek/article_00c9230c-f4cf-11eb-900f-8fc0c55d813e.html">Highway crash reported near Smiley Creek</a></li><li><a href="/news/bellevue/bellevue-lot-contaminated-with-lead-arsenic/article_957cc99e-f0a7-11eb-b3d9-f7cd991a4f25.html">Bellevue lot contaminated with lead, arsenic</a></li><li><a href="/news/cops_courts/hailey-woman-sentenced-to-prison-for-theft/article_4a78a89c-f4a7-11eb-b2b6-8f9271564bbd.html">Hailey woman sentenced to prison for theft</a></li><li><a href="/news/coronavirus_covid-19_info/with-covid-19-cases-surging-experts-push-for-vaccinations/article_a437bd7a-f0c2-11eb-81e5-43023174faf0.html">With COVID-19 cases surging, experts push for vaccinations</a></li></ul></div>
        
        
            <div id="images-1210209" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/opinion/cartoon/unvaccinate-this/image_2ecc9244-f0af-11eb-81d0-432560e6c3e8.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Unvaccinate This"
                            class="img-responsive lazyload full default"
                            width="584"
                            height="584"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/ec/2ecc9244-f0af-11eb-81d0-432560e6c3e8/610315c40209f.image.jpg?crop=584%2C584%2C121%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/ec/2ecc9244-f0af-11eb-81d0-432560e6c3e8/610315c40209f.image.jpg?crop=584%2C584%2C121%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/ec/2ecc9244-f0af-11eb-81d0-432560e6c3e8/610315c40209f.image.jpg?crop=584%2C584%2C121%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/ec/2ecc9244-f0af-11eb-81d0-432560e6c3e8/610315c40209f.image.jpg?crop=584%2C584%2C121%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/ec/2ecc9244-f0af-11eb-81d0-432560e6c3e8/610315c40209f.image.jpg?crop=584%2C584%2C121%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/ec/2ecc9244-f0af-11eb-81d0-432560e6c3e8/610315c40209f.image.jpg?crop=584%2C584%2C121%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/2/ec/2ecc9244-f0af-11eb-81d0-432560e6c3e8/610315c40209f.image.jpg?crop=584%2C584%2C121%2C0&resize=584%2C584&order=crop%2Cresize 640w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/st-luke-s-wood-river/image_ef11912c-f0c2-11eb-89a6-fbc206a2a2a4.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="St. Luke’s Wood River"
                            class="img-responsive lazyload full default"
                            width="517"
                            height="517"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/f1/ef11912c-f0c2-11eb-89a6-fbc206a2a2a4/610336e1564f4.image.jpg?crop=517%2C517%2C129%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/f1/ef11912c-f0c2-11eb-89a6-fbc206a2a2a4/610336e1564f4.image.jpg?crop=517%2C517%2C129%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/f1/ef11912c-f0c2-11eb-89a6-fbc206a2a2a4/610336e1564f4.image.jpg?crop=517%2C517%2C129%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/f1/ef11912c-f0c2-11eb-89a6-fbc206a2a2a4/610336e1564f4.image.jpg?crop=517%2C517%2C129%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/f1/ef11912c-f0c2-11eb-89a6-fbc206a2a2a4/610336e1564f4.image.jpg?crop=517%2C517%2C129%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/e/f1/ef11912c-f0c2-11eb-89a6-fbc206a2a2a4/610336e1564f4.image.jpg?crop=517%2C517%2C129%2C0&resize=517%2C517&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/opinion/cartoon/at-the-bottom/image_9b23e730-ef29-11eb-9517-676c74100eed.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="At The Bottom"
                            class="img-responsive lazyload full default"
                            width="540"
                            height="540"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/9/b2/9b23e730-ef29-11eb-9517-676c74100eed/6100880be2795.image.jpg?crop=540%2C540%2C117%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/9/b2/9b23e730-ef29-11eb-9517-676c74100eed/6100880be2795.image.jpg?crop=540%2C540%2C117%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/9/b2/9b23e730-ef29-11eb-9517-676c74100eed/6100880be2795.image.jpg?crop=540%2C540%2C117%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/9/b2/9b23e730-ef29-11eb-9517-676c74100eed/6100880be2795.image.jpg?crop=540%2C540%2C117%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/9/b2/9b23e730-ef29-11eb-9517-676c74100eed/6100880be2795.image.jpg?crop=540%2C540%2C117%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/9/b2/9b23e730-ef29-11eb-9517-676c74100eed/6100880be2795.image.jpg?crop=540%2C540%2C117%2C0&resize=540%2C540&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/sports/local/2020-ketchum-coed-softball-league/image_451b55c0-ef20-11eb-9c54-ff2f79f08d47.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="2020 Ketchum Coed Softball League"
                            class="img-responsive lazyload full default"
                            width="732"
                            height="732"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/51/451b55c0-ef20-11eb-9c54-ff2f79f08d47/6100788205f0f.image.jpg?crop=732%2C732%2C482%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/51/451b55c0-ef20-11eb-9c54-ff2f79f08d47/6100788205f0f.image.jpg?crop=732%2C732%2C482%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/51/451b55c0-ef20-11eb-9c54-ff2f79f08d47/6100788205f0f.image.jpg?crop=732%2C732%2C482%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/51/451b55c0-ef20-11eb-9c54-ff2f79f08d47/6100788205f0f.image.jpg?crop=732%2C732%2C482%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/51/451b55c0-ef20-11eb-9c54-ff2f79f08d47/6100788205f0f.image.jpg?crop=732%2C732%2C482%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/51/451b55c0-ef20-11eb-9c54-ff2f79f08d47/6100788205f0f.image.jpg?crop=732%2C732%2C482%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/51/451b55c0-ef20-11eb-9c54-ff2f79f08d47/6100788205f0f.image.jpg?crop=732%2C732%2C482%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/4/51/451b55c0-ef20-11eb-9c54-ff2f79f08d47/6100788205f0f.image.jpg?crop=732%2C732%2C482%2C0&resize=732%2C732&order=crop%2Cresize 750w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/opinion/cartoon/eviction-epidemic/image_f00baf06-f4ad-11eb-a366-9fad965cceb1.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Eviction Epidemic."
                            class="img-responsive lazyload full default"
                            width="511"
                            height="511"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/00/f00baf06-f4ad-11eb-a366-9fad965cceb1/6109c9bbe0bc8.image.jpg?crop=511%2C511%2C132%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/00/f00baf06-f4ad-11eb-a366-9fad965cceb1/6109c9bbe0bc8.image.jpg?crop=511%2C511%2C132%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/00/f00baf06-f4ad-11eb-a366-9fad965cceb1/6109c9bbe0bc8.image.jpg?crop=511%2C511%2C132%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/00/f00baf06-f4ad-11eb-a366-9fad965cceb1/6109c9bbe0bc8.image.jpg?crop=511%2C511%2C132%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/00/f00baf06-f4ad-11eb-a366-9fad965cceb1/6109c9bbe0bc8.image.jpg?crop=511%2C511%2C132%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/00/f00baf06-f4ad-11eb-a366-9fad965cceb1/6109c9bbe0bc8.image.jpg?crop=511%2C511%2C132%2C0&resize=511%2C511&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/opinion/cartoon/anti-vax/image_f395b65c-e9b4-11eb-8c8e-433cd5295772.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Anti-Vax"
                            class="img-responsive lazyload full default"
                            width="518"
                            height="518"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/39/f395b65c-e9b4-11eb-8c8e-433cd5295772/60f760ecceda9.image.jpg?crop=518%2C518%2C128%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/39/f395b65c-e9b4-11eb-8c8e-433cd5295772/60f760ecceda9.image.jpg?crop=518%2C518%2C128%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/39/f395b65c-e9b4-11eb-8c8e-433cd5295772/60f760ecceda9.image.jpg?crop=518%2C518%2C128%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/39/f395b65c-e9b4-11eb-8c8e-433cd5295772/60f760ecceda9.image.jpg?crop=518%2C518%2C128%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/39/f395b65c-e9b4-11eb-8c8e-433cd5295772/60f760ecceda9.image.jpg?crop=518%2C518%2C128%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/editorial/f/39/f395b65c-e9b4-11eb-8c8e-433cd5295772/60f760ecceda9.image.jpg?crop=518%2C518%2C128%2C0&resize=518%2C518&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        
        
        
            <div id="collections-1210209" class="tab-pane tab-pane-collections fade in ">
                <h4 class="tab-content-heading">Collections</h4><ul class="tab-content-list bullet-disc border border-solid"><li><a href="/gallery/summer-so-far/collection_694860f8-e3f1-11eb-a8eb-8fd53243b7c1.html">Summer So Far</a></li><li><a href="/gallery/fourth-of-july-parade/collection_8295d8c4-de79-11eb-8732-87eb97e06c79.html">Fourth of July Parade</a></li><li><a href="/gallery/days-of-the-old-west-rodeo/collection_94fa33b2-de7d-11eb-a5f0-a3b92a89cc6f.html">Days of the Old West Rodeo</a></li></ul></div>
        
        
            <div id="commented-1210209" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-disc border border-solid"><li><a href="/opinion/letters_to_editor/don-t-let-ketchum-become-jackson/article_13a9de76-e98a-11eb-99fd-e7b48d385c4d.html">Don’t let Ketchum become Jackson</a> (17)</li><li><a href="/news/hailey/as-campground-dispute-continues-hailey-eyes-new-residential-growth/article_9f515d0a-e5c5-11eb-a836-dfd99436b4b6.html">As campground dispute continues, Hailey eyes new residential growth</a> (17)</li><li><a href="/opinion/letters_to_editor/idaho-laws-limit-housing-options/article_90dbc4e2-deb1-11eb-b140-9f697f7b77d6.html">Idaho laws limit housing options</a> (16)</li><li><a href="/news/blaine_county/for-cities-housing-crunch-hits-home/article_4bf0ac0a-f4b7-11eb-a205-cbf248c6489c.html">For cities, housing crunch hits home</a> (14)</li><li><a href="/news/ketchum/ketchum-takes-aim-at-housing-crisis/article_8cc93c90-e041-11eb-b505-0b716401b202.html">Ketchum takes aim at housing crisis</a> (14)</li><li><a href="/news/business/what-s-going-on-with-the-labor-market/article_42e9f126-e435-11eb-a41b-df36bb7cb220.html">What’s going on with the labor market?</a> (13)</li><li><a href="/opinion/guest_opinions/st-luke-s-needs-your-help-with-housing/article_227b8b48-deae-11eb-af25-67b6ba84857b.html">St. Luke’s needs your help with housing</a> (11)</li><li><a href="/opinion/guest_opinions/forest-health-plans-offer-false-hope/article_0a4689c4-f4a7-11eb-9576-57af100b36bd.html">‘Forest health’ plans offer false hope</a> (10)</li><li><a href="/news/sun_valley/summer-camp-for-moguls-returns-to-sun-valley/article_d497bafa-deb7-11eb-85aa-876ff0e18177.html">‘Summer camp’ for moguls returns to Sun Valley</a> (10)</li><li><a href="/news/coronavirus_covid-19_info/bellevue-eldercare-facility-under-lockdown-after-staff-tests-positive-for-covid/article_00b0ffac-ee67-11eb-b95b-3fe621f92274.html">Bellevue eldercare facility under lockdown after staff tests positive for COVID</a> (9)</li><li><a href="/news/coronavirus_covid-19_info/st-luke-s-requiring-staff-to-get-covid-19-vaccine/article_9266e960-e34b-11eb-9fc8-4302bde27b53.html">St. Luke’s requiring staff to get COVID-19 vaccine</a> (9)</li><li><a href="/opinion/letters_to_editor/ketchum-should-take-its-own-advice/article_082eb0bc-e426-11eb-91ed-7384c22c97a1.html">Ketchum should take its own advice</a> (8)</li><li><a href="/opinion/editorials/hot-enough-scared-yet/article_8ae35e14-e5b5-11eb-aeec-032a6844aa33.html">Hot enough? Scared yet?</a> (7)</li><li><a href="/opinion/editorials/immigration-should-be-fixed-not-resisted/article_954c7c46-dead-11eb-bc45-cb4b2a3f5764.html">Immigration should be fixed, not resisted</a> (7)</li><li><a href="/news/hailey/hailey-residents-voice-ideas-concerns-at-town-square-workshop/article_cc98b564-eb48-11eb-af6a-eba946093e66.html">Hailey residents voice ideas–concerns–at town square workshop</a> (7)</li><li><a href="/news/ketchum/revised-bluebird-village-plans-head-to-p-z/article_48646696-ef33-11eb-8d0c-cfe67e9f7dd5.html">Revised Bluebird Village plans head to P&Z</a> (6)</li><li><a href="/news/coronavirus_covid-19_info/cdc-blaine-county-s-covid-19-spread-is-substantial/article_504c1074-f4b6-11eb-83e6-ab438600a5ee.html">CDC: Blaine County’s COVID-19 spread is ‘substantial’</a> (6)</li><li><a href="/news/hailey/hailey-adopts-tentative-budget-of-16-2m/article_974cdb64-ef2c-11eb-9177-8784cb8ec55e.html">Hailey adopts tentative budget of $16.2M</a> (6)</li><li><a href="/news/blaine_county/itd-moving-forward-on-project-south-of-ketchum/article_a339c3a8-deae-11eb-85a5-5ff601bf7a3f.html">ITD moving forward on project south of Ketchum</a> (5)</li><li><a href="/news/hailey/hailey-to-hold-town-square-workshop-tuesday/article_b40a9562-e5b7-11eb-a5c9-ff9ecec97943.html">Hailey to hold Town Square workshop Tuesday</a> (5)</li><li><a href="/opinion/letters_to_editor/you-can-t-get-something-for-nothing/article_7dbf78e8-e426-11eb-8ca4-373b752bf42f.html">You can’t get something for nothing</a> (4)</li><li><a href="/news/hailey/hailey-eyes-expanded-2022-budget-new-staff-positions/article_a7ab3a90-deb6-11eb-b5e2-0352d6ec3cd8.html">Hailey eyes expanded 2022 budget,  new staff positions</a> (4)</li><li><a href="/news/heat-wave-to-hit-south-valley-on-monday/article_b46bbadc-ee53-11eb-92dc-ff3278611be7.html">Heat wave to hit south valley on Monday</a> (4)</li><li><a href="/news/transportation/as-allen-co-descends-private-flights-surpass-airport-capacity/article_e82ecc3c-e03f-11eb-8e07-cba289b3c318.html">As Allen & Co. descends, private flights surpass airport capacity</a> (4)</li><li><a href="/news/coronavirus_covid-19_info/covid-19-delta-variant-confirmed-in-region/article_0595d4da-e5c4-11eb-b323-4f91df5d8ef5.html">COVID-19 Delta variant confirmed in region</a> (3)</li><li><a href="/opinion/editorials/new-regulations-should-mean-more-freedom/article_258c82cc-e428-11eb-bb97-ffeec948b03a.html">New regulations should mean more freedom</a> (3)</li><li><a href="/news/business/for-allen-co-a-return-to-normal-almost/article_2737a1ea-e434-11eb-a663-6705c75e766f.html">For Allen & Co., a return to normal—almost</a> (3)</li><li><a href="/news/environment/baldy-gets-a-trim-to-improve-forest-health/article_2aee6cae-eb48-11eb-83a9-5fff1def2ba2.html">Baldy gets a trim to improve forest health</a> (3)</li><li><a href="/news/ketchum/ketchum-firefighters-union-ink-3-year-deal/article_5ee270c6-eb45-11eb-942e-8bca3b2b7480.html">Ketchum, firefighters’ union ink 3-year deal</a> (3)</li><li><a href="/news/ketchum/ketchum-looks-at-sister-resort-for-housing-answers/article_62046e6e-e9b3-11eb-b5c0-ef46940bd5a5.html">Ketchum looks at sister resort for housing answers</a> (3)</li><li><a href="/opinion/letters_to_editor/save-money-and-save-our-valley/article_6a1fe83c-e989-11eb-93ae-b38165baf68f.html">Save money and save our valley!</a> (3)</li><li><a href="/opinion/editorials/fix-stuff-then-go-for-more/article_730a5df2-f4a5-11eb-a3f0-d79112f87af2.html">Fix stuff, then go for more</a> (3)</li><li><a href="/opinion/letters_to_editor/kindness-compassion-and-hospitality-still-thrive-in-ketchum-sun-valley/article_b7473ef8-e989-11eb-967d-2b2da0f16a8d.html">Kindness, compassion and hospitality still thrive in Ketchum/Sun Valley</a> (3)</li><li><a href="/opinion/editorials/paying-for-the-hanging/article_d0fd12a8-e427-11eb-9b96-13e96637b5d1.html">Paying for the hanging</a> (3)</li><li><a href="/opinion/guest_opinions/our-economy-is-poised-for-a-comeback-if-we-only-let-it/article_fe2ca88c-ef27-11eb-acdf-7be595161add.html">Our economy is poised for a comeback—if we only let it</a> (3)</li><li><a href="/news/environment/drivers-asked-to-watch-for-wild-horses/article_19f87050-deac-11eb-b4c9-637fec4970be.html">Drivers asked to watch for wild horses</a> (2)</li><li><a href="/news/blaine_county/dog-and-cat-population-has-skyrocketed-at-mountain-humane/article_23a94a7e-e5c4-11eb-89f9-e79fea7c053e.html">Dog and cat population has ‘skyrocketed’ at Mountain Humane</a> (2)</li><li><a href="/wood_river_journal/community/breaking-moose-f-g-relocates-pair-from-woodside/article_45724714-e402-11eb-9e74-4b6ce3ba45bf.html">Breaking 'Moose': F&G relocates pair from Woodside</a> (2)</li><li><a href="/wood_river_journal/community/picabo-desert-farm-bids-farewell/article_52843df8-eb47-11eb-bc05-e7e40ac6a426.html">Picabo Desert Farm bids farewell</a> (2)</li><li><a href="/news/wildfire-spotted-17-miles-northeast-of-hailey/article_67848df4-e0d2-11eb-a980-cf859c64d202.html">Wildfire spotted 17 miles northeast of Hailey</a> (2)</li><li><a href="/news/delta-variant-discovered-in-twin-falls-county/article_86403fce-e594-11eb-8f24-43f5e7816ce5.html">Delta variant discovered in Twin Falls County</a> (2)</li><li><a href="/news/blaine_county/wood-river-land-trust-secures-conservation-area-through-transfer-of-development-rights/article_88d6588e-e41a-11eb-9f18-8f0cd4ed7da9.html">Wood River Land Trust secures conservation area through transfer of development rights</a> (2)</li><li><a href="/opinion/editorials/stop-the-stabbing-of-idaho-s-heart/article_8a7a7260-e028-11eb-bd11-43d2372d9072.html">Stop the stabbing of Idaho’s heart</a> (2)</li><li><a href="/news/coronavirus_covid-19_info/with-covid-19-cases-surging-experts-push-for-vaccinations/article_a437bd7a-f0c2-11eb-81e5-43023174faf0.html">With COVID-19 cases surging, experts push for vaccinations</a> (2)</li><li><a href="/news/bellevue/land-trust-secures-111k-for-bellevue-river-restoration/article_a653daa0-f4ad-11eb-9b09-cbd5b9b6444b.html">Land Trust secures $111K for Bellevue river restoration</a> (2)</li><li><a href="/news/environment/amid-weekend-heat-wave-crews-contain-2-fires-in-the-sawtooths/article_abcc66e0-e42d-11eb-97e9-9bd5fcafc19b.html">Amid weekend heat wave, crews contain 2 fires in the Sawtooths</a> (2)</li><li><a href="/news/hailey/hailey-rezone-clears-path-for-housing-hardware-store/article_b4e496cc-deb9-11eb-91b1-a31c40dc1e01.html">Hailey rezone clears path for housing, hardware store</a> (2)</li><li><a href="/news/search-continues-for-local-hiker-missing-in-montana/article_ba687642-e010-11eb-bf5b-830e4793c46b.html">Search continues for local hiker missing in Montana</a> (2)</li><li><a href="/opinion/guest_opinions/army-general-shoots-down-critical-race-theory-hysteria-amen/article_c86f53fa-e029-11eb-9514-af903433a80f.html">Army general shoots down ‘critical race theory’ hysteria. Amen.</a> (2)</li><li><a href="/news/ketchum/ketchum-names-john-and-diane-peavey-wagon-days-grand-marshals/article_cf76357c-f0b6-11eb-9c9a-1fa9970d1cea.html">Ketchum names John and Diane Peavey Wagon Days grand marshals</a> (2)</li><li><a href="/opinion/letters_to_editor/consider-a-recirculation-pump/article_e58d8100-e425-11eb-a0fc-33462aad87ca.html">Consider a recirculation pump</a> (2)</li><li><a href="/opinion/editorials/no-water-no-food/article_ebc88948-dead-11eb-9875-7b3a54dd91ca.html">No water, no food</a> (2)</li><li><a href="/opinion/letters_to_editor/we-must-adapt-to-a-dry-climate/article_f682afea-f49b-11eb-851b-cfdcef7fd16e.html">We must adapt to a dry climate</a> (2)</li><li><a href="/news/coronavirus_covid-19_info/eviction-ban-set-to-end-saturday/article_02ccb58a-f0c2-11eb-9ea5-17b59ada1a1d.html">Eviction ban set to end Saturday</a> (1)</li><li><a href="/opinion/editorials/when-i-m-sorry-isn-t-enough/article_0f9c5952-f0b6-11eb-93ee-6bf3a98bc972.html">When ‘I’m sorry’ isn’t enough</a> (1)</li><li><a href="/sports/local/baseball-the-beautiful/article_11f0b1f4-e41c-11eb-b67c-87123c60a314.html">Baseball the beautiful</a> (1)</li><li><a href="/news/appeal-set-for-sawtooth-valley-airstrip/article_1579de36-eb0b-11eb-8c0c-33dd595fdbf0.html">Appeal set for Sawtooth Valley airstrip</a> (1)</li><li><a href="/news/bellevue/bellevue-p-z-to-consider-new-zone-for-apartment-buildings/article_1899a5f8-e677-11eb-8db2-a374583f4888.html">Bellevue P&Z to consider new zone for apartment buildings</a> (1)</li><li><a href="/news/coronavirus_covid-19_info/blaine-county-s-covid-19-risk-level-increases/article_19195b52-f3c1-11eb-86da-cbec706e7335.html">Blaine County’s COVID-19 risk level increases</a> (1)</li><li><a href="/news/ketchum/ketchum-makes-changes-to-2022-budget-reschedules-review/article_2847749e-f0b8-11eb-b97d-eb487b6b3a22.html">Ketchum makes changes to 2022 budget, reschedules review</a> (1)</li><li><a href="/opinion/guest_opinions/idaho-schools-need-a-boost/article_3b885304-e427-11eb-acaa-afd6991d41fe.html">Idaho schools need a boost</a> (1)</li><li><a href="/news/blaine_county/rockslide-closes-trail-creek/article_4998cd56-f3e6-11eb-978d-5be066f3401d.html">Rockslide closes Trail Creek</a> (1)</li><li><a href="/opinion/guest_opinions/texas-house-democrats-retreat-is-continued-march-for-rights/article_5e8108cc-e9a1-11eb-a749-e3277abb37b7.html">Texas House Democrats’ retreat is continued march for rights</a> (1)</li><li><a href="/news/bellevue/bellevue-leaders-debate-spending-priorities/article_62f68bd8-e5ba-11eb-9bd2-77d8cb471673.html">Bellevue leaders debate spending priorities</a> (1)</li><li><a href="/news/bellevue/bellevue-p-z-shows-support-for-high-density-housing-downtown/article_6be7e33a-e99e-11eb-a48f-9f1fc1fe8853.html">Bellevue P&Z shows support for high-density housing downtown</a> (1)</li><li><a href="/news/bellevue/bellevue-s-draft-budget-is-53-larger-than-last-year/article_761a4afc-ef19-11eb-8b29-cf268b6d8cfa.html">Bellevue’s draft budget is 53% larger than last year</a> (1)</li><li><a href="/news/coronavirus_covid-19_info/bcsd-health-district-schedule-vaccination-clinics-for-students/article_7da8b380-f48c-11eb-b12e-bf94278280aa.html">BCSD, Health District schedule vaccination clinics for students</a> (1)</li><li><a href="/news/blaine_county/judicial-review-of-proposed-transmission-line-continues/article_84baeff2-ef33-11eb-9904-7be5b43fa6f0.html">Judicial review of proposed transmission line continues</a> (1)</li><li><a href="/wood_river_journal/community/may-the-force-be-with/article_862ebd3c-ef33-11eb-b371-3b096b30d466.html">May the ‘force’ be with...</a> (1)</li><li><a href="/opinion/letters_to_editor/save-water-save-ourselves/article_8638720e-f49d-11eb-81f5-231312e0da09.html">Save water, save ourselves</a> (1)</li><li><a href="/news/coronavirus_covid-19_info/county-s-covid-19-cases-increase-slightly/article_8a4a4674-deb8-11eb-a131-db7ce132f343.html">County’s COVID-19 cases increase slightly</a> (1)</li><li><a href="/arts_and_events/events/sawtooth-forum-starts-friday/article_8ce5503e-deb0-11eb-b9fe-f3644f034ff6.html">Sawtooth Forum starts Friday</a> (1)</li><li><a href="/news/environment/groups-prepare-to-sue-idaho-over-new-wolf-hunting-laws/article_8fa8efdc-e9b0-11eb-b5cb-b3d469c4c72f.html">Groups prepare to sue Idaho over new wolf hunting laws</a> (1)</li><li><a href="/news/business/visit-sun-valley-hailey-chamber-get-tourism-grants/article_91d81a3c-f4a8-11eb-bc29-37b3e85f61d8.html">Visit Sun Valley, Hailey Chamber get tourism grants</a> (1)</li><li><a href="/news/bellevue/bellevue-lot-contaminated-with-lead-arsenic/article_957cc99e-f0a7-11eb-b3d9-f7cd991a4f25.html">Bellevue lot contaminated with lead, arsenic</a> (1)</li><li><a href="/news/hailey-p-z-to-consider-new-townhome-developments/article_997c2182-e8e8-11eb-9e12-ef4fdef260ff.html">Hailey P&Z to consider new townhome developments</a> (1)</li><li><a href="/wood_river_journal/community/the-gem-state-or-the-new-golden-state/article_a3edcbca-dea2-11eb-aaa9-730d6a0d7e7a.html">The Gem State, Or The New Golden State?</a> (1)</li><li><a href="/news/business/ketchum-continues-strong-lot-collections/article_a8f882cc-ef32-11eb-bb4e-eb804725a59e.html">Ketchum continues strong LOT collections</a> (1)</li><li><a href="/arts_and_events/events/in-ketchum-drones-to-create-a-spectacle-of-lights/article_acd0dcfc-deb4-11eb-b173-cf585ada1a42.html">In Ketchum, drones to create a spectacle of lights</a> (1)</li><li><a href="/opinion/letters_to_editor/hailey-town-square-is-the-wrong-plan/article_b4496164-ef28-11eb-a704-3b58a3a3abc8.html">Hailey town square is the wrong plan</a> (1)</li><li><a href="/opinion/editorials/in-any-language/article_c36bb490-ef27-11eb-8f4a-2365f9c3d375.html">In any language</a> (1)</li><li><a href="/wood_river_journal/features/snapshots/article_c81a0628-e02b-11eb-8bde-c7900284a7f3.html">Snapshots</a> (1)</li><li><a href="/news/ketchum/ketchum-to-study-potential-changes-to-main-street-warm-springs-road/article_ca5c082a-f4b5-11eb-9991-93dbf8e82e9e.html">Ketchum to study potential changes to Main Street, Warm Springs Road</a> (1)</li><li><a href="/news/business/all-in-for-allen-co/article_cbee9ffe-e042-11eb-b6ab-57194f06a5a9.html">All In For Allen & Co.</a> (1)</li><li><a href="/sports/local/local-ducks-unlimited-shooters-all-smiles-in-bellevue/article_e09c09f8-e418-11eb-9076-27507cd818a8.html">Local Ducks Unlimited shooters all smiles in Bellevue</a> (1)</li><li><a href="/news/hailey/helping-honey-bear-firefighters-rescue-dog-on-della-mountain/article_e8b025ea-deb7-11eb-8b50-fff2cc736881.html">Helping Honey Bear:  Firefighters rescue dog on Della Mountain</a> (1)</li><li><a href="/news/environment/mud-lick-fire-nears-containment/article_eb89aef0-f4ae-11eb-8614-e31cf6c5ec43.html">Mud Lick Fire nears containment</a> (1)</li><li><a href="/news/hailey/hailey-officials-report-smooth-sailing-over-holiday-weekend/article_f5d21916-deb9-11eb-84ba-d3fa5668073e.html">Hailey officials report smooth sailing over holiday weekend</a> (1)</li></ul></div>
        
    </div>
</div></section></div><div id="tncms-block-1210172" class="tncms-block"><section id="block-1210172" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1210172 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="https://www.mtexpress.com/special/page-s01/page_4b621d70-5a74-529e-bb5b-c7b85b073442.html" target="_blank" rel="noopener">
                
                Latest Special Section
                
                    </a>
                
            </h4>
        </div>
    </div></div><div class="card-grid   card-img-lg card-compact">
        
        
            <div class=" ">
        
        <div class="  last-grid-item">
                 
                                
                    <article id="card-summary-1210172-3785f9f2-8ba2-5fe6-9cc3-cd3e2aa6caf8" class="tnt-asset-type-edition clearfix card summary has-image image-top inherit letterbox-style-default  tnt-section-special">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-3785f9f2-8ba2-5fe6-9cc3-cd3e2aa6caf8 media-preview edition-asset" data-aspect="original"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/special/fourth-of-july/edition_3785f9f2-8ba2-5fe6-9cc3-cd3e2aa6caf8.html" class="tnt-asset-link" >                
                
                    <div class="asset-icon"><i class="far tnt-newspaper tnt-fw" title="e-Edition"></i></div>
                
                
                
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Fourth of July"
                    class="img-responsive lazyload  letterbox default"
                    width="775"
                    height="1198"
                    data-src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/assets/v3/eedition/3/78/3785f9f2-8ba2-5fe6-9cc3-cd3e2aa6caf8/60da077fa8509.preview-775.jpg?resize=775%2C1198" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/special/fourth-of-july/edition_3785f9f2-8ba2-5fe6-9cc3-cd3e2aa6caf8.html" class="tnt-asset-link">
        

        
            Fourth of July</a></h3></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
            
        
        
        
        
        </div>
        </div></section></div><div id="tncms-block-1402605" class="tncms-block"><iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2FMountainExpress%2F&amp;tabs=timeline&amp;width=340&amp;height=500&amp;small_header=false&amp;adapt_container_width=true&amp;hide_cover=false&amp;show_facepile=true&amp;appId" width="340" height="500" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowtransparency="true"></iframe></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/cops_courts","refresh":true}' style="display:none;"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1210220" class="tncms-block"><section id="block-1210220" class="block emphasis-h4    tnt-has-block-bg" ><div class="clearfix">
    
    <div class="block-title title-1210220 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/site/forms/online_services/submit_news">
                
                Submit Your News
                
                    </a>
                
            </h4>
        </div>
    </div></div><article class="card promo media"><div class="media-body"><p>We're always interested in hearing about news in our community. Let us know what's going on!</p><a href="/site/forms/online_services/submit_news">
                <button type="button" class="btn btn-primary  ">Submit News Item</button>
            </a></div>
</article><span class="clearfix"></span></section></div><div id="tncms-block-1210226" class="tncms-block"><section id="block-1210226" class="block emphasis-h4    tnt-has-block-bg" ><div class="clearfix">
    
    <div class="block-title title-1210226 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/place_an_ad">
                
                Want to Run an Ad?
                
                    </a>
                
            </h4>
        </div>
    </div></div><article class="card promo media"><div class="media-body"><p>If you're interested in advertising with us, fill out this form to get more information.</p><a href="https://www.mtexpress.com/site/forms/online_services/submit_news/request_advertising_information/">
                <button type="button" class="btn btn-primary  ">Info Request Form</button>
            </a></div>
</article><span class="clearfix"></span></section></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article><template class="hidden" id="infinity-asset-top">  
            <div id="tncms-region-infinity_asset_top" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-first">
            <div id="tncms-region-infinity_asset_after_first" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-third">
            <div id="tncms-region-infinity_asset_after_third" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-fifth">
            <div id="tncms-region-infinity_asset_after_fifth" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-eighth">
            <div id="tncms-region-infinity_asset_after_eighth" class="tncms-region "></div>
        </template>

    <div id="infinite-container" class="infinity-summary-container hidden-print">
        <div id="infinite-more" data-next-url="https://www.mtexpress.com/tncms/search/mlt/?origin=68a5078e-f56f-11eb-abc5-03a73030860a&app=editorial&inline=infinity&type=article%2Ccollection%2Cvideo%2Cyoutube">
            <i class="fas tnt-spinner tnt-pulse"></i>
        </div>
    </div>

    <script>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</script>
    
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1210119" class="tncms-block">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1210120" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1210194" class="tncms-block"><section id="block-1210194" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1210194 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-news"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-wood-river-journal"  href="/wood_river_journal/"  tabindex="0">
                    <span class="nav-label">Wood River Journal</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-opinion"  href="/opinion/"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-arts-events"  href="/arts_and_events/"  tabindex="0">
                    <span class="nav-label">Arts & Events</span>
                </a></li><li>
                <a class="nav-link   tnt-section-calendar"  href="/calendar"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries/"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="http://classified.mtexpress.com/showads"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link   tnt-section-area-guides"  href="/area_guides/"  tabindex="0">
                    <span class="nav-label">Area Guides</span>
                </a></li><li>
                <a class="nav-link   tnt-section-real-estate-guide"  href="http://www.sunvalley-realestate.com/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Real Estate Guide</span>
                </a></li><li>
                <a class="nav-link   tnt-section-special-sections"  href="/special/"  tabindex="0">
                    <span class="nav-label">Special Sections</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather/"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1210195" class="tncms-block"><section id="block-1210195" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1210195 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-advertise"  href="https://www.mtexpress.com/site/forms/online_services/submit_news/request_advertising_information/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Advertise</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-personnel"  href="/site/personnel.html"  tabindex="0">
                    <span class="nav-label">Personnel</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscription-services"  href="/site/services"  tabindex="0">
                    <span class="nav-label">Subscription Services</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submission-forms"  href="/site/forms"  tabindex="0">
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link   tnt-section-rack-locations"  href="/site/rack_locations.html"  tabindex="0">
                    <span class="nav-label">Rack Locations</span>
                </a></li><li>
                <a class="nav-link   tnt-section-email-alerts"  href="/newsletters"  tabindex="0">
                    <span class="nav-label">Email Alerts</span>
                </a></li><li>
                <a class="nav-link   tnt-section-employment"  href="https://www.mtexpress.com/site/employment.html"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Employment</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1210208" class="tncms-block padding-bottom"><section id="block-1210208" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/89adca7a-ef9d-11e5-b176-438b3732dd45.png?resize=150%2C24 150w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/89adca7a-ef9d-11e5-b176-438b3732dd45.png?resize=200%2C31 200w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/89adca7a-ef9d-11e5-b176-438b3732dd45.png?resize=225%2C35 225w, https://bloximages.chicago2.vip.townnews.com/mtexpress.com/content/tncms/custom/image/89adca7a-ef9d-11e5-b176-438b3732dd45.png 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="300"
                height="47"
                alt=""></a></div></section></div><div id="tncms-block-1210200" class="tncms-block"><section id="block-1210200" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1210200 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>mtexpress.com</strong><br>
    PO Box 1013<br>
    Ketchum, ID 83340
    <br>
    
        <strong>Phone:</strong> 208-726-8060<br>
        <strong>Email:</strong> <a href="mailto:publisher@mtexpress.com">publisher@mtexpress.com</a><br>
    
</address></section></div><div id="tncms-block-1372263" class="tncms-block"><br>Newsroom: <a href="mailto:news@mtexpress.com">news@mtexpress.com</a>
<br>Subscription Dept: <a href="mailto:adsales@mtexpress.com">subs@mtexpress.com</a>
<br>Advertising Dept: <a href="mailto:adsales@mtexpress.com">adsales@mtexpress.com</a>
<br>Classified Dept: <a href="mailto:classifieds@mtexpress.com">classifieds@mtexpress.com</a>
<br><br></div><div id="tncms-block-1210217" class="tncms-block padding-bottom"><div class="follow-links-1210217 default">
    
    <section id="block-1210217" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1210217 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/MountainExpress/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href=" https://twitter.com/IdahoMtExpress" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.mtexpress.com",
  "sameAs" : ["https://www.facebook.com/MountainExpress/"," https://twitter.com/IdahoMtExpress"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
<script type="text/javascript" language="javascript"> 
$(document).ready(function() 
{ 
$('img').bind('contextmenu', function(e){ 
return false; 
}).delay(6000); 
}); 
</script>

            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1210201" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1210201"><div class="col-md-7"><small>&copy; Copyright 2021 <a href="/">Idaho Mountain Express</a>, PO Box 1013 Ketchum, ID</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    <div id="sticky-anchor"><div id="tncms-region-page_sticky_anchor" class="tncms-region hidden-print collapse in"><div id="tncms-block-1836935" class="tncms-block">
        <div id="blox-ad-position-sticky-frontpage-ad1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"sticky-frontpage-ad","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/mtexpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/news\/cops_courts","refresh":false}' style="display:none;"></div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("68a5078e-f56f-11eb-abc5-03a73030860a")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.7e2e0b303de1e8619d0517c270f18503.js"></script>
<script>/*<![CDATA[*/ 
            dataLayer.push({'tncms.asset.sections':["cops_courts"]});
         /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/metering/resources/scripts/tnt.metering.c1fd4b9015c14b57a58acdbc3ee4daca.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                                    $('#weather_zip_toggle_1210232').click(function(e){
                                        $('#weather-1210232 .zip-update-form').toggle('fast');
                                        return false; 
                                    });
                                }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/editorial/resources/scripts/tnt.poll.aa4a56a35da582e986ed8bbce2004ea4.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/maillist_signup.deacc71a82fe583ccc361b42498ff614.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/mtexpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.54d9f15b0d238de6bb20ec82ed8307ac.js"></script>
<script>/*<![CDATA[*/ __tnt.regions.stickyAnchor.init(); /*]]>*/</script></body>
</html>